Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97766 - nvidia freeze on resource conflict with kernel >2.6.9
Summary: nvidia freeze on resource conflict with kernel >2.6.9
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High critical (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
: 100128 128921 (view as bug list)
Depends on:
Reported: 2005-07-02 14:36 UTC by Pavel Vondricka
Modified: 2006-04-11 19:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Vondricka 2005-07-02 14:36:29 UTC
X freezes with nvidia original driver after 5-30 seconds of USB mouse movement  
(not touchpad movement!) when used on kernel >2.6.9. I tried differrent  
versions of gentoo-sources up to 2.6.12-r3 and nvidia-kernel 1.0-6629 and  
7664. There is no problem when the USB mouse is plugged into another USB port  
(on another USB bus!), but it freezed later as well - maybe a conflict with  
another device (eg. the sk-98/skge network-driver). See details.  

Reproducible: Always
Steps to Reproduce:
1.Boot kernel >2.6.9    
2. start X-server with nvidia driver   
3. move a USB mouse (connected on a bus sharing the same IRQ with VGA) for 
Actual Results:  
The graphics and keyboard freezes, the cursor can be moved further with PS/2 
touchpad and the system can be switched off with the power button (acpid 
background shutdown). 

Expected Results:  

The computer is an Asus L5842DF notebook with Athlon64, Nforce3 chipset and     
GeForce FX Go5650.     
The /proc/interrupts:     
  0:    1076260          XT-PIC  timer     
  1:       3041          XT-PIC  i8042     
  2:          0          XT-PIC  cascade     
  5:       2628          XT-PIC  ohci_hcd, NVidia nForce3     
  9:        605          XT-PIC  acpi, yenta     
 10:          4          XT-PIC  ehci_hcd, NVidia nForce3 Modem     
 11:      76279          XT-PIC  SysKonnect SK-98xx, ohci_hcd, yenta,     
ohci1394, nvidia     
 12:       3470          XT-PIC  i8042     
 14:       6808          XT-PIC  ide0     
 15:       9164          XT-PIC  ide1     
NMI:         80     
LOC:    1076009     
ERR:          4     
MIS:          0     
The listing on 2.6.12 (unlike this one from a 2.6.9 kernel) shows additional 
bus numbers for particular ehci/ohci_hcd IRQs - with IRQ 11 there is bus no. 1 
and the "mouse problem" rises only when the mouse is connected to this bus no. 
I found no regular relevant reports in system log (some iiregular "NVRM:   
Xid:..." messages). I can send the "lspci -v" or anything else    
if required.
Comment 1 Pavel Vondricka 2005-07-29 04:21:25 UTC
The "noapic" kernel parameter solved the problem. So it seems to be an APIC 
problem in kernels >2.6.9. 
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2005-09-10 08:56:39 UTC
This is a problem with sk98xx-based network adaptors (a quick Google search
shows a tonne of people with sk98xx cards using noapic).  I don't think there's
a fix for this other than adding 'noapic' and sometimes 'noacpi'/'acpi=off' to
the boot options.

Kernel team, do you know anything more about this?
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2005-09-10 10:15:00 UTC
You should see if skge exhibits the same problem. We can get support for that
Comment 4 Pavel Vondricka 2005-09-29 10:09:39 UTC
If I remember well, I tried both skge and sk-98 driver. 
I didn't notice that my older kernel (2.6.9) didn't actually use the APIC (asi 
the listing above shows), so the problem has nothing to do with krnel versions 
but only with APIC in general.... or maybe the driver, as you say... 
Comment 5 eipi 2005-10-19 05:42:47 UTC
I have  exactly the same problem. But I am not using the nvidia driver. 
Instead, I am using tge vesa driver. The USB mouse stops running after some 
music is played. I thought it was an alsa problem, but it may be an APIC one. 
Here is my emerge info: 
Portage (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 
2.6.12-gentoo-r10 x86_64) 
System uname: 2.6.12-gentoo-r10 x86_64 AMD Athlon(tm) 64 Processor 3200+ 
Gentoo Base System version 1.6.13 
ccache version 2.3 [disabled] 
dev-lang/python:     2.3.5-r2, 2.4.1-r1, 2.4.2 
sys-apps/sandbox:    1.2.12 
sys-devel/autoconf:  2.13, 2.59-r6 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1 
sys-devel/libtool:   1.5.18-r1 
virtual/os-headers:  2.6.11-r2 
CFLAGS="-march=athlon64 -Os -pipe" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon64 -Os -pipe" 
FEATURES="autoconfig distlocks sandbox sfperms strict" 
LINGUAS="en fr" 
USE="amd64 X Xaw3d a52 aac aalib acpi alsa apm arts audiofile avi 
bash-completion berkdb bitmap-fonts cdparanoia cdr crypt cups curl dga dio 
directfb dv dvd dvdr dvdread eds emacs emboss encode faad fam fbcon ffmpeg flac 
foomaticdb fortran gd gdbm ggi gif glut gphoto2 gstreamer gtk gtk2 gtkhtml hal 
ieee1394 imagemagick imlib innodb jack java jpeg junit kde kdeenablefinal lcms 
libcaca libg++ libwww lirc lm_sensors lzo lzw lzw-tiff mad matroska mikmod mng 
motif mp3 mpeg mule mysql nas ncurses neXt nls nptl nptlonly nsplugin nvidia 
odbc ogg oggvorbis opengl pam pcmcia pdflib perl plotutils png portaudio 
postgres ppds python qt quicktime rdesktop readline real ruby samba scanner sdl 
slang sndfile speex spell sqlite ssl svg tcltk tcpd tetex theora threads tiff 
transcode truetype truetype-fonts type1-fonts unicode usb userlocales vorbis 
wmf wxwindows xface xine xml xml2 xmms xosd xpm xprint xv xvid zlib 
video_cards_nvidia linguas_en linguas_fr userland_GNU kernel_linux elibc_glibc" 
Comment 6 Jeremy Huddleston (RETIRED) gentoo-dev 2005-10-28 00:35:24 UTC
*** Bug 100128 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-04-05 08:22:24 UTC
*** Bug 128921 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Huddleston (RETIRED) gentoo-dev 2006-04-06 11:29:07 UTC
This has nothing to do with nvidia drivers as the behavior appears with vesa drivers as well... Have you guys experienced the problem using the skge driver or just the sk98?
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2006-04-11 19:25:04 UTC
Closing this bug. We can't address issues with the closed-source nvidia driver, and if this really is reproducable with open-source drivers then you should open an entirely new bug.