Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97545 - vlc-0.7.2 doesn't compile with current ffmpeg
Summary: vlc-0.7.2 doesn't compile with current ffmpeg
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-30 14:06 UTC by Jan Kunzmann
Modified: 2005-07-01 15:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kunzmann 2005-06-30 14:06:49 UTC
vlc-0.7.2 doesn't compile with ffmpeg-0.4.9_p20050226-r3 and above (because a   
function called av_seek_frame has 4 parameters in libavformat/avformat.h).  
  
Works perfectly when using ffmpeg-0.4.9_pre1-r1 (which provides the  
av_seek_frame with 3 parameters as vlc expect). 
 
Please fix in ebuild. 

Reproducible: Always
Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-06-30 14:38:33 UTC

*** This bug has been marked as a duplicate of 90474 ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-06-30 14:39:24 UTC
Use vlc-0.8.1-r1
Comment 3 Jan Kunzmann 2005-07-01 14:51:19 UTC
vlc-0.7.2 seems to be the last version working as streaming server for the  
current version of Neutrino (Linux on DVB receiver dbox2). Using >=vlc-0.8 is 
no solution at the moment, I'm afraid. 
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-07-01 15:24:13 UTC
There's no way to use current ffmpeg with vlc-0.7.x . 
 
Have you tried with the stream useflag? 
Comment 5 Jan Kunzmann 2005-07-01 15:34:30 UTC
The stream use flag isn't supported with vlc 0.7.2.   
   
As I stated in my report, you can build vlc 0.7.2 with ffmpeg-0.4.9_pre1-r1 
but with no ffmpeg above that version due changes in libavformat/avformat.h. 
 
So the thing I'm asking for is to extend the RDEPEND of vlc-0.7.2.ebuild from 
>=media-video/ffmpeg-0.4.8.20040222 
to  
>=media-video/ffmpeg-0.4.8.20040222 <=media-video/ffmpeg-0.4.9_pre1-r1  
 
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-07-01 15:45:18 UTC
I was intending stream useflag in 0.8.2. 
 
about the dep, that would make the system going up and down because we don't 
really have a "range" dep 
so if you want to install 0.7.2 you must do so using p.mask.