Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 97051 - sys-kernel/genkernel-3.2.0_pre11 changes .config file
Summary: sys-kernel/genkernel-3.2.0_pre11 changes .config file
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: genkernel (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-25 10:06 UTC by Alon Bar-Lev
Modified: 2005-07-12 12:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alon Bar-Lev gentoo-dev 2005-06-25 10:06:13 UTC
I like to use genkernel, it saves me a lot of work.

I tried to compile a kernel with all features as modules... But I failed... I
noticed that genkernel modify the .config file regardless what I configure.

For example at gen_configkernel.sh there is the following command:
sed -i ${KERNEL_DIR}/.config -e 's/#\? \?CONFIG_EXT2_FS[ =].*/CONFIG_EXT2_FS=y/g'

I did not expect genkernel to modify any setting...

Reproducible: Always
Steps to Reproduce:
1. genkernel --menuconfig
2. Select ext2 as module.
3. Save and exit.
4. Compilation will fail... (Since you change only one variable)

Actual Results:  
ext2 cannot be compiled as module.

Expected Results:  
Minimal: Please consider adding --do-not-touch-config and avoid modify the
.config file.

Maximal: Please consider copying the required modules to the initramfs and
modprobe... If the user selects them as modules. :)
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2005-06-27 14:36:23 UTC
We're not going to implement --do-not-touch-config since some things *have* to
be on for anything to remotely work. The ext2/3 issue you bring up is valid
however, and we do need to disable that check if you are generating an initramfs
image.
Comment 2 Alon Bar-Lev gentoo-dev 2005-06-27 23:28:49 UTC
I am glad!!!
I suggested the --do-not-touch-config since it was the simplest way to go (not
the best...)

1. As I understand genkernel always depends on initrd... right?
If I specify the bzImage or kernel it just to reduce time for compilation.

2. Please consider to analyze the .config file and warn or error when invalid
options were detected... So that the user may change this him-self.

Thanks Again!
Comment 3 Alon Bar-Lev gentoo-dev 2005-06-28 03:44:23 UTC
I've seen what you done in pre14.
It is fine for me!

But I still think that modifying the .config cause advanced users to lose
control... So my last request is to consider --strick that warns the user if
genkernel is not happy with configuration... without modifying it.
Comment 4 Eric Edgar (RETIRED) gentoo-dev 2005-07-12 12:09:31 UTC
If you wish to add that behavior that is fine please send us a patch.  However
we would get more bug reports stating genkernel is broken if we do not enable
the few options that we do.  The only options currently are for dmraid/lvm
modules to be compiled for that filesystem support.