Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 96088 - set support for portage (including an "all" target)
Summary: set support for portage (including an "all" target)
Status: RESOLVED DUPLICATE of bug 144480
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 72265 96087 129004 144777 185397 191962 207063 213665 (view as bug list)
Depends on:
Blocks: 144480
  Show dependency tree
 
Reported: 2005-06-14 08:49 UTC by Attila Stehr
Modified: 2008-03-17 09:33 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log requested in emerge error (config.log,27.78 KB, text/plain)
2006-05-08 10:21 UTC, moth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Attila Stehr 2005-06-14 08:49:21 UTC
When I do 'emerge -pv --deep --newuse world' not all packages are stated which
can be updated. See example below.

==>
Hum - I know this is very awkward topic. So if I understood something wrong or
am in any other way the reason for this problem: PLEASE DO NOT SHOOT ME !
<==

Reproducible: Always
Steps to Reproduce:
1. emerge -pv --deep --newuse world
2. emerge -pv --deep --newuse hal

Actual Results:  
Some packages which may be updated are not shown.
(One package whichis grub seems not installed at all - wonder how it disappears
each time after booting my system :-O

Expected Results:  
show existing (and make) update (possible) by using 'world'

Maybe I'm blind - but I can not find 
1) hal
2) mc
3) grub (wich IS installed)
in the 'emerge -p world' result below.

magic atti # emerge -pv --newuse --deep world 
These are the packages that I would merge, in order:

Calculating world dependencies                       ...done!
[ebuild  NS   ] gnome-extra/libgtkhtml-3.6.1  -debug 1,325 kB
[ebuild  NS   ] gnome-extra/gal-2.4.1  -debug -doc 1,168 kB
[ebuild     U ] mail-client/evolution-2.2.1.1 [2.0.4] +crypt -debug -doc
+gstreamer +ipv6 -kerberos -ldap (-mono) -mozilla -nntp +pda -spell +ssl 13,086 kB
[ebuild   R   ] media-libs/xine-lib-1.0-r2  +X +aac -aalib +alsa (-altivec)
-arts -cle266 -debug +directfb +dvd -dxr3 +esd +fbcon +ffmpeg -flac +gnome -i8x0
+ipv6 -libcaca +mng +nls +nvidia +opengl +oss +png -samba +sdl -speex -theora*
-v4l -vidix +vorbis (-win32codecs) -xinerama +xv +xvmc 0 kB
[ebuild     U ] www-client/epiphany-1.6.0-r3 [1.4.8] -debug -doc 0 kB
[ebuild     U ] gnome-extra/evolution-webcal-2.2.0 [2.0.1] -debug 135 kB
[ebuild     U ] gnome-base/gnome-2.10-r1 [2.8.3-r1] -accessibility +cdr +dvdr
+hal 0 kB

Total size of downloads: 15,716 kB
magic atti # emerge -pv --newuse --deep hal mc grub

These are the packages that I would merge, in order:

Calculating dependencies    ...done!
[ebuild     U ] sys-apps/hal-0.4.7-r2 [0.4.5-r2] -debug -doc -livecd -pcmcia
1,317 kB
[ebuild     U ] app-misc/mc-4.6.0-r14 [4.6.0-r13] -7zip +X -debug +gpm +ncurses
+nls -samba +slang* +unicode 391 kB
[ebuild  N    ] sys-boot/grub-0.96-r1  -debug -netboot -static 1,001 kB

Total size of downloads: 2,710 kB
Comment 1 Attila Stehr 2005-06-14 08:51:44 UTC
Isn't /var/lib/portage/world where all emerged packages are listed?!

magic atti # cat /var/lib/portage/world | grep hal
magic atti # cat /var/lib/portage/world | grep grub
magic atti # cat /var/lib/portage/world | grep metalog
magic atti # cat /var/lib/portage/world | grep links
magic atti # cat /var/lib/portage/world | grep gpm
magic atti # cat /var/lib/portage/world | grep mc
magic atti # cat /var/lib/portage/world | grep emacs
magic atti # cat /var/lib/portage/world | grep slocate
magic atti #
Comment 2 Sven Wegener gentoo-dev 2005-06-14 08:55:23 UTC
No, it's a list of packages (better: atoms) you merged explicitly. Packages merged
by using --oneshot or merged as dependencies are not included in this list.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-06-14 09:10:58 UTC
*** Bug 96087 has been marked as a duplicate of this bug. ***
Comment 4 Attila Stehr 2005-06-14 09:46:10 UTC
*wonder*

I explicitly use --deep (and --newuse) on all emerge's.
I always thought, that emerge is outstanding for keeping the whole system (all
merges/installed packages/software) easily up to date?

If it's not this is a big disappointment to me!

Is there a workaround to make portage do (that much) I'd like it to do?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-06-14 10:04:15 UTC
(In reply to comment #4)
> *wonder*
> 
> I explicitly use --deep (and --newuse) on all emerge's.
> I always thought, that emerge is outstanding for keeping the whole system (all
> merges/installed packages/software) easily up to date?

No, '--deep world' does not mean _all_ installed packages. E.g., it won
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-06-14 10:04:15 UTC
(In reply to comment #4)
> *wonder*
> 
> I explicitly use --deep (and --newuse) on all emerge's.
> I always thought, that emerge is outstanding for keeping the whole system (all
> merges/installed packages/software) easily up to date?

No, '--deep world' does not mean _all_ installed packages. E.g., it won´t update
stale dependencies from packages that you have already unmerged.
Comment 7 Attila Stehr 2005-06-14 10:25:10 UTC
So I have to make a list of all 'manually' emerged packages like 'mc'?
In my opinion that's not what a user should care about - I've got a degree in cs
but how to explain that to my partner - which I try to convince of gentoo linux?

Okay, windows is worse - althoug lots of (free) porgramms have a 'check for
update' funcitionality - 
but as I thought portage is outstanding in this regard?!

Well whatever - what about adding a feature to portage putting all 'manually'
emerged packages in the world file? Shouldn't be a big issue.
hehe
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-06-14 10:59:28 UTC
(In reply to comment #6)
> So I have to make a list of all 'manually' emerged packages like 'mc'?
> In my opinion that's not what a user should care about

I really don
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-06-14 10:59:28 UTC
(In reply to comment #6)
> So I have to make a list of all 'manually' emerged packages like 'mc'?
> In my opinion that's not what a user should care about

I really don´t know what´s wrong with your local portage, mc definitely shows
its updates via emerge -uDpv world for, likewise for grub.
Comment 10 Attila Stehr 2005-06-14 11:12:55 UTC
me neither:

magic atti # emerge -uDpv world

These are the packages that I would merge, in order:

Calculating world dependencies         ...done!
[ebuild  NS   ] sys-libs/db-4.2.52_p2  -bootstrap -doc -java -nocxx +tcltk 3,980 kB
[ebuild     U ] net-mail/mailbase-0.00-r9 [0.00-r8] +pam 0 kB
[ebuild  N    ] dev-libs/check-0.9.2  157 kB
[ebuild     U ] x11-terms/xterm-200-r3 [200-r1] -Xaw3d -debug -toolbar +truetype
+unicode 0 kB
[ebuild     U ] sys-devel/binutils-config-1.8-r3 [1.8-r2] 0 kB
[ebuild     U ] app-cdr/cdrtools-2.01-r3 [2.01-r2] -on-the-fly-crypt +unicode 0 kB
[ebuild     U ] media-libs/gst-plugins-0.8.8-r2 [0.8.8] +alsa -debug +esd +oss 0 kB
[ebuild     U ] gnome-base/gail-1.8.3 [1.8.2-r1] -debug -doc -static 549 kB
[ebuild  N    ] perl-core/Storable-2.13  131 kB
[ebuild     U ] mail-filter/spamassassin-3.0.4 [3.0.2-r1] +berkdb -doc -qmail
+ssl 827 kB
[ebuild  NS   ] gnome-extra/gal-2.4.1  -debug -doc 1,168 kB
[ebuild     U ] net-libs/gnutls-1.2.4 [1.2.3] +crypt -doc +zlib 2,388 kB
[ebuild     U ] net-libs/libsoup-2.2.3 [2.2.2] -debug -doc +ipv6 +ssl 349 kB
[ebuild  NS   ] gnome-extra/libgtkhtml-3.6.1  -debug 1,325 kB
[ebuild  N    ] dev-tcltk/itcl-3.2.1-r1  417 kB
[ebuild     U ] mail-client/evolution-2.2.1.1 [2.0.4] +crypt -debug -doc
+gstreamer +ipv6 -kerberos -ldap (-mono) -mozilla -nntp +pda -spell +ssl 13,086 kB
[ebuild  N    ] dev-tcltk/iwidgets-4.0.1  632 kB
[ebuild     UD] media-libs/imlib2-1.2.0-r2 [1.2.0.007] +X -doc +gif +jpeg (-mmx)
+nls +png +tiff 869 kB
[ebuild     U ] www-client/epiphany-1.6.0-r3 [1.4.8] -debug -doc 0 kB
[ebuild     U ] gnome-extra/evolution-webcal-2.2.0 [2.0.1] -debug 135 kB
[ebuild     U ] gnome-base/gnome-2.10-r1 [2.8.3-r1] -accessibility +cdr +dvdr
+hal 0 kB
[ebuild     UD] dev-libs/pth-1.4.0 [2.0.3] 434 kB

Total size of downloads: 26,455 kB
magic atti # emerge -uDpv world | grep mc
magic atti # emerge -uDpv mc

These are the packages that I would merge, in order:

Calculating dependencies      ...done!
[ebuild     U ] sys-devel/binutils-config-1.8-r3 [1.8-r2] 0 kB
[ebuild  NS   ] sys-libs/db-4.2.52_p2  -bootstrap -doc -java -nocxx +tcltk 3,980 kB
[ebuild  N    ] dev-libs/check-0.9.2  157 kB
[ebuild     U ] x11-terms/xterm-200-r3 [200-r1] -Xaw3d -debug -toolbar +truetype
+unicode 0 kB
[ebuild     U ] net-mail/mailbase-0.00-r9 [0.00-r8] +pam 0 kB
[ebuild     U ] app-misc/mc-4.6.0-r14 [4.6.0-r13] -7zip +X -debug +gpm +ncurses
+nls -samba +slang* +unicode 391 kB

Total size of downloads: 4,529 kB
Comment 11 Dan Check 2005-07-02 08:59:06 UTC
This may be a different problem, but I just noticed on two of my machines that
my world file was missing a _lot_ of entries.  On both machines it had clearly
been erased and rewritten, as it was missing a lot of the things that I emerge
at the beginning of an install (vixie-cron), but not games that I'd added
recently (flobopuyo).

On both machines, it would have happened over a week ago -- one of them has been
missing the latest curl update, which happened over a week ago.

Are there any circumstances under which deleting your world file is expected
behavior?  If not, there appears to be a pretty serious bug here...

Maybe I did something stupid like stopping an emerge in the "Updating your world
file" section, after it had (maybe) erased the previous one but before it had
written the new one?  That seems far fetched, though, as a reason why this would
have happened on two boxes.
Comment 12 Attila Stehr 2005-07-05 11:57:29 UTC
This bug may be connected with bug #98036.
Comment 13 Martin Schlemmer (RETIRED) gentoo-dev 2005-07-17 10:10:26 UTC
Seems all right here:

-----
ycan nss_ldap-239 # emerge -uD world -p

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild     UD] sys-apps/baselayout-1.12.0_alpha2-r1 [1.12.0_pre1]
[ebuild  N    ] media-libs/imlib-1.9.14-r3
lycan nss_ldap-239 # emerge -up $(find /var/db/pkg/ -mindepth 2 -maxdepth 2
-printf "%P\n" | sed 's/-[0-9].*//g')

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     UD] sys-apps/baselayout-1.12.0_alpha2-r1 [1.12.0_pre1]
[ebuild     U ] media-gfx/gimp-print-5.0.0_beta4 [4.2.7]
lycan nss_ldap-239 #
Comment 14 mstar-gentoo 2005-09-27 03:39:16 UTC
Having the same problem here.  Was running the "glsa-check" utilitity and it 
says that clamav needs an update.  Strange, I emerge'd world and it didn't get 
updated:

(emerge sync)

master ~ # emerge -avuD world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!

Total size of downloads: 0 kB

Nothing to merge; do you want me to auto-clean packages? [Yes/No] no

Quitting.

master ~ # 
master ~ # emerge -av clamav

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] app-antivirus/clamav-0.87 [0.82-r1] +crypt -mailwrapper -milter 
(-selinux) 4,173 kB 

Total size of downloads: 4,173 kB

Do you want me to merge these packages? [Yes/No] 
master ~ # emerge -av spamassassin

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] mail-filter/spamassassin-3.0.4 [3.0.2-r1] -berkdb +doc +qmail 
+ssl 827 kB 

Total size of downloads: 827 kB

Do you want me to merge these packages? [Yes/No] 
master ~ # grep -i clamav /var/lib/portage/world 
master ~ # grep -i spamass /var/lib/portage/world 

Can you please let me know what I need to do to keep my gentoo system up to date 
using portage.

Comment 15 Zac Medico gentoo-dev 2005-10-09 13:50:29 UTC
(In reply to comment #9)
> Are there any circumstances under which deleting your world file is expected
> behavior?  If not, there appears to be a pretty serious bug here...

This would be a separate bug (not yet filed?).  I have heard genone talk about
adding proper locking to the world file in order to correct such problems.
Comment 16 Attila Stehr 2005-12-04 05:10:40 UTC
If I remember right, I emerged those packages when I followed the handbook:
"chapter 9. Installing Necessary System Tools"

hal grub metalog links gpm mc emacs slocate
That seems to be right especially with grub and metalog in the list...

Will packages at that point of time NOT be recorded in the world file?

-------------------------------------

If thats true, here is a workaround:
First unmerge the "missing" packages. Then emerge the packages ->  now the entry
in world will be made.
Comment 17 Jason Stubbs (RETIRED) gentoo-dev 2005-12-05 05:49:53 UTC
With current portages, any package specified on the command line will be added 
to world unless the parameter --oneshot is specified. If you want to confirm 
that installed packages are in world without actually reemerging them the 
--noreplace parameter can be used. 
Comment 18 Attila Stehr 2005-12-05 06:17:52 UTC
Jason, thank you for that information!

Well, I build my system about one year ago. Does that mean that the "bug" only
affects portage versions which are older than about one year?
Comment 19 Marius Mauch (RETIRED) gentoo-dev 2005-12-05 11:14:52 UTC
Well, back on topic, an "all" target would be another candidate for set modules.
Any volunteers for tearing emerge into pieces?
Comment 20 Peter Read 2006-01-08 13:24:54 UTC
Why would people want to update software which is not a dependancy of anything and keep it out of world?  Surely all it would achieve is a lot of bad press the first time a newbie runs --depclean on a system with a broken world file.  

& if for whatever reason someone *really* wanted to do this, couldn't they just mv the world file, run 'regenworld', emerge -auvDN (or whatever) world, then move the old world file back?
Comment 21 Attila Stehr 2006-01-08 13:41:49 UTC
"Why would people want to update software which is not a dependancy of anything
and keep it out of world?"

Well, why would someone like to have the newest version of software when all (s)he gets is more festures or "faster code" or better compatibility?

"Surely all it would achieve is a lot of bad press the first time a newbie runs --depclean on a system with a broken world file."

Lets hava a USE flag and don't make it a default one.

"& if for whatever reason someone *really* wanted to do this, couldn't they just
mv the world file, run 'regenworld', emerge -auvDN (or whatever) world, then
move the old world file back?"

I didn't know that. I probably will once in a while execute the procedure above. Nontheless I would be feel safer and it would be more comfortable to let portage  (emerge uD --all) do it.

Regards,
~ Attila
Comment 22 Peter Read 2006-01-08 14:04:40 UTC
I guess it would be fairly trivial to add an 'update-universe' or whatever script to portage.

I'm just not sure if it's something to encourage, as everything should either be in the world file or a dependancy.  Otherwise it shouldn't be on the system...

Maybe there's a better solution, an interactive depclean say in the style of dispatch-conf, which offers (c)lean, (a)dd to world or (i)gnore ?  Or a pre-depclean script which takes the output of depclean -p, offers similar choices, then updates world & either unmerges the rest or re-runs depclean?  

Obviously these would be less trivial to implement, as you would ideally want to check dependancies & e.g. if package2 depends on package1, ask about package2 first & ignore package1 if user chose to add to world.  A danger they might want package1 in world in its own right too I guess, but no more than if they emerged something normally & happened to use the dependancy directly too.
Comment 23 Attila Stehr 2006-01-08 14:19:08 UTC
Erm .. I didn't understand what's going to happen now (implemenation or not). All I can say that I wold really likt to have this feature - maybe other people too. ;)
Comment 24 Brian Harring gentoo-dev 2006-01-08 18:32:32 UTC
emerge --oneshot --uprade $(python -c'import portage;print " ".join(map(lambda x:"="+x, portage.vdb.cpv_all()))'

...roughly.
Comment 25 Marius Mauch (RETIRED) gentoo-dev 2006-01-09 09:24:50 UTC
trivial once set support is in.
Comment 26 Simon Stelling (RETIRED) gentoo-dev 2006-04-06 12:33:20 UTC
*** Bug 129004 has been marked as a duplicate of this bug. ***
Comment 27 moth 2006-05-08 10:21:41 UTC
Created attachment 86430 [details]
config.log requested in emerge error
Comment 28 Marius Mauch (RETIRED) gentoo-dev 2006-05-08 12:38:49 UTC
(In reply to comment #25)
> Created an attachment (id=86430) [edit]
> config.log requested in emerge error
> 

Sorry, but how is that related to this feature request?
Comment 29 Peter Hyman 2006-07-26 03:32:57 UTC
Maybe related. All of a sudden, updates to this software are not found.

mars peter # emerge -puDN world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] dev-libs/liboil-0.3.6-r1 [0.3.6] 
[ebuild     U ] kde-base/kopete-3.5.3-r3 [3.5.3-r2] 
mars peter # emerge -pu beyond-sources

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] sys-kernel/beyond-sources-2.6.17_p30  USE="-build -symlink" 
mars peter # grep beyond /var/lib/portage/world
sys-kernel/beyond-sources

mars peter # emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-beyo                                                                 
nd2.2 i686)
=================================================================
System uname: 2.6.17-beyond2.2 i686 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shu                                                                 
tdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr                                                                 
/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf                                                                 
/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/                                                                 
terminfo"
CXXFLAGS="-O2 -march=i686 -fomit-frame-pointer"
DISTDIR="/mnt/src/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo ftp://gentoo.mirrors.tds.net/g                                                                 
entoo ftp://206.75.217.180/"
MAKEOPTS="-j2"
PKGDIR="/mnt/src/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress                                                                  
--force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/d                                                                 
istfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/mnt/src/var/tmp"
PORTDIR="/mnt/src/portage"
PORTDIR_OVERLAY="/mnt/src/local/portage /mnt/src/local/overlays/bmg-main"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts artswrappersuid avi berkdb bitmap-fonts bzip2 c                                                                 
li crypt cups dlloader dri dvd dvdr eds emboss encode esd fam flac foomaticdb fo                                                                 
rtran gdbm gif glut gnome gpm gstreamer gtk gtk2 imlib ipv6 isdnlog java jpeg lc                                                                 
ms ldap libg++ libwww mad mikmod motif mp3 mpeg mysql ncurses nls nptl nsplugin                                                                  
offensive ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 qt4 quickti                                                                 
me readline reflection samba sdl session slang spell spl ssl svga tcltk tcpd tif                                                                 
f truetype truetype-fonts type1-fonts udev vorbis win32codecs xine xml xmms xorg                                                                 
 xscreensaver xv zlib elibc_glibc input_devices_keyboard input_devices_mouse inp                                                                 
ut_devices_evdev kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGU                                                                 
AS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 30 Jakub Moc (RETIRED) gentoo-dev 2006-08-22 11:44:09 UTC
*** Bug 144777 has been marked as a duplicate of this bug. ***
Comment 31 Zac Medico gentoo-dev 2006-10-11 10:12:36 UTC
I don't think that an "all" set is either necessary or desirable.  The world "favorites" set, which includes the system set, is the same as "all" when --depclean is used properly.  The --depclean implementation was suboptimal in the past, but it is quite good in >=portage-2.1.1.  Other things to note:

1) Bug 4698 has been fixed in 2.1.2, ensuring that all installed slots can be automatically updated (world and system are "greedy" with respect to slots).
2) In 2.1.2, unnecessary build time dependencies with not be updated by default.  You'll need --with-bdeps=y in order to force those to be updated.
Comment 32 Marius Mauch (RETIRED) gentoo-dev 2006-10-11 11:30:40 UTC
Zac: this bug is about general set support, not just the "all" target (I just added that to the summary so people don't get confused when their bugs are duped against this one).
Comment 33 Simon Stelling (RETIRED) gentoo-dev 2006-10-11 11:43:57 UTC

*** This bug has been marked as a duplicate of 144480 ***
Comment 34 Zac Medico gentoo-dev 2007-01-12 06:56:24 UTC
*** Bug 72265 has been marked as a duplicate of this bug. ***
Comment 35 Zac Medico gentoo-dev 2007-07-15 11:47:07 UTC
*** Bug 185397 has been marked as a duplicate of this bug. ***
Comment 36 Jakub Moc (RETIRED) gentoo-dev 2007-09-10 13:56:46 UTC
*** Bug 191962 has been marked as a duplicate of this bug. ***
Comment 37 Jakub Moc (RETIRED) gentoo-dev 2008-01-22 17:28:45 UTC
*** Bug 207063 has been marked as a duplicate of this bug. ***
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2008-03-17 09:24:16 UTC
*** Bug 213665 has been marked as a duplicate of this bug. ***