Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 95836 - OpenGL support on ati-drivers-8.14.13-r1 fundamentally broken on AMD64
Summary: OpenGL support on ati-drivers-8.14.13-r1 fundamentally broken on AMD64
Status: RESOLVED DUPLICATE of bug 95683
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-11 23:16 UTC by gtl4407
Modified: 2005-06-11 23:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gtl4407 2005-06-11 23:16:03 UTC
Using version 8.14.13-r1 of the drivers on Radeon 9200 PRO. Everything seems to
be loading correctly in the xorg.log file, and I can see the frglx module
present. However I still don't have direct OpenGL. If I run the folllowing command:

LIBGL_DEBUG=verbose fglrxinfo

I get this output:
libGL: XF86DRIGetClientDriverName: 8.14.13 atiogl_a (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib64/modules/dri/atiogl_a_dri.so
libGL error: dlopen /usr/X11R6/lib64/modules/dri/atiogl_a_dri.so failed
(/usr/X11R6/lib64/modules/dri/atiogl_a_dri.so: cannot open shared object file:
No such file or directory)
libGL error: unable to find driver: atiogl_a_dri.so
libGL: XF86DRIGetClientDriverName: 8.14.13 atiogl_a (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib64/modules/dri/atiogl_a_dri.so
libGL error: dlopen /usr/X11R6/lib64/modules/dri/atiogl_a_dri.so failed
(/usr/X11R6/lib64/modules/dri/atiogl_a_dri.so: cannot open shared object file:
No such file or directory)
libGL error: unable to find driver: atiogl_a_dri.so
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Rolling back to older version of the driver restors OpenGL Direct3d Functionality

Reproducible: Always
Steps to Reproduce:
1. Install updated driver 8.14.13-r1 using emerge
2.
3.

Actual Results:  
OpenGL support broken and switches to software 3D (mesa)

Expected Results:  
OpenGL support should be provided by ATI drivers
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-06-11 23:20:05 UTC
Not only on AMD64.

*** This bug has been marked as a duplicate of 95683 ***