Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 94727 - 'emerge mod_php' (5.0.4 ebuild) failed at configure
Summary: 'emerge mod_php' (5.0.4 ebuild) failed at configure
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 60438
  Show dependency tree
 
Reported: 2005-06-01 05:11 UTC by Tiago Freire
Modified: 2005-09-07 00:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tiago Freire 2005-06-01 05:11:38 UTC
The error was: 

/var/tmp/portage/mod_php-5.0.4/work/php-5.0.4
 * Applying php5-prefork.patch ...                                             
                                                                               
            [ ok ]
 * Rebuilding configure script
configure.in:150: warning: AC_PROG_LEX invoked multiple times
autoconf/programs.m4:438: AC_DECL_YYTEXT is expanded from...
configure.in:150: the top level
configure.in:623: error: possibly undefined macro: PHP_AC_BROKEN_REALPATH
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

!!! ERROR: dev-php/mod_php-5.0.4 failed.
!!! Function src_unpack, Line 58, Exitcode 1
!!! Unable to regenerate configure script
!!! If you need support, post the topmost build error, NOT this status message.


Reproducible: Always
Steps to Reproduce:
1. emerge mod_php
2.
3.

Actual Results:  
see error above

Expected Results:  
compilation successful

Portage 2.0.51.19 (default-linux/amd64/2005.0, gcc-3.4.3-vanilla,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.11-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May 13 2005, 13:07:29)]
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://open-systems.ufl.edu/mirrors/gentoo
http://ftp.heanet.ie/pub/gentoo/ http://gentoo.seren.com/gentoo
ftp://mirror.nutsmaas.nl/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 3dnowex X aac aalib acl acpi alsa apache2 arts artswrappersuid avi
berkdb bidi bitmap-fonts bzlib calendar canna caps cdparanoia cdr cjk crypt cups
curl curlwrappers dba dga doc dts dv dvb dvd dvdr dvdread encode esd ethereal
evo fam fbcon ffmpeg flac font-server foomaticdb fortran ftp gd gdbm gif gmp
gnutls gpm gstreamer gtk gtk2 hardenedphp i8x0 iconv imagemagick imap imlib
innodb interbase ipv6 java jp2 jpeg jpeg2k junit kde kdeenablefinal kdexdeltas
lcms ldap libwww lm_sensors lzw lzw-tiff mad maildir mailwrapper mbox mcal mhash
mime mmap mng motif mozdevelop mozilla mozsvg mp3 mpeg mppe-mppc mysql mysqli
nas ncurses nls nptl nvidia oav odbc offensive ogg oggvorbis openal opengl oss
pam pcntl pcre pda perl php pic plotutils png posix postgres ppds prelude
profile python qt quicktime rdesktop readline samba sasl scanner sdl session
shared sharedmem slang sndfile snmp soap sockets sox speex spell spl sqlite ssl
svg symlink tcpd theora threads tidy tiff tokenizer truetype truetype-fonts
type1-fonts unicode usb userlocales utf8 vhosts vorbis wddx wifi win32 wmf xine
xml2 xmlrpc xmms xpm xprint xrandr xsl xv xvid yahoo zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Mark Watkins 2005-06-06 21:18:16 UTC
Same problem, although i'm on x86.. (athlon-xp)

/var/tmp/portage/mod_php-5.0.4/work/php-5.0.4
 * Applying php5-prefork.patch ...                                             
                                      [ ok ] * Rebuilding configure script
configure.in:150: warning: AC_PROG_LEX invoked multiple times
autoconf/programs.m4:438: AC_DECL_YYTEXT is expanded from...
configure.in:150: the top level
configure.in:623: error: possibly undefined macro: PHP_AC_BROKEN_REALPATH
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

!!! ERROR: dev-php/mod_php-5.0.4 failed.
!!! Function src_unpack, Line 58, Exitcode 1
!!! Unable to regenerate configure script



Portage 2.0.51.19 (hardened/x86/2.6, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11-hardened-r13 i686)
=================================================================
System uname: 2.6.11-hardened-r13 i686 Unknow CPU Type
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Jun  6 2005, 19:25:23)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -fforce-addr -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/bind /var/qmail/alias /var/qmail/control
/var/vpopmail/domains /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -fforce-addr -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://mirror.pacific.net.au/linux/Gentoo
http://mirror.isp.net.au/pub/gentoo/ ftp://mirror.isp.net.au/pub/gentoo/
http://gentoo.ccccom.com"
MAKEOPTS="-j2"
PKGDIR="/usr/portage//packages/x86/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="3dnow acl acpi apache2 bash-completion berkdb bzip2 calendar cdr crypt curl
dba dbm dlloader exif gd gdbm gpm hardened hardenedphp imap imlib innodb jpeg
ldap libwww lm_sensors maildir mime mmap mmx mysql ncurses nls pam pcre perl
perlsuid pic png python readline session sharedmem simplexml snmp soap sockets
spell sse ssl symlink tcpd userlocales vhosts x86 xml2 xmlrpc zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 2 Mark Watkins 2005-06-06 21:29:37 UTC
looks like them thar hardenedphp patches are need of a little loving

USE="-hardenedphp" emerge mod_php

...blahblahblah...
configure.in:150: warning: AC_PROG_LEX invoked multiple times
autoconf/programs.m4:438: AC_DECL_YYTEXT is expanded from...
configure.in:150: the top level
>>> Source unpacked.

then goes on to build ok...
Comment 3 Tiago Freire 2005-06-07 04:46:59 UTC
shouldn't this flag be disabled for this version too, until 5.0.4-r1 (or  
later) fixes it? Would altering the ebuild just to add a warning and ignoring  
the flag need a version bump? or would the warning go 
into /usr/portage/eclass/php5sapi-r2.eclass php5-sapi-r2_check_awkward_uses()? 
like the mysqli check. 
Comment 4 Tiago Freire 2005-06-07 04:54:05 UTC
#something like this perhaps: 
 
    if useq hardenedphp ; then  
        eerror  
        eerror "The hardenedphp patches area bit icky right now."  
        eerror "please add -hardenedphp to mod_php  
in /etc/portage/package.use"  
        eerror "or remove it from your USE flags. "  
        eerror 
        die "hardenedphp is not compiling right now"  
     fi  
Comment 5 Flo 2005-09-05 01:13:17 UTC
Please note that there are new ebuilds for PHP5 in the portage tree now, the old
ones have been removed. Sync and read 
http://www.gentoo.org/news/en/gwn/20050905-newsletter.xml

It doesn't mean that it will neccessarily solve the configure problem, but you
should continue working (or trying) with the new ebuilds from dev-lang/php.
dev-php is outdated for php5 now. But please also note that those new ebuilds
from dev-lang/php are masked in /usr/portage/profiles/package.mask due to some
final tests till thursday this week.
Comment 6 Stuart Herbert (RETIRED) gentoo-dev 2005-09-07 00:22:20 UTC
Hi,

I've removed dev-php/mod_php-5* from Portage.  It has been replaced by the new
dev-lang/php package.  Please switch to using that package.

Best regards,
Stu