Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 94650 - Beep-media-player segfault when using bmp-crossfade
Summary: Beep-media-player segfault when using bmp-crossfade
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-31 11:20 UTC by Anonymous
Modified: 2005-07-30 08:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anonymous 2005-05-31 11:20:44 UTC
Beep-media-player crashes with a segfault when
you quit bmp without stopping the current song.

Btw, this happens with stable and unstable bmp, and with stable and unstable
alsa-lib, alsa-headers etc.



Here's a strace of the segfault:

munmap(0xb6348000, 65536)               = 0
ioctl(11, 0x4112, 0x2)                  = 0
close(11)                               = 0
munmap(0xb6359000, 4096)                = 0
munmap(0xb6358000, 4096)                = 0
open("/home/frank/.bmp/config", O_RDONLY|O_LARGEFILE) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=3301, ...}) = 0
read(7, "[beep]\nallow_multiple_instances="..., 3301) = 3301
close(7)                                = 0
open("/home/frank/.bmp/config", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb73da000
write(7, "[beep]\nallow_multiple_instances="..., 3282) = 3282
close(7)                                = 0
munmap(0xb73da000, 131072)              = 0
write(2, "[crossfade] fini: cleanup: closi"..., 49) = 49
munmap(0xb620f000, 1282048)             = 0
write(2, "[crossfade] fini: cleanup: done\n", 32) = 32
futex(0xb742e614, FUTEX_WAKE, 1)        = 0
open("/home/frank/.bmp/config", O_RDONLY|O_LARGEFILE) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=3282, ...}) = 0
read(7, "[beep]\nallow_multiple_instances="..., 3282) = 3282
close(7)                                = 0
open("/home/frank/.bmp/config", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb73da000
write(7, "[beep]\nallow_multiple_instances="..., 3300) = 3300
close(7)                                = 0
munmap(0xb73da000, 131072)              = 0
write(2, "[crossfade] save_config: configu"..., 45) = 45
write(2, "[crossfade] fini: done.\n", 24) = 24
munmap(0xb73fa000, 214576)              = 0
munmap(0x47104000, 115576)              = 0
futex(0x482f2180, FUTEX_WAKE, 1)        = 1
munmap(0xb751d000, 47688)               = 0
+++ killed by SIGABRT +++


I looked into the source of bmp-crossfade and it seems like the fault has
nothing to do with crossfade. The cleanup function ("fini") is called by bmp and
seems to exit gracefully, as the last command in this function is just normally
run (write(2, "[crossfade] fini: done.\n", 24) = 24).
So the problem is either bmp or some thread started in crossfade (although this
one seems to shut down normally as well).

Reproducible: Always
Steps to Reproduce:
Start bmp
Enable crossfade plugin
Start playing a song
Quit bmp -> segfault :(



Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11.10 i686)
=================================================================
System uname: 2.6.11.10 i686 AMD Athlon(TM) XP 2800+offset=0 skip=0
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 27 2005, 20:25:01)]
ccache version 2.3 [enabled]0
dev-lang/python:     2.3.5fig: 7194 ms flushed
sys-apps/sandbox:    [Not Present]il=50 out=50 in=50 offset=-50 skip=0
sys-devel/autoconf:  2.59-r6, 2.13es to next crossing
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"anup: waiting for buffer thread...
AUTOCLEAN="yes"fer_thread_f: timeout: input did not restart after 101 ms (playin
                                CFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx
-fomit-frame-pointer -pipe -ffast-math"
CHOST="i686-pc-linux-gnu"_f: timeout: manual stop
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx -fomit-frame-pointer -pipe
-ffast-math"
DISTDIR="/usr/portage/distfiles"eout, eop: closing output...
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo
http://ftp.easynet.nl/mirror/gentoo"
MAKEOPTS="-j2"ni: cleanup: waiting for buffer thread... done
PKGDIR="/usr/portage/packages"sing audio...
PORTAGE_TMPDIR="/var/tmp": closing audio... done
PORTDIR="/usr/portage"nup: done
PORTDIR_OVERLAY="/usr/local/portage"on saved
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X alsa avi berkdb bitmap-fonts bluetooth cups divx4linux
dvd dvdr dvdread encode foomaticdb gdbm gif gpm gtk gtk2 imagemagick imlib java
jpeg live mad mmx mmxext mp3 mpeg nas ncurses network nls nptl oggvorbis opengl
pam perl png ppds python qt quicktime readline samba sdl softmmu sox spell sse
ssl svga tcltk tga tiff truetype truetype-fonts type1-fonts v4l2 win32codecs xv
xvid zlib userland_GNU kernel_linux elibc_glibc"    Unset:  ASFLAGS, CBUILD,
CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Tony Vroon gentoo-dev 2005-05-31 11:35:52 UTC
Could you repost your emerge info? It got mangled by some other program.
Comment 2 Anonymous 2005-05-31 12:03:02 UTC
Lol, indeed, weird (think it's because I resized my xterm).
Here it is again:

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11.10 i686)
=================================================================
System uname: 2.6.11.10 i686 AMD Athlon(TM) XP 2800+
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 27 2005, 20:25:01)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx -fomit-frame-pointer -pipe
-ffast-math"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx -fomit-frame-pointer -pipe
-ffast-math"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo
http://ftp.easynet.nl/mirror/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X alsa avi berkdb bitmap-fonts bluetooth cups divx4linux
dvd dvdr dvdread encode foomaticdb gdbm gif gpm gtk gtk2 imagemagick imlib java
jpeg live mad mmx mmxext mp3 mpeg nas ncurses network nls nptl oggvorbis opengl
pam perl png ppds python qt quicktime readline samba sdl softmmu sox spell sse
ssl svga tcltk tga tiff truetype truetype-fonts type1-fonts v4l2 win32codecs xv
xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 3 Hopeless 2005-06-04 15:39:46 UTC
I've had the same issue for quite a while, but I just ignored it as it didn't
have any apparent ill effect.

Anyway, my emerge info, if it helps;
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3-20050110,
glibc-2.3.4.20050125-r1, 2.6.11-gentoo-r5 i686)
=================================================================
System uname: 2.6.11-gentoo-r5 i686 Pentium III (Coppermine)
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  7 2005, 19:38:24)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE=""
ANT_HOME="/usr/share/ant-core"
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/spork/is/not/valid/profile.env"
CFLAGS="-O2 -march=pentium3 -mtune=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CVS_RSH="ssh"                   
CXXFLAGS="-O2 -march=pentium3 -mtune=pentium3 -pipe -fomit-frame-pointer"
DISPLAY=":0.0"                  
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"              
ELIBC="glibc"                   
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
GCC_SPECS=""                    
GDK_USE_XFT="1"                 
GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo/ ftp://ftp.heanet.ie/pub/gentoo/"
GRP_STAGE23_USE="ipv6 pam tcpd readline nls ssl gpm perl python berkdb ncurses"
G_BROKEN_FILENAMES="1"          
HOME="/root"                    
HOSTNAME="gentoo"               
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.15.92.0.2/info:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.3-20050110/info"
JAVAC="/opt/sun-jdk-1.4.2.08/bin/javac"
JAVA_HOME="/opt/sun-jdk-1.4.2.08"
JDK_HOME="/opt/sun-jdk-1.4.2.08"
KERNEL="linux"                  
LANG="en_IE"                    
LANGUAGE="en_IE"                
LC_ALL="en_IE"                  
LDFLAGS="-Wl,-O1"               
LESS="-R"                       
LESSOPEN="|lesspipe.sh %s"      
LOGNAME="root"                  
MAIL="/var/mail/root"           
MAKEOPTS="-j2"                  
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.15.92.0.2/man:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.3-20050110/man::/opt/sun-jdk-1.4.2.08/man"
MOZILLA_FIVE_HOME="/usr/lib/mozilla"
NOCOLOR="false"                 
OPENGL_PROFILE="xorg-x11"       
PAGER="/usr/bin/less"           
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.4.3-20050110:/usr/i386-pc-linux-gnu/gcc-bin/3.3:/opt/sun-jdk-1.4.2.08/bin:/opt/sun-jdk-1.4.2.08/jre/bin:/opt/sun-jdk-1.4.2.08/jre/javaws"
               
PKGDIR="/usr/portage/packages"  
PORTAGE_ARCHLIST="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos ppc-od
s390 sh sparc x86 x86-fbsd x86-obsd x86-od"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CALLER="emerge"         
PORTAGE_GID="250"               
PORTAGE_MASTER_PID="16545"      
PORTAGE_NICENESS="20"           
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"          
PRELINK_PATH=""                 
PRELINK_PATH_MASK=""            
PWD="/root"                     
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"       
RSYNC_RETRIES="3"               
RSYNC_TIMEOUT="180"             
SANE_CONFIG_DIR="/etc/sane.d"   
SGML_CATALOG_FILES="/etc/sgml/sgml-docbook.cat:/etc/sgml/openjade-1.3.2.cat:/etc/sgml/sgml-ent.cat:/etc/sgml/sgml-docbook-3.0.cat:/etc/sgml/sgml-docbook-3.1.cat:/etc/sgml/sgml-docbook-4.0.cat:/etc/sgml/sgml-docbook-4.1.cat:/etc/sgml/sgml-lite.cat:/etc/sgml/dsssl-docbook-stylesheets.cat"
SHELL="/bin/bash"               
SHLVL="1"                       
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="Eterm"                    
USE="x86 X acl acpi alsa avi bash-completion bitmap-fonts bmp cdparanoia crypt
cups curl directfb dvd dvdread emboss encode fam fbcon ffmpeg firefox
font-server foomaticdb fortran gd gdbm gif gphoto2 gpm gtk gtk2 imagemagick
imlib jikes jpeg libg++ libwww lirc mad mmx mozilla mp3 mpeg ncurses nls
nojoystick nptl ogg opengl pam pdflib plotutils png ppds quicktime readline real
rtc scanner sdl slang spell sse ssl svga tcpd tetex truetype truetype-fonts
type1-fonts unicode usb vorbis xine xml2 xmms xv xvid zlib video_cards_rage128
userland_GNU kernel_linux elibc_glibc"
USER="root"                     
USERLAND="GNU"                  
USE_EXPAND="FRITZCAPI_CARDS FCDSL_CARDS VIDEO_CARDS INPUT_DEVICES LINGUAS
USERLAND KERNEL ELIBC"
VIDEO_CARDS="rage128"           
XARGS="xargs -r"                
XAUTHORITY="/root/.xauthYKamAt" 
XINITRC="/etc/X11/xinit/xinitrc"
_="/usr/bin/emerge"             
Comment 4 Anonymous 2005-06-05 09:29:07 UTC
It doesn't have any ill effect at my pc either, but it just shouldn't be this
way, I'm sure some memory is leaked or something this way, it's not "clean".
Comment 5 Paul 2005-07-17 09:33:37 UTC
(In reply to comment #0)
> Beep-media-player crashes with a segfault when
> you quit bmp without stopping the current song.
> 
> Btw, this happens with stable and unstable bmp, and with stable and unstable
> alsa-lib, alsa-headers etc.
> 
> 
> 
> Here's a strace of the segfault:
> 
> munmap(0xb6348000, 65536)               = 0
> ioctl(11, 0x4112, 0x2)                  = 0
> close(11)                               = 0
> munmap(0xb6359000, 4096)                = 0
> munmap(0xb6358000, 4096)                = 0
> open("/home/frank/.bmp/config", O_RDONLY|O_LARGEFILE) = 7
> fstat64(7, {st_mode=S_IFREG|0644, st_size=3301, ...}) = 0
> read(7, "[beep]\nallow_multiple_instances="..., 3301) = 3301
> close(7)                                = 0
> open("/home/frank/.bmp/config", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 7
> fstat64(7, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
> mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
> 0xb73da000
> write(7, "[beep]\nallow_multiple_instances="..., 3282) = 3282
> close(7)                                = 0
> munmap(0xb73da000, 131072)              = 0
> write(2, "[crossfade] fini: cleanup: closi"..., 49) = 49
> munmap(0xb620f000, 1282048)             = 0
> write(2, "[crossfade] fini: cleanup: done\n", 32) = 32
> futex(0xb742e614, FUTEX_WAKE, 1)        = 0
> open("/home/frank/.bmp/config", O_RDONLY|O_LARGEFILE) = 7
> fstat64(7, {st_mode=S_IFREG|0644, st_size=3282, ...}) = 0
> read(7, "[beep]\nallow_multiple_instances="..., 3282) = 3282
> close(7)                                = 0
> open("/home/frank/.bmp/config", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 7
> fstat64(7, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
> mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
> 0xb73da000
> write(7, "[beep]\nallow_multiple_instances="..., 3300) = 3300
> close(7)                                = 0
> munmap(0xb73da000, 131072)              = 0
> write(2, "[crossfade] save_config: configu"..., 45) = 45
> write(2, "[crossfade] fini: done.\n", 24) = 24
> munmap(0xb73fa000, 214576)              = 0
> munmap(0x47104000, 115576)              = 0
> futex(0x482f2180, FUTEX_WAKE, 1)        = 1
> munmap(0xb751d000, 47688)               = 0
> +++ killed by SIGABRT +++
> 
> 
> I looked into the source of bmp-crossfade and it seems like the fault has
> nothing to do with crossfade. The cleanup function ("fini") is called by bmp and
> seems to exit gracefully, as the last command in this function is just normally
> run (write(2, "[crossfade] fini: done.\n", 24) = 24).
> So the problem is either bmp or some thread started in crossfade (although this
> one seems to shut down normally as well).
> 
> Reproducible: Always
> Steps to Reproduce:
> Start bmp
> Enable crossfade plugin
> Start playing a song
> Quit bmp -> segfault :(
> 
> 
> 
> Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
> glibc-2.3.4.20041102-r1, 2.6.11.10 i686)
> =================================================================
> System uname: 2.6.11.10 i686 AMD Athlon(TM) XP 2800+offset=0 skip=0
> Gentoo Base System version 1.6.12
> Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 27 2005, 20:25:01)]
> ccache version 2.3 [enabled]0
> dev-lang/python:     2.3.5fig: 7194 ms flushed
> sys-apps/sandbox:    [Not Present]il=50 out=50 in=50 offset=-50 skip=0
> sys-devel/autoconf:  2.59-r6, 2.13es to next crossing
> sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
> sys-devel/binutils:  2.15.92.0.2-r7
> sys-devel/libtool:   1.5.16
> virtual/os-headers:  2.6.8.1-r2
> ACCEPT_KEYWORDS="x86"anup: waiting for buffer thread...
> AUTOCLEAN="yes"fer_thread_f: timeout: input did not restart after 101 ms (playin
>                                 CFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx
> -fomit-frame-pointer -pipe -ffast-math"
> CHOST="i686-pc-linux-gnu"_f: timeout: manual stop
> CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
> /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
> /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
> CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
> CXXFLAGS="-O3 -march=athlon-xp -msse -m3dnow -mmmx -fomit-frame-pointer -pipe
> -ffast-math"
> DISTDIR="/usr/portage/distfiles"eout, eop: closing output...
> FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
> GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo
> http://ftp.easynet.nl/mirror/gentoo"
> MAKEOPTS="-j2"ni: cleanup: waiting for buffer thread... done
> PKGDIR="/usr/portage/packages"sing audio...
> PORTAGE_TMPDIR="/var/tmp": closing audio... done
> PORTDIR="/usr/portage"nup: done
> PORTDIR_OVERLAY="/usr/local/portage"on saved
> SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
> USE="x86 3dnow 3dnowext X alsa avi berkdb bitmap-fonts bluetooth cups divx4linux
> dvd dvdr dvdread encode foomaticdb gdbm gif gpm gtk gtk2 imagemagick imlib java
> jpeg live mad mmx mmxext mp3 mpeg nas ncurses network nls nptl oggvorbis opengl
> pam perl png ppds python qt quicktime readline samba sdl softmmu sox spell sse
> ssl svga tcltk tga tiff truetype truetype-fonts type1-fonts v4l2 win32codecs xv
> xvid zlib userland_GNU kernel_linux elibc_glibc"    Unset:  ASFLAGS, CBUILD,
> CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

I have segfault issues with BMP, but the action required to initiate the
segfault is different. I didn't want to start another bug, but will if
appropriate. When running BMP and listening to mp3's through the OSS plugin, all
is well, but when using the alsa plugin, as soon as I hit "play," BMP segfaults.
This only happens with alsa-headers 1.08 and alsa-lib 1.08. It did not happen
with previous versions of alsa-lib and alsa-headers. Here are my USE flags:

USE="gtk gtk2 gnome alsa cups mp3 -qt -kde -arts"

Here is the stack trace I am getting:

execve("/usr/bin/beep-media-player", ["beep-media-player"],
["MANPATH=/usr/local/share/man:/us"..., "HOSTNAME=malaga", "SHELL=/bin/bash",
"TERM=rxvt", "WINDOWID=31457283", "QTDIR=/usr/qt/3",
"ANT_HOME=/usr/share/ant-core", "MOZILLA_FIVE_HOME=/usr/lib/mozil"...,
"USER=paul", "PRELINK_PATH_MASK=/usr/lib/gstre"...,
"LS_COLORS=no=00:fi=00:di=01;34:l"..., "GDK_USE_XFT=1",
"CONFIG_PROTECT_MASK=/etc/gconf /"..., "PAGER=/usr/bin/less",
"XINITRC=/etc/X11/xinit/xinitrc", "PATH=/usr/local/bin:/usr/bin:/bi"...,
"MAIL=/var/mail/paul", "PWD=/home/paul", "JAVA_HOME=/opt/blackdown-jdk-1.4"...,
"JAVAC=/opt/blackdown-jdk-1.4.2.0"..., "EDITOR=/bin/nano", "KDEDIRS=/usr",
"QMAKESPEC=linux-g++", "KDE_MALLOC=1", "COLORFGBG=10;0", "HOME=/home/paul",
"SHLVL=4", "JDK_HOME=/opt/blackdown-jdk-1.4."...,
"TERMINFO=/usr/share/terminfo", "LOGNAME=paul",
"PYTHONPATH=/usr/lib/portage/pym", "LESS=-R", "GCC_SPECS=", "CVS_RSH=ssh",
"CLASSPATH=.", "LESSOPEN=|lesspipe.sh %s",
"INFOPATH=/usr/share/info:/usr/sh"..., "DISPLAY=:0.0", "OPENGL_PROFILE=nvidia",
"CONFIG_PROTECT=/usr/lib/mozilla/"..., "G_BROKEN_FILENAMES=1",
"COLORTERM=rxvt-xpm", "XAUTHORITY=/home/paul/.Xauthorit"...,
"_=/usr/bin/strace"]) = 0
uname({sysname="Linux", nodename="malaga", release="2.6.11-gentoo-r11",
version="#2 Fri Jul 1 12:16:06 CDT 2005", machine="i686"}) = 0
brk(0)                                  = 0x80d6000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_dev=makedev(8, 2), st_ino=378790, st_mode=S_IFREG|0644,
st_nlink=1, st_uid=0, st_gid=0, st_blksize=131072, st_blocks=144, st_size=70150,
st_atime=2005/07/17-11:13:36, st_mtime=2005/07/17-11:07:31,
st_ctime=2005/07/17-11:07:31}) = 0

continued...

events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12,
events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}], 6, 9) = 0
gettimeofday({1121616819, 420443}, NULL) = 0
ioctl(4, FIONREAD, [0])                 = 0
gettimeofday({1121616819, 420507}, NULL) = 0
poll([{fd=5, events=POLLIN}, {fd=4, events=POLLIN}, {fd=9,
events=POLLIN|POLLPRI}, {fd=11, events=POLLIN|POLLPRI}, {fd=12,
events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}], 6, 0) = 0
ioctl(20, 0x80044121, 0xbffff238)       = 0
gettimeofday({1121616819, 420652}, NULL) = 0
gettimeofday({1121616819, 420679}, NULL) = 0
read(17, "\0\0\0\0\3\0\0\0M\0\0\0\2\0\0\0\0\0\0\0\0\0\0\0EMU10K1"..., 72) = 72
ioctl(17, USBDEVFS_CONNECTINFO, 0xbfffee70) = 0
ioctl(17, USBDEVFS_IOCTL, 0xbfffe700)   = 0
ioctl(17, USBDEVFS_IOCTL, 0xbfffe700)   = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
write(2, "\nReceived SIGSEGV\n\nThis could be"..., 141) = 141
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
kill(14700, SIGABRT)                    = 0
--- SIGABRT (Aborted) @ 0 (0) ---
+++ killed by SIGABRT +++
Comment 6 Tony Vroon gentoo-dev 2005-07-30 08:26:35 UTC
If you feel this warrants removal of the package, let me know. As this is the
only action I can take regarding this bug. Upstream appears dead, and the BMP
patch wasn't provided by upstream to begin with.
I am able to reproduce the bug, but I have been unabel to trace it's origin.