Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 94624 - checkfs runs "vgchange -a y" for LVM2 baselayout-1.9.4-r6 but /dev nodes not created I have a workaround.
Summary: checkfs runs "vgchange -a y" for LVM2 baselayout-1.9.4-r6 but /dev nodes not ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-31 07:13 UTC by Karl Roberts
Modified: 2005-05-31 07:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Roberts 2005-05-31 07:13:54 UTC
The checkfs script has been added to the boot runlevel. I have configured LVM to
create a logical volume. However after reboot the logical volume /dev node was
not created.
The script executes correctly however ther step that calls "/sbin/vgchange -a y
>/dev/null" does not create the /dev node. The problem seems to be that
"/sbin/vgchange -a n" was not run on shutdown, and so the vgachange command
"thinks" that the logical volume /dev entries already exist.
I worked around it by adding the line:
   /sbin/vgchange -a n >/dev/null
before the "/sbin/vgchange -a y >/dev/null" line. It now works and creates the
/dev lv's on reboot.

Reproducible: Always
Steps to Reproduce:
1. create a logical volume (as per the gentoo documentation)
2. proove youi can mount it
3. reboot (without typing "vgchange -a n"
4. notice that the /dev mount point doesn't exit
5. run "vgchange -a n" then "vgchange -a y"
6. verify that the /dev mount points now exist
7. hack "vgchange -a n" in front of the "vgchange -a y" line in checkfs
8. reboot
9. verify /dev logical volume mount points now exist

Actual Results:  
as per step 4) above the /dev mount points were not recreated at startup.
the setup of LVMwas correct as proved by steps 5) & 6)

after the checkfs script was hacked by my workaround the mointpoints were
re-created after the boot

Expected Results:  
checkfs script (calling vgachange) should have generated the logical volume
moint points at reboot.

can be worked around as per my description above

emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3-20050110,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r8 i686)
=================================================================
System uname: 2.6.11-gentoo-r8 i686 AMD Athlon(TM) XP 2800+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.2.3-r1,dev-lang/python-2.3.5 [2.3.5 (#1,
Apr 27 2005, 19:19:12)]
ccache version 2.3 [enabled]
dev-lang/python:     2.2.3-r1, 2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2, 2.4.19-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig buildpkg ccache distlocks fixpackages sandbox
sfperms strict"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://ftp.gentoo.skynet.be/pub/gentoo/ http://gentoo.mirror.sdv.fr"
LANG="en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/usr/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib aci acpi alsa apm arts avi berkdb bitmap-fonts bluetooth bonobo
cdr crypt cups curl dga dvd eds emboss encode esd fam fbcon flac flash
foomaticdb fortran freetds gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2
gtkhtml guile hal ifoomaticdb imagemagick imap imlib ipv6 java jpeg junit ldap
libg++ libwww lirc mad mikmod mmx motif mozilla mp3 mpeg mpi mysql ncurses nls
nvidia ogg oggvorbis opengl oss pam pda pdflib perl ployutils png pnp ppds
python quicktime readline samba scanner sdl slang slp snmp socks5 spell sse ssl
svga tcltk tcpd tiff truetype truetype-fonts trusted type1-fonts unicode usb
vorbis wmf xine xml xml2 xmms xv zeo zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 SpanKY gentoo-dev 2005-05-31 07:17:39 UTC
provide a patch (if it's even needed still) against
/usr/portage/sys-fs/lvm2/files/lvm2-{start,stop}.sh