Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 94235 - app-editors/vim-6.3.074 fails compiling because of 'undefined reference' to some Perl stuff
Summary: app-editors/vim-6.3.074 fails compiling because of 'undefined reference' to s...
Status: RESOLVED DUPLICATE of bug 18129
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Other
: High normal (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-27 18:25 UTC by Karol Krizka
Modified: 2005-05-28 00:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Krizka 2005-05-27 18:25:40 UTC
I can't update to vim-6.3.074 I tried recompiling perl but that didn't help.

Reproducible: Always
Steps to Reproduce:
1.emerge -uD vim
2.
3.

Actual Results:  
The following is just the few bottom lines. The actual error output is way
longer but same.

objects/if_perl.o: In function `XS_VIBUF_Append':
if_perl.c:(.text+0x4521): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4530): undefined reference to `Perl_Tstack_sp_ptr'
if_perl.c:(.text+0x453f): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x454e): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4558): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4567): undefined reference to `Perl_Tmarkstack_ptr_ptr'
if_perl.c:(.text+0x4583): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4592): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x45d0): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x45df): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x45ee): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4615): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4624): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4642): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4651): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4662): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x46a6): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x46b5): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x46ce): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x46dd): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4703): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4712): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4734): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4743): undefined reference to `Perl_Tna_ptr'
if_perl.c:(.text+0x474d): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x475c): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4774): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4783): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x47c6): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x47d5): undefined reference to `Perl_Tstack_sp_ptr'
if_perl.c:(.text+0x47f3): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4802): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4823): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4832): undefined reference to `Perl_Tna_ptr'
if_perl.c:(.text+0x483c): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x484b): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4855): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x48b3): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x48c2): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x48cc): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4912): undefined reference to `Perl_croak_nocontext'
if_perl.c:(.text+0x4919): undefined reference to `Perl_Gthr_key_ptr'
objects/if_perl.o: In function `boot_VIM':
if_perl.c:(.text+0x494a): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4959): undefined reference to `Perl_Tstack_sp_ptr'
if_perl.c:(.text+0x4960): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x496f): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4979): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4988): undefined reference to `Perl_Tmarkstack_ptr_ptr'
if_perl.c:(.text+0x49a3): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x49b2): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x49bc): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x49ee): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4a0c): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4a34): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4a52): undefined reference to `Perl_Gthr_key_ptr'
objects/if_perl.o:if_perl.c:(.text+0x4a7a): more undefined references to
`Perl_Gthr_key_ptr' follow
objects/if_perl.o: In function `boot_VIM':
if_perl.c:(.text+0x4ec1): undefined reference to `Perl_Isv_yes_ptr'
if_perl.c:(.text+0x4ecb): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4eda): undefined reference to `Perl_Tstack_base_ptr'
if_perl.c:(.text+0x4ee8): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4ef7): undefined reference to `Perl_Tstack_sp_ptr'
if_perl.c:(.text+0x4f01): undefined reference to `Perl_Gthr_key_ptr'
if_perl.c:(.text+0x4f10): undefined reference to `Perl_Tstack_base_ptr'
collect2: ld returned 1 exit status
make[1]: *** [vim] Error 1
make[1]: Leaving directory `/var/tmp/portage/vim-6.3.074/work/vim63/src'
make: *** [first] Error 2


Expected Results:  
vim should have upgraded

Portage 2.0.51.22-r1 (default-linux/amd64/2005.0, gcc-3.4.3-20050110,
glibc-2.3.5-r0, 2.6.11-gentoo-r9 x86_64)
=================================================================
System uname: 2.6.11-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.12
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.8
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.16
sys-devel/libtool:   1.5.18
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/breakmygentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d a52 aac aalib accessibility acl acpi aim allegro alsa amuled
apache2 athena audiofile avi backward-compatible bash-completion bcmath berkdb
berkkdb bidi bitmap-fonts bl bonobo bzip2 bzlib calendar canna caps cdb cdda
cddb cdio cdparanoia cdparanois cdr cegui cg chasen cjk clanJavaScript clanVoice
cpdflibcrypt cpudetection crypt cscope css ctype cups curl curlwrappers
custom-cflags db2 dba dbase dbm dbx dedicated devil dga dio directfb
directfbdivx4linux djbfft djvu dnd doc double-precision dpms dts dv dvb dvd dvdr
dvdread dxr3 edl eds emacs emacs-w3 emul-linux-x86 encode epiphany esd evo
examples exif expat f77 fam fame fbcon ffmpeg fftw flac flash flatfile
font-server foomaticdb fortan fortran fping fpx freetds freetype freewnn ftp
gaim gb gcj gd gd-external gdbm geoip gg ggi gif giff gii gimpprint ginac glut
gnome gnomedb gnustep gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml
guile hal howl httpd iconv icq ieee1394 imagemagick imap imlib inifile innodb
ipv6 irc ithreads jabber java javascript jbig jikes jp2 jpeg lcms ldap leim
libcaca libedit libg++ libgda libvisual libwww live lj lzo lzw lzw-tiff mad
maildir mailwrapper matroska matrox mbox mcal mcve md5sum mdb migemo mikmod mime
ming mjpeg mng motif mozdevelop mozilla mozillampg3 mozsvg mp3 mpeg mpi mplayer
msn mssql mule mysql mysqli mythtv nas ncurses neXt network nfs nls nntp nowin
nptl nvidia oci8 odbc offensive ofx ogg oggvorbis openal openexr opengl openntpd
oracle oss pam parse-clocks pcmcia pcre pda pdflib perl php physfs plotutils png
pnp posix postgres ppds python qmail quicktime rar readlibe readline real remote
rss rtc ruby samba sblive scanner sdk sdl silc slang sndfile sockets sox speex
spell spl sqlite ssl stats stream subp subtitles svg symlink synlinkszip sysfs
tcltk tcpd tga theora threads tidy tiff tokenizer truetype truetype-fonts
type1-fonts unicode usb userlocales v4l v4l2 vcd videos vidix vlm vorbis wifi
wmf wxgtk1 wxwindows xanim xbase xchatdccserver xchattext xface xine xml xml2
xmlrpc xmms xosd xpm xprint xrandr xsl xv xvid xvmc yahoo yaz yv12 zeo zlib zvbi
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Comment 1 Ciaran McCreesh 2005-05-28 00:54:04 UTC
Recompile perl and libperl with the same USE flags.

*** This bug has been marked as a duplicate of 18129 ***