Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 9369 - Problem updating perl-5.6.1-r7
Summary: Problem updating perl-5.6.1-r7
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Michael Cummings (RETIRED)
Depends on:
Reported: 2002-10-20 03:26 UTC by patg68
Modified: 2003-02-04 19:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description patg68 2002-10-20 03:26:55 UTC
here is the error message while trying to update system :

Making x2p stuff
make[1]: Entering directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1/x2p'
make[1]: *** Pas de r
Comment 1 patg68 2002-10-20 03:26:55 UTC
here is the error message while trying to update system :

Making x2p stuff
make[1]: Entering directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1/x2p'
make[1]: *** Pas de règle pour fabriquer la cible « <interne> », nécessaire pour
« hash.o ». Arrêt.
make[1]: Leaving directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1/x2p'
make: *** [translators] Erreur 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line -2, Exitcode 2
!!! (no error message)
Comment 2 SpanKY gentoo-dev 2002-10-20 09:52:46 UTC
set LC_ALL=C and try again

*** This bug has been marked as a duplicate of 8659 ***
Comment 3 patg68 2002-10-20 17:04:10 UTC
I did that, it didn't solve the problem
Comment 4 Michael Cummings (RETIRED) gentoo-dev 2002-10-28 05:56:38 UTC
What platform is this on? (x86, sparc, etc.)
Comment 5 Michael Cummings (RETIRED) gentoo-dev 2002-11-22 06:37:50 UTC
Is this still a problem? It's been a month since we heard from you patg
Comment 6 Michael v.Ostheim 2002-11-23 12:01:15 UTC
exactly the same problem here. I tried to upgrade from 1.2 to 1.4_rc1, 
following this upgrade guide: failed with the this error messages (with perl-5.6.1-r8 the 
same problem):  
------- Snip --------  
Finding dependencies for perlio.o.  
Finding dependencies for perlapi.o.  
Finding dependencies for miniperlmain.o.  
Finding dependencies for perlmain.o.  
make[1]: Entering directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1'  
echo Makefile.SH cflags.SH config_h.SH makeaperl.SH makedepend.SH makedir.SH  
myconfig.SH writemain.SH pod/Makefile.SH | tr ' ' '\n' >.shlist  
make[1]: Leaving directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1'  
Updating makefile...  
test -s perlmain.c && touch perlmain.c  
cd x2p; make depend  
make[1]: Entering directory  
makefile:144: *** target pattern contains no `%'.  Stop.  
make[1]: Leaving directory `/var/tmp/portage/perl-5.6.1-r7/work/perl-5.6.1/x2p'  
make: *** [depend] Error 2  
!!! ERROR: sys-devel/perl-5.6.1-r7 failed.  
!!! Function src_compile, Line 46, Exitcode 2  
!!! (no error message)  
emerge -e gcc binutils glibc pam-login FAILED.  
-------- Snap ---------  
It's an athlon system, and I tried it with different CFLAG settings. It's the 
same problem with athlon specific optimations and with more conservative i686 
I did this upgrade experiment on a mirror system. On the original 1.2 system 
sys-devel/perl-5.6.1-r7 emerged without problems. 
Comment 7 Michael v.Ostheim 2002-11-25 13:14:27 UTC
Works now. 
I installed a binary package of perl-5.6.1-r7 first, then made a system and 
world update. After that an emerge from source finished without a problem. 
Comment 8 Michael Cummings (RETIRED) gentoo-dev 2002-11-26 09:15:25 UTC
what was in your use flags (or, close the bug if it's irrelivent to you now). 
Just curious for future reference - have another bug open where -berkdb was the 
Comment 9 Michael v.Ostheim 2002-12-01 13:42:30 UTC
USE="-java -svga objprelink cups pda X xv tcltk quicktime mpeg python perl  
oggvorbis opengl sdl jpeg png truetype xml xml2  
dvd avi aalib mpeg encode fbcon"  
For me it's irrelevant now, feel free to close this. But I can't speak for 
patg68, the creator of this bugreport :-).  
Comment 10 Michael Cummings (RETIRED) gentoo-dev 2002-12-01 14:46:06 UTC
patg, still a problem or can this be closed?