Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 93636 - dev-libs/cyrus-sasl-2.1.20-r3 ebuild is broken
Summary: dev-libs/cyrus-sasl-2.1.20-r3 ebuild is broken
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-22 21:05 UTC by Jonathan Adamczewski
Modified: 2005-06-07 22:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Adamczewski 2005-05-22 21:05:26 UTC
There is a typo in the ebuild and other problems.

From pkg_install() :
        newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
        newinitd "${FILESDIR}pwcheck.rc6" pwcheck || \
                die "failed to install pwcheck to /etc/init.d"

There is a missing / in the above, between "${FILESDIR}" and "pwcheck.rc6".

I get the following error after the above is fixed :
...
Making install in saslauthd
make[1]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
make[2]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
/bin/sh ./config/mkinstalldirs /var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/sbin
  /usr/bin/install -c saslauthd
/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/sbin/saslauthd
nroff -mdoc ./saslauthd.mdoc > ./saslauthd.8
/bin/sh ./config/mkinstalldirs
/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/share/man/cat8
mkdir -p -- /var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/share/man/cat8
/usr/bin/install -c -m 644 ./saslauthd.8
/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/share/man/cat8/saslauthd.8
make[2]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
make[1]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
make[1]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[2]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[1]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
install: cannot create regular file
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//etc/conf.d/': Is a directory

!!! ERROR: dev-libs/cyrus-sasl-2.1.20-r3 failed.
!!! Function src_install, Line 3161, Exitcode 1
!!! failed to install /etc/conf.d/saslauthd


Reproducible: Always
Steps to Reproduce:




Portage 1.589-cvs (default-linux/x86/2005.0, gcc-3.4.3-20050110, glibc-2.3.5-r0,
2.6.11-gentoo-r7 i686)
=================================================================
System uname: 2.6.11-gentoo-r7 i686 AMD Athlon(tm) XP 2700+
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 18 2005, 10:51:01)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.8
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.16
sys-devel/libtool:   1.5.18
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -finline-functions -ftracer
-fweb -maccumulate-outgoing-args -fprefetch-loop-arrays"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -finline-functions -ftracer
-fweb -maccumulate-outgoing-args -fprefetch-loop-arrays -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.ccccom.com http://mirror.datapipe.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X aalib adns alsa apache2 apm avi bash-completion berkdb
bitmap-fonts cdr crypt cups curl dba dedicated doc dv dvd dvdr dvdread emboss
encode esd exif faad fam flac foomaticdb fortran gd gdbm gif gnome gphoto2 gpm
gstreamer gtk gtk2 hal imagemagick imlib ipv6 java jpeg junit lcms ldap libg++
libwww matroska mbox mikmod mmx mmx2 motif mozilla mp3 mpeg ncurses network nls
nptl ogg oggvorbis opengl pam pcre pdflib perl png postgres ppds python qt
quicktime readline real samba sasl scanner sdl session slang spell sse ssl tcpd
tetex theora tiff truetype truetype-fonts type1-fonts usb vhosts videos vorbis
win32codecs wmf xine xml xml2 xmms xv xvid zlib userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

Config files: /etc/make.conf, /etc/portage/package.mask,
/etc/portage/package.unmask, /etc/portage/package.keywords
Comment 1 Fernando J. Pereda (RETIRED) gentoo-dev 2005-05-22 23:41:36 UTC
Fixed in CVS, well spotted

Cheers,
Ferdy
Comment 2 Jonathan Adamczewski 2005-05-23 05:41:34 UTC
Ok, you've added the /, but I still get the other error mentioned in the report :

install: cannot create regular file
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//etc/conf.d/': Is a directory
Comment 3 Fernando J. Pereda (RETIRED) gentoo-dev 2005-05-23 10:33:44 UTC
I can't reproduce it. It is working fine here:

---8<---
/bin/install -c -m 644 ./saslauthd.8
/var/tmp/portage/cyrus-sasl-2.1.20-r3/image//usr/share/man/cat8
/saslauthd.8
make[2]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
make[1]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20/saslauthd'
make[1]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[2]: Entering directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
make[1]: Leaving directory
`/var/tmp/portage/cyrus-sasl-2.1.20-r3/work/cyrus-sasl-2.1.20'
man:
gzipping man page: saslauthd.8
gzipping man page: sasl_listmech.3
---8<---

Cheers,
Ferdy
Comment 4 Tuan Van (RETIRED) gentoo-dev 2005-05-23 11:19:39 UTC
> Portage 1.589-cvs
Please "downgrade" to portage ~x86 then try again. Also see bug #69896 if it is
related to your problem.
Comment 5 Jonathan Adamczewski 2005-05-23 20:57:41 UTC
Good point.  The fix mentioned in comment 7 of the bug you linked resolved my
problem.
Comment 6 Jonathan Adamczewski 2005-06-07 22:59:16 UTC
Marking as closed.