Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 93235 - DVDRip 0.52.4 cannot find installed programs.
Summary: DVDRip 0.52.4 cannot find installed programs.
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-19 11:00 UTC by Joerg Plate
Modified: 2005-05-26 05:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Plate 2005-05-19 11:00:20 UTC
1> dvdrip
sh: error while loading shared libraries: libdl.so.2: cannot open shared object
file: No such file or directory

And then a "dvd::rip Dependency check" window pops up where *all* programs
are reported as missing (which is wrong, because transcode, ImageMagick, etc
are installed).

0.52.3-r1 works.


Reproducible: Always
Steps to Reproduce:





Portage 2.0.51.22-r1 (default-linux/amd64/2005.0, gcc-3.4.3-20050110,
glibc-2.3.5-r0, 2.6.11-cko5 x86_64)
=================================================================
System uname: 2.6.11-cko5 x86_64 AMD Athlon(tm) 64 Processor 4000+
Gentoo Base System version 1.6.12
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.1
sys-apps/sandbox:    1.2.8
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r1, 2.15.92.0.2-r3, 2.15.92.0.2-r9
sys-devel/libtool:   1.5.18
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/2/share/config
/usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref
/usr/share/config /var/bind /var/qmail/control /var/run/dspam /var/service
/var/spool/dspam"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=athlon64 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg candy ccache distlocks sandbox strict"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
http://gentoo.inode.at/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://137.226.34.228/gentoo-portage"
USE="cdr fping gnome mplayer ogg rar subtitles xvid"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Geert Vanhaute 2005-05-19 11:20:52 UTC
Same problem on ~x86
Comment 2 Jan Brinkmann (RETIRED) gentoo-dev 2005-05-19 13:06:39 UTC
from their homepage:

        * Tip of the day: if you encounter problems with dvd::rip 0.52.5 on your
system (e.g. Gentoo, or AMD64 architecture) while 0.52.3 works try disabling the
Workaround transcode NPTL bugs switch in dvd::rip's Preferences and restart
dvd::rip.



going to bump the version, though. thanks for reporting anyways! supports our
development
Comment 3 Alexander Skwar 2005-05-26 05:51:14 UTC
(In reply to comment #2)
> from their homepage:
> 
>         * Tip of the day: if you encounter problems with dvd::rip 0.52.5 on your
> system (e.g. Gentoo, or AMD64 architecture) while 0.52.3 works try disabling the
> Workaround transcode NPTL bugs switch in dvd::rip's Preferences and restart
> dvd::rip.
> 

I also ran into this. Since dvdrip is installed WITHOUT this setting, I disagree
that the bug is resolved. Would it be possible to ship dvdrip with this setting set?
> 
> going to bump the version, though. thanks for reporting anyways! supports our
> development