Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 930262 - sci-geosciences/viking-1.10 - terraservermapsource.c: error: assignment to DownloadFileOptions ( )(VikMapSourceDefault , MapCoord ) {aka DownloadFileO
Summary: sci-geosciences/viking-1.10 - terraservermapsource.c: error: assignment to Do...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
: 883117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-04-19 20:56 UTC by Toralf Förster
Modified: 2024-06-26 11:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,19.65 KB, text/plain)
2024-04-19 20:56 UTC, Toralf Förster
Details
emerge-history.txt.xz (emerge-history.txt.xz,60.09 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
environment (environment,80.42 KB, text/plain)
2024-04-19 20:56 UTC, Toralf Förster
Details
etc.clang.tar.xz (etc.clang.tar.xz,1.16 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
etc.portage.tar.xz (etc.portage.tar.xz,15.56 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
logs.tar.xz (logs.tar.xz,13.15 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
qlist-info.txt.xz (qlist-info.txt.xz,71.41 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
sci-geosciences:viking-1.10:20240419-203539.log.xz (sci-geosciences:viking-1.10:20240419-203539.log.xz,33.27 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details
temp.tar.xz (temp.tar.xz,20.84 KB, application/x-xz)
2024-04-19 20:56 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2024-04-19 20:56:04 UTC
too long lines were shrinked:

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -I/usr/lib64/libffi/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-3.0 -I/usr/includ
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -I/usr/lib64/libffi/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-3.0 -I/usr/includ
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -I/usr/lib64/libffi/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-3.0 -I/usr/includ
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -I/usr/lib64/libffi/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-3.0 -I/usr/includ
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -I/usr/lib64/libffi/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-3.0 -I/usr/includ
terraservermapsource.c: In function terraserver_map_source_class_init:
terraservermapsource.c:137:44: error: assignment to DownloadFileOptions * (*)(VikMapSourceDefault *, MapCoord *) {aka DownloadFileOptions * (*)(struct _VikMapSourceDefault *, MapCoord *)} from incompatible pointer type DownloadFileOptions * (*)(VikMapSourceDefault *) {aka DownloadFileOptions * (*)(s
  137 |         parent_class->get_download_options = _get_download_options;
      |                                            ^

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 23.0_desktop_plasma-20240412-195555

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-14 *
clang/llvm (if any):
clang version 18.1.4
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/18/bin
Configuration file: /etc/clang/x86_64-pc-linux-gnu-clang.cfg
/usr/lib/llvm/18
18.1.4
Python 3.11.9
Available Ruby profiles:
  [1]   ruby31 (with Rubygems)
  [2]   ruby32 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.77.1 *
The following VMs are available for generation-2:
1)	Eclipse Temurin JDK 17.0.10_p7 [openjdk-bin-17]
*)	Eclipse Temurin JDK 21.0.2_p13 [openjdk-bin-21]
3)	Eclipse Temurin JDK 8.402_p06 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-bin-17 
  [3]   openjdk-bin-21  system-vm

The Glorious Glasgow Haskell Compilation System, version 9.2.8
php cli (if any):
  [1]   php8.1
  [2]   php8.3 *
go version go1.22.2 linux/amd64

  HEAD of ::gentoo
commit e9ecccce4e219e686fb578774089e8ad50a22ce1
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Fri Apr 19 20:19:07 2024 +0000

    2024-04-19 20:19:07 UTC

emerge -qpvO sci-geosciences/viking
[ebuild  N    ] sci-geosciences/viking-1.10  USE="exif magic nls -doc -geoclue -gps -libexif -oauth"
Comment 1 Toralf Förster gentoo-dev 2024-04-19 20:56:05 UTC
Created attachment 891135 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2024-04-19 20:56:06 UTC
Created attachment 891136 [details]
emerge-history.txt.xz
Comment 3 Toralf Förster gentoo-dev 2024-04-19 20:56:07 UTC
Created attachment 891137 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2024-04-19 20:56:08 UTC
Created attachment 891138 [details]
etc.clang.tar.xz
Comment 5 Toralf Förster gentoo-dev 2024-04-19 20:56:09 UTC
Created attachment 891139 [details]
etc.portage.tar.xz
Comment 6 Toralf Förster gentoo-dev 2024-04-19 20:56:10 UTC
Created attachment 891140 [details]
logs.tar.xz
Comment 7 Toralf Förster gentoo-dev 2024-04-19 20:56:11 UTC
Created attachment 891141 [details]
qlist-info.txt.xz
Comment 8 Toralf Förster gentoo-dev 2024-04-19 20:56:13 UTC
Created attachment 891142 [details]
sci-geosciences:viking-1.10:20240419-203539.log.xz
Comment 9 Toralf Förster gentoo-dev 2024-04-19 20:56:14 UTC
Created attachment 891143 [details]
temp.tar.xz
Comment 10 Hans de Graaff gentoo-dev Security 2024-06-26 11:53:31 UTC
*** Bug 883117 has been marked as a duplicate of this bug. ***
Comment 11 Larry the Git Cow gentoo-dev 2024-06-26 11:55:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=94b3774fa74e57354acc7a747de56984103b3af6

commit 94b3774fa74e57354acc7a747de56984103b3af6
Author:     Hans de Graaff <graaff@gentoo.org>
AuthorDate: 2024-06-26 11:53:55 +0000
Commit:     Hans de Graaff <graaff@gentoo.org>
CommitDate: 2024-06-26 11:55:04 +0000

    sci-geosciences/viking: backport compilation fix
    
    Closes: https://bugs.gentoo.org/930262
    Signed-off-by: Hans de Graaff <graaff@gentoo.org>

 .../viking/files/viking-1.10-terraserver.patch     | 31 ++++++++++++++++++++++
 sci-geosciences/viking/viking-1.10.ebuild          |  5 ++--
 2 files changed, 34 insertions(+), 2 deletions(-)