Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 92844 - emerge xorg-x11-4.3.0-r6 fails on xbox
Summary: emerge xorg-x11-4.3.0-r6 fails on xbox
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-05-16 16:05 UTC by Mark Knecht
Modified: 2005-08-19 04:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mark Knecht 2005-05-16 16:05:51 UTC
Hi. If this is a totally impossible/bogus thing to do for some reason beyond my knowledge set please let me know and I'll go away. ;-)  However I hope you'll help. Thanks in advance and I'll thank you again at the end of this message too!

NOTE: I've listed it as 'major' even though I understand it may or may ot even be a feature to be able to do this. Thanks for understanding. 

I'm attempting to upgrade to more or less a standard Gentoo installation on an xbox version 1.6(b) machine so that I can run MythTV. This revision of the xbox is NOT supported by the cromwell BIOS (as per David Pye - Cromwell BIOS maintainer) so I've started from GentooX since I couldn't start from gentoo-xbox which requires cromwell. GentooX loaded and boots just fine. I changed the profile to 2005.0, sync'ed and loaded a new portage, and then did an emerge system and then emerge world to get totally up to date. I had no problems at all the machine still boots and seems to be working very well. I loaded some simple apps. (vim, pciutils) All that worked fine. My world file is still very simple:

Pro root # cat /var/lib/portage/world
Pro root #

At this point I'm trying to install xorg-x11 but it isn't working. The first problem (or strange aspect at least) is that I seem to be limited to a strange version number - xorg-x11-4.3.0-r6. I do not understand this version. It seems very different from all my other Gentoo machines.

Second the emerge files like this:

install -c -m 0644 libXrender.a /var/tmp/portage/xorg-x11-4.3.0-r6/image//usr/X11R6/lib
ranlib  /var/tmp/portage/xorg-x11-4.3.0-r6/image//usr/X11R6/lib/libXrender.a
+ install -c -m 0444 Xrender.h /var/tmp/portage/xorg-x11-4.3.0-r6/image//usr/X11R6/include/X11/extensions
install in lib/Xrender done
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-4.3.0-r6/work/xc/lib/Xrender'
installing in lib/Xft1...
make[3]: Entering directory `/var/tmp/portage/xorg-x11-4.3.0-r6/work/xc/lib/Xft1'
rm -f xftcfg.o
i686-pc-linux-gnu-gcc -c -mno-mmx  -ansi -pedantic -Wno-return-type -w  -I/usr/include/freetype2  -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                                -D_POSIX_SOURCE -D_XOPEN_SOURCE
                                -D_BSD_SOURCE -D_SVID_SOURCE                    -D_GNU_SOURCE              -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -D_REENTRANT -DXUSE_MTSAFE_API    -DFREETYPE2      -fPIC xftcfg.c
In file included from XftFreetype.h:29,
                 from xftint.h:31,
                 from xftcfg.c:28:
/usr/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h' hasn't been included yet!"
/usr/include/freetype2/freetype/freetype.h:21:2: #error "Please always use macros to include FreeType header files."
/usr/include/freetype2/freetype/freetype.h:22:2: #error "Example:"
/usr/include/freetype2/freetype/freetype.h:23:2: #error "  #include <ft2build.h>"
/usr/include/freetype2/freetype/freetype.h:24:2: #error "  #include FT_FREETYPE_H"
make[3]: *** [xftcfg.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-4.3.0-r6/work/xc/lib/Xft1'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-4.3.0-r6/work/xc/lib'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-4.3.0-r6/work/xc'
make: *** [install] Error 2

!!! ERROR: x11-base/xorg-x11-4.3.0-r6 failed.
!!! Function src_install, Line 628, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

Pro root # 

There doesn't seem to be a testing version:

Pro root # ACCEPT_KEYWORDS="~x86" emerge -pv xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] x11-base/xorg-x11-4.3.0-r6  -3dfx -3dnow -bindist -cjk -debug -doc -ipv6 +mmx +nls +pam -sdk +sse -static +truetype +xml2 0 kB [1]

Total size of downloads: 0 kB
Portage overlays:
 [1] /usr/share/gentoox/portage
Pro root #

I am still using the GentooX kernel. If this is possibly effected by the kernel I'm running please let me know and I'll see if I can figure out how to replace the GentooX kernel with something newer. I built a 2.6 kernel under gentoo-xbox but with no cromwell support was unable to try booting it.


Reproducible: Always
Steps to Reproduce:
1.emerge xorg-x11

Actual Results:  
As above.

Expected Results:  
Would like it to build xorg-x11-6.8.X correctly.

Pro root # emerge info
Portage (default-linux/x86/2005.0/2.4, gcc-3.3.5-20050130,
glibc-, 2.4.22-xbox-Gentoox i686)
System uname: 2.4.22-xbox-Gentoox i686 Celeron (Coppermine)
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May 16 2005, 11:25:47)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/libtool:   1.4.3-r4, 1.5.16
virtual/os-headers:  2.4.19, 2.4.22-r1
CFLAGS="-march=pentium3 -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 X aalib alsa apm arts avi berkdb bitmap-fonts crypt cups dvd emboss
encode foomaticdb fortran gdbm gif gpm gtk gtk2 imlib java jpeg kde libg++
libwww mad mikmod mmx motif mp3 mpeg ncurses nls oggvorbis opengl oss pam pdflib
perl png python qt quicktime readline samba sdl slang spell sse ssl svga tcpd
truetype truetype-fonts type1-fonts usb xml2 xmms xv zlib userland_GNU
kernel_linux elibc_glibc"

Pro root #
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-05-16 16:53:59 UTC
Do you really expect us to support a package that hasn't been in the tree for seven months?

The reason you're seeing the combination of 4.3.0 with xorg-x11 is that xfree was moved to xorg-x11. Uninstall it, and emerge a newer one.

Make sure you're building xorg 6.8 or higher. If you still get this problem, reopen the bug. The specific failure you're seeing is related to a need to upgrade freetype.
Comment 2 Mark Knecht 2005-05-16 17:15:12 UTC
Donnie - No, I do NOT expect you to support anything that's no longer in
portage. I'm trying to figure out how to get the machine to load the right
xorg-x11-6.8.0-rX jsut like you want me to. I don't see yet what I'm doing wrong:

Pro root # qpkg -I | grep xfree
Pro root #

Pro root # qpkg -I | grep x11
x11-base/opengl-update *
x11-misc/ttmkfdir *
Pro root #

Tell me what to uninstall and I'll do it right away.

Sorry for being so dense!
Comment 3 Mark Knecht 2005-05-16 17:21:08 UTC
Is this the stuff? Do I just delete this stuff? Or better yet should I remove
this gentoox/portage overlay? I've no need for it as far as I know. this is the
only thing in it.

Pro portage # ls /usr/share/gentoox
Pro portage # ls /usr/share/gentoox/portage/
Pro portage # ls /usr/share/gentoox/portage/x11-base/x
xfree     xorg-x11
Pro portage # ls /usr/share/gentoox/portage/x11-base/xfree/
ChangeLog  Manifest  files  metadata.xml  xfree-4.3.0-r6.ebuild
Pro portage # ls /usr/share/gentoox/portage/x11-base/xorg-x11/
ChangeLog  Manifest  files  metadata.xml  xorg-x11-4.3.0-r6.ebuild
Pro portage #
Comment 4 Mark Knecht 2005-05-16 17:26:39 UTC
OK - by removing the portage overlay I'm now pointing at xorg-x11-6.8 but it's
masked. Possibly that's because of the kernel or something else I've got on here.

Thanks for the help. This is now forward progress. I'll either upgrade the
kernel (possibly a little difficult on xbox) or I'll build the masked version
and see what happens.

Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2005-05-16 19:23:40 UTC
It may be masked in your package.mask in your profile, or in /etc/portage. I
have no idea what xbox setups look like.
Comment 6 Chris Bainbridge (RETIRED) gentoo-dev 2005-08-19 04:25:11 UTC
Xbox setups are just x86. Gentoox, however, is totally different, it doesn't use
the gentoo xbox profile and requires a load of hacks and the 'magic' update
system to put them there. To install gentoo it's best to start from scratch,
either with an empty partition or chroot.