Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 92772 - beep-media-player: mpg123-plugin doesn't work
Summary: beep-media-player: mpg123-plugin doesn't work
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-16 02:51 UTC by Mirko Guenther
Modified: 2005-07-01 14:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Guenther 2005-05-16 02:51:49 UTC
in beep-media-player-0.9.7-r5 the mpg123-Inputplugin are compiled but not load, so  I can not play mp3-files
under x86 it works but not under amd64 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jon Portnoy (RETIRED) gentoo-dev 2005-05-16 02:54:44 UTC
Wrong product
Comment 2 Tony Vroon gentoo-dev 2005-05-16 14:30:17 UTC
You will have to post emerge info before I can help you.
Please read the bug posting instructions before pushing the submit button.
Comment 3 Mirko Guenther 2005-05-16 23:21:23 UTC
my emerge info:
Portage 2.0.51.19 (default-linux/amd64/2005.0, gcc-3.4.3-20050110,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.11-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.7.0
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May 12 2005, 08:40:13)]
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r8
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=athlon64 -pipe -ffast-math -fomit-frame-pointer -mfpmath=sse
-fpeel-loops -funswitch-loops -funit-at-a-time -ftracer -minline-all-stringops
-maccumulate-outgoing-args -fforce-addr"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/2/share/config
/usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -march=athlon64 -pipe -ffast-math -fomit-frame-pointer
-mfpmath=sse -fpeel-loops -funswitch-loops -funit-at-a-time -ftracer
-minline-all-stringops -maccumulate-outgoing-args -fforce-addr"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache digest distlocks sandbox strict"
GENTOO_MIRRORS="http://ftp.easynet.nl/mirror/gentoo/
http://mirror.switch.ch/mirror/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/"
LANG="german"
LC_ALL="de_DE@euro"
LINGUAS="de nds"
MAKEOPTS="-s -j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/gentoo-de /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 3dnow 3dnowex X Xaw3d aalib acpi alsa apm avi berkdb bitmap-fonts
bonobo cdr crypt cups curl directfb dvd dvdr encode faad fam fbcon flac
font-server foomaticdb fortran gd gd-external gdbm gif gimpprint gpm gstreamer
gtk gtk2 hal ieee1394 imagemagick imlib ipv6 ithreads java jikes joystick jp2
jpeg jpeg2k kde kdeenablefinal kdexdeltas libwww lm_sensors logitech-mouse lzw
lzw-tiff mad mikmod mmx mng motif mp3 mpeg ncurses nls nptl oav ogg oggvorbis
opengl oss pam perl pic pie png ppds python qt quicktime readline samba sdl
slang socks5 speex sse sse2 ssl svg sysfs tcltk tcpd tetex theora threads tiff
truetype truetype-fonts type1-fonts unicode usb userlocales v4l vorbis wmf xft
xml xml2 xosd xpm xprint xrandr xscreensaver xv xvid zlib video_cards_nvidia
linguas_de linguas_nds userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS

I've also testet it with 'CFLAGS="-O3 -march=athlon64 -pipe"'. Same Problem
Comment 4 Tony Vroon gentoo-dev 2005-05-17 00:16:52 UTC
You will have to compile all of your system with reasonable CFLAGS if you want
support.
Comment 5 Tony Vroon gentoo-dev 2005-05-17 00:18:35 UTC
That would involve dropping -ffast-math and -mfpmath at the *very* least, and
then running emerge -e world. Bug reports filed with those two flags in CFLAGS
will not be honoured.
Marking as invalid.
Comment 6 Mirko Guenther 2005-06-06 01:31:13 UTC
The problem is solved. It wasn't the compilerflags. The problem was caused by
some USE-flage, with I've played.
Comment 7 Fredrik Smedberg 2005-07-01 14:51:18 UTC
Do this USE="-mmx" and Beep Media Player should have a working libmpg123.so plugin.