Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 92573 - app-admin/gamin version bump to 0.1.0
Summary: app-admin/gamin version bump to 0.1.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 93587
  Show dependency tree
 
Reported: 2005-05-14 03:35 UTC by Daniel Drake (RETIRED)
Modified: 2005-06-20 10:43 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gamin-0.1.0.ebuild (gamin-0.1.0.ebuild,1.16 KB, text/plain)
2005-05-14 03:35 UTC, Daniel Drake (RETIRED)
Details
gamin-0.1.0.ebuild (noinotify USE flag) (gamin-0.1.0.ebuild,1.87 KB, text/plain)
2005-05-15 05:34 UTC, Mark Rosenstand
Details
gamin-0.1.0.ebuild (gamin-0.1.0.ebuild,1.26 KB, text/plain)
2005-05-23 13:11 UTC, Daniel Drake (RETIRED)
Details
gamin-0.1.0-flow-control.patch (gamin-0.1.0-flow-control.patch,4.81 KB, patch)
2005-05-23 13:11 UTC, Daniel Drake (RETIRED)
Details | Diff
gamin-0.1.0-cvs-upgrade.patch (gamin-0.1.0-cvs-upgrade.patch,3.43 KB, patch)
2005-05-23 14:38 UTC, Giacomo Perale
Details | Diff
gamin-0.1.0-r1.patch (gamin-0.1.0-r1.patch,1.45 KB, patch)
2005-05-26 16:18 UTC, Diego Elio Pettenò (RETIRED)
Details | Diff
gamin-0.1.0-freebsd.patch (gamin-0.1.0-freebsd.patch,51.87 KB, patch)
2005-05-26 16:19 UTC, Diego Elio Pettenò (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Drake (RETIRED) gentoo-dev 2005-05-14 03:35:12 UTC
This requires inotify 0.23-6 which is not available in portage yet, so if its added to portage, it needs to be in package.mask.

gentoo-sources-2.6.12 will include inotify 0.23-7 or whatever the newest one is at time of release.
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2005-05-14 03:35:42 UTC
Created attachment 58855 [details]
gamin-0.1.0.ebuild

Nothing needed changing except the info messages
Comment 2 Mark Rosenstand 2005-05-15 05:34:23 UTC
Created attachment 58948 [details]
gamin-0.1.0.ebuild (noinotify USE flag)

Optional (although heavily encouraged) inotify usage. I got it imported to
gentopia yesterday.
Comment 3 Mark Rosenstand 2005-05-15 08:39:41 UTC
Comment on attachment 58948 [details]
gamin-0.1.0.ebuild (noinotify USE flag)

Never mind. joem didn't like the idea of configurable inotify support.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2005-05-23 13:11:03 UTC
Created attachment 59654 [details]
gamin-0.1.0.ebuild

Latest bugfix from John McCutchan
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2005-05-23 13:11:25 UTC
Created attachment 59655 [details, diff]
gamin-0.1.0-flow-control.patch

The actual fix
Comment 6 Giacomo Perale 2005-05-23 14:38:03 UTC
Created attachment 59663 [details, diff]
gamin-0.1.0-cvs-upgrade.patch

includes two CVS fixes since the release of 0.1.0

* server/gam_poll.c: (unregister_node), factorize code and make sure node are
unregistered correctly. Fix crash from bug #303932.
* libgamin/gam_data.c: (gamin_data_conn_event): Fix req->state vs req->type
thinko.
Comment 7 Steev Klimaszewski gentoo-dev 2005-05-23 14:50:51 UTC
Is this going to go into the gentopia overlay as well?
Comment 8 Doug Goldstein gentoo-dev 2005-05-23 19:51:37 UTC
Dan, any chance we can give ya commit access or anything? And you toss them in
there? It will give you a larger test base.
Comment 9 Doug Goldstein gentoo-dev 2005-05-23 19:56:30 UTC
Dan, to Gentopia that is.

Added ebuild to Gentopia overlay as gamin-0.1.0-r1.ebuild with both patches applied.
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-05-26 16:07:28 UTC
fam is not going to work fine on Gentoo/FreeBSD, I'll submit a patch to this 
ebuild and a patch to gamin sourced (cumulative of ports patches) as gamin is 
probably the best way to go for us. 
Comment 11 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-05-26 16:18:50 UTC
Created attachment 59898 [details, diff]
gamin-0.1.0-r1.patch

(svn) patch over gamin-0.1.0-r1 ebuild, which adds G/FreeBSD support.
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-05-26 16:19:57 UTC
Created attachment 59899 [details, diff]
gamin-0.1.0-freebsd.patch

Patch with all the FreeBSD changes. Works fine on Linux (and probably
Gentoo/kFreeBSD), too.
Comment 13 gad.kadosh 2005-06-18 04:19:27 UTC
gamin-0.1.1 is out, but it doesn't look like kernel 2.6.12 has inotify ?
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2005-06-18 08:01:48 UTC
Correct. inotify has never been in the upstream kernel.
Comment 15 Claessens Xavier 2005-06-18 22:03:20 UTC
gentoo-sources-2.6.12 is out with inotify 0.23-12. So gamin-0.1.0 can now be in
portage in ~x86
Comment 16 Steev Klimaszewski gentoo-dev 2005-06-19 01:48:11 UTC
I'm not sure if it works for you Claessens, however, here, I have
gentoo-sources-2.6.12, and gamin-0.1.0-r1 (and even tried gamin CVS) and I am
back to the problem that I had before with mm-sources, in which, gamin no longer
notifies/reads my usb disk insertion/pmount no longer automounts the disk.

steev@mebius ~ $ pmount-hal /org/freedesktop/Hal/devices/volume_uuid_1C98_52D7
Error: device /dev/sda1 is not removable

Is what I get (and got with mm-sources, but due to mm-sources nature, I didn't
file a bug, simply bumped down to 2.6.11-r11, which worked fine once I applied
the proper patch for inotify to the kernel)  It seems like the new inotify patch
in gentoo-sources SHOULD work, but apparently, something is missing somewhere. 
Watching both gamin and pmount closely to see.
Comment 17 Daniel Drake (RETIRED) gentoo-dev 2005-06-19 02:10:10 UTC
I think you are running into a HAL bug which is fixed in hal 0.5. Either way,
it's certainly not related to gamin.
Comment 18 Claessens Xavier 2005-06-19 12:27:59 UTC
works for me yes ! just tried gamin-0.1.0.ebuild and gamin-0.1.0-flow-control.patch.

i've sys-apps/hal-0.4.8 and usb key are correctly monted and the icon appeare on
the gnome desktop witch was buggy with preview versions of kernel/gamin.
Comment 19 Daniel Drake (RETIRED) gentoo-dev 2005-06-20 10:43:26 UTC
gamin-0.1.1 is now included in the tree