Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 92065 - emerge libquicktime crashes during compile with error cannot find-lGL.
Summary: emerge libquicktime crashes during compile with error cannot find-lGL.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 92252 93185 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-05-09 19:27 UTC by lj wilson
Modified: 2005-06-05 12:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lj wilson 2005-05-09 19:27:50 UTC
emerge libquicktime crashes during compiling with error cannot find-lGL.
i think that it cant find opengl libraries. /usr/lib/libGL.so.1 exist and i've tried re-linking it to /usr/lib/opengl/ati/lib/libGL.so.1, /usr/lib/opengl/xorg-x11/lib/libGL.so.1, /usr/lib/opengl/ati/lib/libGL.so.1.2 & /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2 with the same error msg.

Reproducible: Always
Steps to Reproduce:
1. emerge ati-drivers
2. emerge libquicktime
3. 

Actual Results:  
i686-pc-linux-gnu-gcc -O3 -pipe -march=athlon-xp -fomit-frame-pointer
-fprefetch-loop-arrays -ffast-math -fforce-addr -m3dnow -msse -mfpmath=sse
-frerun-cse-after-loop -frerun-loop-opt -o .libs/lqtplay lqtplay.o 
../src/.libs/libquicktime.so -lXaw -lXv /usr/lib/libGLU.so -L/usr/lib -lSM -lICE
-lXmu -lXt -lXext -lXi -lGL -lX11 /usr/lib/libasound.so -lpthread -lm -lz -ldl
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -lGL
collect2: ld returned 1 exit status
make[3]: *** [lqtplay] Error 1
make[3]: Leaving directory
`/var/tmp/portage/libquicktime-0.9.4/work/libquicktime-0.9.4/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/var/tmp/portage/libquicktime-0.9.4/work/libquicktime-0.9.4/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/libquicktime-0.9.4/work/libquicktime-0.9.4'
make: *** [all] Error 2

!!! ERROR: media-libs/libquicktime-0.9.4 failed.
!!! Function src_compile, Line 58, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
compile the library and install it.

lwilson@gwenerever lwilson $ emerge -p info

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(TM) XP 2200+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  2 2005, 20:20:10)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -pipe -march=athlon-xp -fomit-frame-pointer -fprefetch-loop-arrays
-ffast-math -fforce-addr -m3dnow -msse -mfpmath=sse -frerun-cse-after-loop
-frerun-loop-opt"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/fax /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -pipe -march=athlon-xp -fomit-frame-pointer -fprefetch-loop-arrays
-ffast-math -fforce-addr -m3dnow -msse -mfpmath=sse -frerun-cse-after-loop
-frerun-loop-opt"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d aalib acl acpi afs aim alsa apm arts audiofile avi bcmath
berkdb bidi bitmap-fonts bmp bonobo bzlib calendar caps cdr cross crypt cscope
ctype cups curl curlwrappers dba dbase dbm dbx dga dio directfb divx4linux doc
dvb dvd dvdr eds emacs emacs-w3 emboss encode esd ethereal evo exif fam fbcon
flac flash flatfile foomaticdb fortran ftp gb gd gdbm ggi gif gimpprint ginac
gmp gnome gnutils gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile icq ifc
imagemagick imap imlib infile innodb iodbc ipv6 jabber jack java jikes joystick
jpeg kde kerberos lcms ldap leim lesstif libedit libg++ libgda libwww lirc mad
maildir mailwrapper mbox mcal memlimit mhash mikmod mime ming mmx mng
mnogosearch motif mozilla mp3 mpeg msn mule mysql mysqli nas ncurses nls nmap
odbc ofx ogg oggvorbis openal opengl oscar oss pam pcre pda pdflib perl
plotutils png portaudio posix ppds python qt quicktime readline sasl scanner sdl
shared simplexml slang slp sndfile snmp soap sockets socks5 spell sse ssl svg
svga szip tcltk tcpd telex tetex theora tidy tiff truetype truetype-fonts
type1-fonts unicode usb videos vorbis wmf wxwindows x86 xine xinerama xml xml2
xmlrpc xmms xosd xpm xprint xsl xv xvid yahoo yaz zlib userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Luca Barbato gentoo-dev 2005-05-10 06:13:30 UTC
please use opengl-update to reset it

opengl-update xorg-x11 should help.

if you are using another opengl implementation reemerge it and the issue the correct opengl-update command.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-05-11 08:49:37 UTC
*** Bug 92252 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-05-19 04:30:57 UTC
*** Bug 93185 has been marked as a duplicate of this bug. ***
Comment 4 Jan Brinkmann (RETIRED) gentoo-dev 2005-06-05 12:34:03 UTC
test with lu_zero's suggestions, feel free to reopen if the problem persists.