Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 91320 - wxGTK 2.6.0 doesn't compile
Summary: wxGTK 2.6.0 doesn't compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-03 08:46 UTC by Joerg Erdmenger
Modified: 2005-05-03 19:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Erdmenger 2005-05-03 08:46:17 UTC
emerging x11-libs/wxGTK-2.6.0 fails. After looking at other bug reports I unmerged wxGTK-2.4.2 and all packages depending on it. I also played with the LANG env variable since that is one of the few things non standard on my system but I keep getting the same result

Reproducible: Always
Steps to Reproduce:
1. emerge wxGTK
2.
3.

Actual Results:  
REENTRANT -Wall -Wno-ctor-dtor-privacy
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/dbtable.cpp
./bk-deps i686-pc-linux-gnu-g++ -c -o monodll_debugrpt.o -I.pch/wxprec_monodll
-D__WXGTK__            -DwxUSE_BA                                         SE=1
-DWXMAKINGDLL -fPIC -DPIC -DWX_PRECOMP -DNO_GCC_PRAGMA -DGTK_NO_CHECK_CASTS
-Ilib/wx/include/gtk2-ansi-rele                                         ase-2.6
-I/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/include -DXTHREADS
-D_REENTRANT -DXUSE_MTSAFE_API -p                                         thread
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/                                        
include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -D_FILE_OF                                        
FSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -I/usr/X11R6/include
-march=pentium3 -pipe -O2 -fomit-frame-po                                      
  inter -fforce-addr -frename-registers -fprefetch-loop-arrays
-falign-functions=64 -pthread -I/usr/include/SDL -D                            
            _REENTRANT -Wall -Wno-ctor-dtor-privacy
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cp       
                                 p
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp: In
member function `bool wxDebugRepor                                        
t::AddText(const wxString&, const wxString&, const wxString&)':
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp:289:
error: `wxFFile' undeclared (firs                                         t use
this function)
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp:289:
error: (Each undeclared identifie                                         r is
reported only once for each function it appears in.)
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp:289:
error: expected `;' before "file"
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp:290:
error: `file' undeclared (first u                                         se
this function)
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp: At
global scope:
/var/tmp/portage/wxGTK-2.6.0/work/wxWidgets-2.6.0/src/common/debugrpt.cpp:57:
warning: 'gs_buildOptionsCheck' de                                         fined
but not used
make: *** [monodll_debugrpt.o] Error 1

!!! ERROR: x11-libs/wxGTK-2.6.0 failed.
!!! Function configure_build, Line 57, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
successfull emerge

Portage 2.0.51.21 (default-linux/x86/2005.0, gcc-3.4.3, glibc-2.3.3.20040420-r0,
2.6.9 i686)
=================================================================
System uname: 2.6.9 i686 Intel(R) Pentium(R) M processor 1600MHz
Gentoo Base System version 1.4.16
dev-lang/python:     2.3.3-r1
sys-apps/sandbox:    1.2.1-r2
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.90.0.1.1-r3
sys-devel/libtool:   1.5.2-r5
virtual/os-headers:  2.6.7-r4
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -pipe -O2 -fomit-frame-pointer -fforce-addr
-frename-registers -fprefetch-loop-arrays -falign-functions=64"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=pentium3 -pipe -O2 -fomit-frame-pointer -fforce-addr
-frename-registers -fprefetch-loop-arrays -falign-functions=64"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://mir.zyrianes.net/gentoo/ ftp://mir.zyrianes.net/gentoo/"
LANG="en"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/myportage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X X509 Xaw3d adns aim alsa apache2 avi berkdb bitmap-fonts bluetooth
cdparanoia cdr crypt cups doc dvd dvdr emacs foomaticdb gcj gstreamer gtk2 icq
imagemagick imap imlib2 innodb jabber jack java jikes jpeg kde maildir mime
motif mozilla mule mysql ncurses nls nptl ogg opengl pam png postgres sasl sdl
speedo ssl subversion tiff truetype truetype-fonts type1 type1-fonts unicode
wifi win32codecs wxwindows xine xml2 xslt xv zeroconf linguas_de userland_GNU
kernel_linux libc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS, MAKEOPTS
Comment 1 Rob Cakebread (RETIRED) gentoo-dev 2005-05-03 09:46:32 UTC
Please try it with CFLAGS="-march=pentium3 -pipe -O2" and let us know if that works. If that doesn't work, please post the output of "emerge -pv =x11-libs/wxGTK-2.6.0" so I can see what USE flags were picked up.

If anyone else has this problem, unmerging 2.4.2 probably isn't a good idea. Only three packages use wxGTK-2.6.0 at the moment, so 2.4.2 is still needed by the 27 other wx* packages in portage.

Comment 2 Ben Meek 2005-05-03 13:19:09 UTC
I just tried with CFLAGS="-O2 -march=athlon-xp -pipe" opposed to my usual CFLAGS="-O3 -march=athlon-xp -msse -mmmx -m3dnow -momit-leaf-frame-pointer -fomit-frame-pointer -funroll-loops -ftracer -ffast-math -fprefetch-loop-arrays -finline-limit=600 -mfpmath=387 -pipe" and recieved the same error as the original poster.

# emerge -pv x11-libs/wxGTK

These are the packages that I would merge, in order:

Calculating dependencies  ...done!
[ebuild  NS   ] x11-libs/wxGTK-2.6.0  -debug -dmalloc -doc -gnome +gtk2 -joystick +jpeg -odbc +opengl +png -sdl -tiff +unicode -wxgtk1 -zlib 0 kB


Comment 3 Rob Cakebread (RETIRED) gentoo-dev 2005-05-03 16:20:27 UTC
Could one of you please try emerging again and tell me if it says yes or no for these two lines? Its about 40 lines down after the emerge starts, then you can quit:

checking for --enable-ffile... yes
checking for --enable-file... yes
Comment 4 Rob Cakebread (RETIRED) gentoo-dev 2005-05-03 16:47:56 UTC
I'm testing out this change, if you try it and it works, please let me know. Its just a one line change in /usr/portage/eclass/wxlib.eclass

--- wxlib.eclass.org    2005-05-03 16:44:39.763513912 -0700
+++ wxlib.eclass        2005-05-03 16:45:09.837941904 -0700
@@ -85,6 +85,7 @@
        fi
        ${S}/configure --enable-monolithic \
                --host=${CHOST} \
+               --disable-debugreport \
                --libdir=/usr/$(get_libdir) \
                --prefix=/usr \
                --infodir=/usr/share/info \
Comment 5 Ben Meek 2005-05-03 18:12:05 UTC
Making the change to /usr/portage/eclass/wxlib.eclass makes it compile fine.

And this does appear:
checking for --enable-ffile... yes
checking for --enable-file... yes
Comment 6 Rob Cakebread (RETIRED) gentoo-dev 2005-05-03 19:12:29 UTC
Ok, thanks Ben. I committed the new eclass to CVS. I'm not sure why a few people had this problem but after some research debugreport doesn't seem necessary and wxpython suggests disabling it anyways.

Feel free to re-open if you get the same error.