Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 906931 - dev-util/yamllint-1.31.0 fails tests (MUSL-SYSTEM)
Summary: dev-util/yamllint-1.31.0 fails tests (MUSL-SYSTEM)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-05-22 08:48 UTC by Agostino Sarubbo
Modified: 2024-06-29 06:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,108.37 KB, text/plain)
2023-05-22 08:48 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-05-22 08:48:01 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-util/yamllint-1.31.0 fails tests (MUSL-SYSTEM).
Discovered on: amd64 (internal ref: tinderbox_musl)

NOTE:
(MUSL-SYSTEM) in the summary means that bug was found on a machine that runs MUSL libc but this bug MAY or MAY NOT BE related to musl.
Comment 1 Agostino Sarubbo gentoo-dev 2023-05-22 08:48:03 UTC
Created attachment 862172 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-05-22 08:48:04 UTC
Error(s) that match a know pattern:


        except locale.Error:  # pragma: no cover
E       AssertionError: 1 != 0
E   AssertionError: Lists differ: [3:1: wrong ordering of key "T-shirt" in m[82 chars]ing)] != []
E   AssertionError: Lists differ: [4:1: wrong ordering of key "hais" in mapping (key-ordering)] != []
FAILED tests/rules/test_key_ordering.py::KeyOrderingTestCase::test_locale_accents
FAILED tests/rules/test_key_ordering.py::KeyOrderingTestCase::test_locale_case
FAILED tests/test_cli.py::CommandLineTestCase::test_run_with_locale - Asserti...
Comment 3 Hans de Graaff gentoo-dev Security 2024-06-29 06:10:17 UTC
I can't reproduce this with the currently available versions (1.32.0 and newer). Please re-open if this is still an issue with those versions.