Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 904228 - sys-boot/grub: Grub fails to detect LVM volumes with: error: disk `lvmid/*/*' not found
Summary: sys-boot/grub: Grub fails to detect LVM volumes with: error: disk `lvmid/*/*'...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Mike Gilbert
Keywords: PATCH
Depends on:
Reported: 2023-04-12 13:14 UTC by Horst Prote
Modified: 2023-07-11 00:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Patch (grub-2.06-lvm-volumes.patch,433 bytes, patch)
2023-04-12 13:14 UTC, Horst Prote
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Horst Prote 2023-04-12 13:14:18 UTC
Created attachment 859936 [details, diff]

See also

Citation from the Bug:
When handling a regular LVM volume, Grub can fail with the message:
error: disk `lvmid/******-****-****-****-****-****-
****/******-****-****-****-****-****-******' not found.

If the condition which triggers this exists, grub-probe will report the error mentioned above. Similarly, the grub boot code will fail to detect LVM volumes, resulting in a failure to boot off of LVM disks/partitions. The condition can be created on any LVM VG by an LVM configuration change, so any system with /boot on LVM can become unbootable at 'any' time (after any LVM configuration change).

==== Cause ===
The problem is caused by an incorrect computation of mda_end in lvm.c, when the metadata area wraps around.
--- Citation End ---

I was hit by this yesterday, then tried the proposed fix on grub-2.06-r6 (see attached patch) which worked for me.