Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90414 - no rsync nor grub nor lilo in the next Installation CD
Summary: no rsync nor grub nor lilo in the next Installation CD
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: All All
: High enhancement with 2 votes (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 107980 115048 179628 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-25 12:13 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2011-01-19 23:58 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2005-04-25 12:13:51 UTC
Please put both:
- rsync
- grub-install
- lilo
- mkfs/fsck -for FAT

in the installation CD of gentoo. I cant believe a Knoppix CD is more apropriate to repair a broken Gentoo than the Install CD of Gentoo itself !!!
Comment 1 roger55 (RETIRED) gentoo-dev 2005-04-26 13:10:52 UTC
The install cd is meant to provide what is needed to *install* gentoo.
beejay is working on a rescue cd you might want to try at some point.



- rsync:
that's useful but not needed for installing gentoo

- grub-install:
not needed as you can mount your partitions and chroot just like you do when installing. I much prefer the grub> comandline.

- lilo:
see above

- mkfs/fsck -for FAT:
you didn't install gentoo on FAT did you?

For beejay's project dolphin, the upcoming rescue cd see:
http://bugs.gentoo.org/show_bug.cgi?id=90053


Roger (roger55)

Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2005-04-26 13:14:23 UTC
Sorry, the Gentoo Install CD is not a rescue disk.  It is designed for compact size and for installing Gentoo.

You're comparing a 50MB ISO to a 700MB environment.  That's like saying that your Ferrari is faster than your bicycle.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-10-03 06:43:50 UTC
*** Bug 107980 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-12-10 01:37:12 UTC
*** Bug 115048 has been marked as a duplicate of this bug. ***
Comment 5 Justin R. Pessa 2007-01-09 20:29:17 UTC
(In reply to comment #1)
> The install cd is meant to provide what is needed to *install* gentoo.
> beejay is working on a rescue cd you might want to try at some point.
> 
> 
> 
> - rsync:
> that's useful but not needed for installing gentoo

I fail to see how rsync is not useful for installing Gentoo when my stage tarballs are kept on an rsync server... hmm, weird. 

> 
<snip>
Comment 6 Justin R. Pessa 2007-01-09 20:30:37 UTC
(In reply to comment #5)
> (In reply to comment #1)
> > The install cd is meant to provide what is needed to *install* gentoo.
> > beejay is working on a rescue cd you might want to try at some point.
> > 
> > 
> > 
> > - rsync:
> > that's useful but not needed for installing gentoo
> 
> I fail to see how rsync is not useful for installing Gentoo when my stage
> tarballs are kept on an rsync server... hmm, weird. 
> 
> > 
> <snip>
> 

correction: not needed.
Comment 7 Andrew Gaffney (RETIRED) gentoo-dev 2007-01-09 21:49:17 UTC
Was something unclear about Chris's reply in comment 2? The install (a.k.a. minimal) CD is meant to be as small as possible and used for installs. If you want a CD with lots of goodies, you can use the LiveCD or something like Knoppix.
Comment 8 Justin R. Pessa 2007-01-09 22:28:27 UTC
The reply was quite clear. 

I am simply stating that the minimal CD should include rsync as it is often a desirable tool that may be needed along the way during an install. 

I am not interested in adding "goodies" to the minimal install CD, but I do not see how rsync is not included. Is including rsync on the minimal CD seriously asking for too much? Does rsync constitute a "goodie"? 

I know there are plenty of people who feel the same way I do about this issue.
Comment 9 DEMAINE Benoît-Pierre, aka DoubleHP 2007-01-09 22:33:32 UTC
(In reply to comment #8)
> see how rsync is not included. Is including rsync on the minimal CD seriously
> asking for too much? Does rsync constitute a "goodie"? 
> 
> I know there are plenty of people who feel the same way I do about this issue.
> 

For many people, vim and Bash are goodies ... forget it. I dont either see how adding 500k on a 40MB CD is erally a big deal, but they do, so shut up. They know what they do. If I ask for sshd, I fear they may take cat and dd off the disk.

Stuck to WONTFIX.
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2007-01-10 13:23:18 UTC
Why are people even *looking* at this crap over a year after the last comment?

We have a LiveCD now that provides *all* of these and *more*...

The Minimal InstallCD is *exactly* that... just enough to get the box booted to start the install.  If you want features, you use the LiveCD.  If you want "it boots so I can wget and chroot to install" you use Minimal.  We have no intentions on changing that... ever.  As I said almost 2 *years* ago... the Install CD is *not* a rescue disk.
Comment 11 Justin R. Pessa 2007-01-10 16:36:13 UTC
(In reply to comment #10)
> Why are people even *looking* at this crap over a year after the last comment?
> 

Chris,

We revisit this because we are users who *enjoy* the distribution and feel that these are features we *need* to get our work done. Why don't you appreciate this?
 
> We have a LiveCD now that provides *all* of these and *more*...

Again, I don't need "*all* of these and *more*..." -- just rsync, please.

> 
> The Minimal InstallCD is *exactly* that... just enough to get the box booted to
> start the install.  If you want features, you use the LiveCD.  If you want "it
> boots so I can wget and chroot to install" you use Minimal.  We have no
> intentions on changing that... ever.  As I said almost 2 *years* ago... the
> Install CD is *not* a rescue disk.
> 

The idea that the minimal CD is thought of as, "it boots so I can wget and chroot to install" is completely flawed. Having a quick look at the 2006.1 disk reveals such minimal applications as vim and irssi. 

If the minimal disk is supposedly considered to be "just enough" to install a system, I'd love to know the reasoning for including irssi (I can hear it now, "support..." whatever.) and not including a  useful utility such as rsync.

Enlighten me.
Comment 12 Andrew Gaffney (RETIRED) gentoo-dev 2007-05-24 12:15:39 UTC
*** Bug 179628 has been marked as a duplicate of this bug. ***
Comment 13 Steven Wagner 2007-11-08 23:21:00 UTC
Rsync used to be included on the older gentoo install cd, but it was taken off. Rsync is what I use to install gentoo when I am using pre-built images stored on another server. Gentoo usually supports diversity. So if wget is a valid install method, rsync should be too.
Comment 14 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-09 00:07:41 UTC
2 years, 1 author + 5 CCs, many comments, a dup ... many people asking the same thing as me ... I think it's time to re-open, dont you think ?

I am not speaking about minimal CD. But, Considering 650M ISO, I really think affording 1 or 2 megs to those tools and deps really worth it. Mkfs.fat may be a little bit more discutable.

I would add: when 6 people come to BTS to complain, how many more also wanted this feature, but were too lazy to try to report about it ?

I always considered "install disks" of all distributions as also "quick repair disks". Debian install disk provides dpkg; I cant think of Gentoo disks not having rsync by side of wget&tar. Otherwise, a Slackare disc would probably suffice to install Gentoo ! Gentoo disk should provide Gentoo-specific tools.
Comment 15 Justin R. Pessa 2007-11-09 00:39:24 UTC
(In reply to comment #14)
> 2 years, 1 author + 5 CCs, many comments, a dup ... many people asking the same
> thing as me ... I think it's time to re-open, dont you think ?
> 
> I am not speaking about minimal CD. But, Considering 650M ISO, I really think
> affording 1 or 2 megs to those tools and deps really worth it. Mkfs.fat may be
> a little bit more discutable.
> 
> I would add: when 6 people come to BTS to complain, how many more also wanted
> this feature, but were too lazy to try to report about it ?
> 
> I always considered "install disks" of all distributions as also "quick repair
> disks". Debian install disk provides dpkg; I cant think of Gentoo disks not
> having rsync by side of wget&tar. Otherwise, a Slackare disc would probably
> suffice to install Gentoo ! Gentoo disk should provide Gentoo-specific tools.
> 

Good luck with this fight... 

Clearly, the Gentoo developers are unable to see what their user-base wants in a distribution because they can't see around their own EGOS. 
Comment 16 Andrew Gaffney (RETIRED) gentoo-dev 2007-11-09 02:53:48 UTC
What don't you people understand? The LiveCD already contains rsync, grub, and lilo, and dosfstools. If you don't want to use the LiveCD, that is not our fscking problem. These things are not going on the minimal install CD. There is no discussion. Leave this bug closed.
Comment 17 Justin R. Pessa 2007-11-09 12:27:47 UTC
Hey no worries Andrew, we get it now. You and Chris are (somehow) convinced that rsync isn't necessary for installing Gentoo and that's fine.

Please let me know when you've removed your head from the sand and are willing to consider your user-base's feedback on the product.

Best,

-j (asdf)
Comment 18 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-11 20:11:54 UTC
Justin, your point is wrong: rsync and grub is not required for "install" stage; only for repair, or cold-customise.

By the time I opened this bug, the liveCD did not exist, thus, the only disk that existed was the install disk, that I wanted to use for everything related to Gentoo.

Nowaday, things are différent. There is a liveCD, so, the install disk use can be limitted to install steps described in the Install guide. As long as "now", those tools are provided in an other official disk, Andrew's point is now acceptable, in this end 2007, because now there is a second disk: Live. Because of this, my bug is no more acceptable, because the "sell argument" of all live CDs (Gentoo's one like Knoppix did ages ago) is "get a quick Linux from disk because you dont want to install it, OR REPAIR EXISTING LINUX THAT DOES NOT BOOT ANY MORE.

So, since Gentoo *NOW* have two disks, the original point of this bug does not stand anymore.

I still think that affording 3 or 4 megs for this tool is a minimal effort (especially since the install disk have 400M free left), but, Gentoo's ideology (like UNIX) is to get one thing for each feature, and only one feature per thing ... and, since Gentoo now have a second disk for "repair", Install disk may not contains repair tools. We will all have to accept this, or change distro.

Gentoo evolved; WE have to get head out of sand.
Comment 19 Justin R. Pessa 2007-11-12 00:19:43 UTC
(In reply to comment #18)
> Justin, your point is wrong: rsync and grub is not required for "install"
> stage; only for repair, or cold-customise.
> 
<snip>

Deamine,

I will not take your bait, sorry. 

This thread is a great example of how NOT to listen to your user-base. The problem isn't that people's requests were turned down, it's the fact that the developers wouldn't even take a moment to CONSIDER our input, or try to relate the short-comings were have experienced with the minimal CD. 

Like I said previously, heads out of the sand, and egos out of the way... 

- j
Comment 20 Chris Gianelloni (RETIRED) gentoo-dev 2007-11-13 21:44:10 UTC
Please quit commenting on this bug.  It has been explained ad nauseum why the request wasn't valid for inclusion.  People can claim it's my ego or whatever the hell they want to.  I'll take the blame.  I really don't care.  I think DEMAINE said it best in comment #18 when he explained the different uses of the different media.  That being said, I'm sure a few of you guys are going to get even more upset as the minimal CD gets *even smaller* and even *more specialized* to performing a Gentoo installation, from the Handbook, with as few tools as possible.

This is *very* simple.  If it is not specifically in the Handbook, it won't be supported on the minimal CD.

I understand that this does not meet with *everyone's* view of what *they* think the minimal CD should be, but quite frankly, I gave up on trying to appease everyone all the time about 30 seconds after becoming a developer.  Sometimes, you simply cannot please people.  I understand this.  If you want to call it my "ego" rather than trying to understand the issue at hand, feel free to do so.  Again, it is no skin off my teeth if you have a bad impression of me.  I honestly do not care, at all.  For every person who dislikes my decisions, there are hundreds more who agree with me, and my goal is to appease as many people as possible, without going to the extreme to appease the fringe.

Now, *please* quit the comments here.  This discussion was over *years ago* and bringing it up *again* to the *exact same people* isn't likely to garner a different end result.  Please do not make me restrict this bug.

Thank you.
Comment 21 Justin R. Pessa 2007-11-14 01:58:07 UTC
Chris your remarks reflect my exact sentiments about developers and egos. You admittedly could care less.

You do a great job at sucking the air out of the room. Bravo! 

Now I'm done commenting on this bug.

- j
Comment 22 Andrew Gaffney (RETIRED) gentoo-dev 2007-11-14 02:26:38 UTC
Restricting because people are tools.
Comment 23 Chris Gianelloni (RETIRED) gentoo-dev 2007-11-16 00:23:56 UTC
*yawn*
Comment 24 AL13N 2010-06-17 16:20:23 UTC
please include rsync because of stage tarballs on rsync server

also, i'm looking for the rescue CD but cannot find it for x86_64, i only see livedvd of 2.6GB...

are you expecting me to dl the livedvd and install from there, only because my stage tarballs are on rsync servers?

and where is this rescue cd? i can't find it...
Comment 25 DEMAINE Benoît-Pierre, aka DoubleHP 2010-06-17 16:26:04 UTC
Maarten: the bug is closed and WONTFIX. Forget it, they don't mind.

Now, to install Gentoo, I always start with a small debian:
- sda1 grub 8M (no kernel in there, just an OS selector)
- sda2 debian_rescue 1G
- sda3 swap 2 to 10G
- sda5 Gentoo_/

the small debian can have rsync in, and will let me reinstalling Gentoo quicly, without need for any CD; and I can use it to chroot when I crash my gentoo kernel.

If you want a live CD which can let you install Gentoo, AND use rsync, try Ubuntu, Knoppix, DSL or GRML. Gentoo just needs wget, lynx, vim, rsync and chroot. In fact, it could fit in a 1.4M floppy.
Comment 26 Patryk Rzadzinski 2010-07-09 10:20:29 UTC
I've read the comments and despite it seems pointless, I'll add to the discussion.

It is pointless to make people download 2.7GB LiveDVD for x64 instead of adding rsync, 50kb to the minimal CD.

It has been proven in practise that rsync is required if you want to restore from backup or from a modified image, etc. If minimal cd is only supposed to let people install gentoo by the handbook - then I think the idea is flawed.

If you consider the minimal CD should only have what is required to install gentoo - then it has more than enough... (fb?!?!?!) So obviously this is not the case and software is admitted to be COMFORTABLE for admins and users. Now how many more requests are required from experienced admins to get this extremely useful tool into the minimal CD?
Comment 27 RAPHEAD 2010-07-14 19:27:24 UTC
Just my 50Cent:
I also NEED rsync on the small install image because I
often install gentoo just by booting from USB and
then simply copying (using rsync via SSH) my whole
OS from one server to another.
rsync is ESSENTIAL for me.
Pointless discussion about 100k.
Comment 28 DEMAINE Benoît-Pierre, aka DoubleHP 2010-07-14 19:46:43 UTC
They said that an install CD is not a rescue CD, and that if you don't want to burn a 3G DVD, you can still use DSL, GRML, Ubuntu or Knoppix that all provide rsync in their respective 80M CDs. It's a question of principle. Adding 50k that are not requered for normal install would probably be bad for the reputation or something like this.

It's one of the first bug I created, the first month I used the distro, and, never used Gentoo CD since that day. Just install a rescue Debian on a small partition (usually using PXE), and forget about CDs.

Amongst all bugs I have created, it the one that had most contributions from different people, but, they don't mind.
Comment 29 AL13N 2010-07-14 22:13:25 UTC
putting a debian in front of your gentoo... djeez, what is the world coming to.

and there is NO distro out there with a recent CD version on x86_64, which has all the tools required to rsync AND to chroot into it. keep in mind that x86_64 is required to chroot into it.

there is NONE, what so ever...

every distro should be able to do this...

gentoo and Mandriva are the 2 that have the closest solution.

in the past, i could have understood their reasons, but now, it's not so anymore. the minimal version is already huge in respect to then, there IS no more rescue CD. and the liveCD is discontinued in favor of the liveDVD.

Comment 30 DEMAINE Benoît-Pierre, aka DoubleHP 2010-07-14 22:35:43 UTC
Yes, a small debian in the corner make my laptop is able to ship all rescue tools I need anyplace, any time, in the subway, in a plane, at home, at shcool, at work ... as long as the partition table did not break it. I don't need CD, I don't need USB any more. It's just 15mn to install for life time, faster than downloading and burning any <<rescue DVD>>.

It's long time I did not use GRML, but I am pretty sure they have a disk with evberything I need: 64b, chroot, rsync, lynx, wget, irssi, mdadm ...
Comment 31 AL13N 2010-07-15 00:56:52 UTC
what if you can't reach your debian?

and what is GRML ?
Comment 32 DEMAINE Benoît-Pierre, aka DoubleHP 2010-07-15 02:03:21 UTC
(In reply to comment #31)
> what if you can't reach your debian?

As long as partition table is not corrupt, I always can. I never play with partition table when I am not home. I never had this problem since I started by a Debian (2002, 8 years already). It's not the best distro, but it's here when I need it. And unlike any CD of my dreams, it can store and "remember" things (scripts, stages, portage, memos ... ); unlike any USB, it's always in the laptop, even when I forget to take any bag. It's installed faster than you burn a DVD.

> and what is GRML ?

One of the CDs you criticised in comment 29 without knowing what you were talking about.

Anway, the discussion is closed since comment 2 :) We all wonder why people still come to comment, complain, wimp on a closed bug ... when maintainers decision was so clear and justified.

Booting grml64-small_2008.11.iso in some Xen just to check some points:
- 2.6.26 , with flag CONFIG_X86_64_SMP=y (few live CDs could be proud of this 2 years ago)
- rsync 3.0.4
- bash 3.2.39 (i have to say it, because the default is zsh)
- ssh (client and server)
- grub 0.97
- lilo 22.6.1
- mkfs for bfs cramfs ext2/3/4 minix msdos ntfs vfat reisor xfs (whahoo, already ext4 in 2008)
- fsck for the same list
- chroot 6.10
- tar 1.2
- gunzip 1.3.12
- zcat (my love)
- busybox (at boot, and from prompt)
- framebuffer
- splashscreen
- fuse
- debootstrap

... in 77MiB (is it small enough to fit a business card ?)

Ah, it's missing *one* very "handy" tool (driver in fact), that, few 1337 Gentoo users will regret: ntfs-3g (but there is fuse, and GPL ntfs).

DSL should provide a very similar list.

Before saying that GRML is "the perfect CD", let's check a few more points: screen, iwconfig, iwlist, wget, lynx, links, ping/6, ip{6}tables, ip ... all in. OH, missing irssi, I am very sad ! also missing elinks, curl, kexec, ebtables, no BitTorrent client, no chat I know, no python (but this is very Gentoo specific, and it should be in the target system if it's not too much broken; otherwise, GRML will still let you extract a stage3 to pick Python in it. I always keep my stage3 in / for this use) ...

No, really, can not make a "serious rescue firewall" without ebtables (OMG ^^).

So, if you want a <100MiB CD, you know what I recommend :) And of course, it works very easily on PXE ! way easier than most CDs i have met before.

So ... you were saying that no actual CD have both 64b, rsync, and chroot ? If you think that 2008.11 is not recent enough for you, feel free to try the new 2010 tastes.

I also push a small Debian on all desktops and servers, aside with production OS like BSD, MacOS, Solaris ... just a good reflex to have. Who don't have 1G spare on some disk ? I use it to store a backup of mdadm.conf for example ... just in case ...
Comment 33 AL13N 2010-07-15 10:27:18 UTC
I did mention in #24 that i didn't find this gentoo rescue CD.

You could have mentioned where it was, when i could have used it. Can you tell me it's location now?

I would prefer a more recent kernel, for hardware support, but if it works, i'll take it.
Comment 34 DEMAINE Benoît-Pierre, aka DoubleHP 2010-07-15 10:41:22 UTC
(In reply to comment #33)
> I did mention in #24 that i didn't find this gentoo rescue CD.
> 
> You could have mentioned where it was, when i could have used it. Can you tell
> me it's location now?

Riger did not tell, and he has gone, so ... only God knows :)

I created the bug against the *INSTALL* CD ... like Raphead, Patryk, Justin ... we want rsync on install CD. That's all. A rescue CD should contain Python, but, this bug is created only for install CD, not Rescue cd. And i don't think Python would important for install; it could be a '+', but would cost too much place.

> I would prefer a more recent kernel, for hardware support, but if it works,
> i'll take it.

I tested GRML 2008.11 because it was available "at once" for me; feel free to burn a 2010 one :)
Comment 35 Conor Curran 2011-01-19 18:57:41 UTC
All the original devs are retired. Can we reopen this?
Comment 36 AL13N 2011-01-19 19:16:07 UTC
I agree
Comment 37 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-01-19 19:58:46 UTC
Please follow this discussion on bug 352152.
Comment 38 DEMAINE Benoît-Pierre, aka DoubleHP 2011-01-19 20:58:52 UTC
No; I am not asking for a new Gentoo-fork of Ubuntu, DSL, or Grml, but I am claiming that the Gentoo install CD should afford 500k for providing basic, no, I meant *BASIC* rescue tools in it's install CD, even in the minimal one.

Those tools should be present in all install media; I meant *ALL*, and especially those which are NOT "admin" targeted/dedicated.

Conor & Alien: this is a won't fix. Don't mind if maints are retired or alive; a won't fix is a won't fix. *if* re-open, and reassigned, new maints will read the full page, and, re-tell the arguments that have already be given, and reclose for the same reason. Untill the bug is compleetely removed from Bugzilla, and me removed from my own bug so that we stop bothering them.

Dispite people who are asking for the same thing as me ... Maybe my bug smell rotten; why not create a new fresh one, and hope that new admins are not yet aware of my old bug ? nearly 6 years; one of the first one I have created. 
Comment 39 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-01-19 22:43:10 UTC
(In reply to comment #38)
> No; I am not asking for a new Gentoo-fork of Ubuntu, DSL, or Grml, but I am
> claiming that the Gentoo install CD should afford 500k for providing basic, no,
> I meant *BASIC* rescue tools in it's install CD, even in the minimal one.
> 
> Those tools should be present in all install media; I meant *ALL*, and
> especially those which are NOT "admin" targeted/dedicated.

The reasons for not doing that have been amply presented here.

> Conor & Alien: this is a won't fix. Don't mind if maints are retired or alive;
> a won't fix is a won't fix. *if* re-open, and reassigned, new maints will read
> the full page, and, re-tell the arguments that have already be given, and
> reclose for the same reason. Untill the bug is compleetely removed from
> Bugzilla, and me removed from my own bug so that we stop bothering them.
> 
> Dispite people who are asking for the same thing as me ... Maybe my bug smell
> rotten; why not create a new fresh one, and hope that new admins are not yet
> aware of my old bug ? nearly 6 years; one of the first one I have created. 

If you're not aware of that, I'm a member of the Release Engineering team.
Comment 40 AL13N 2011-01-19 23:58:02 UTC
Well, imho, this weird policy of yours should be reviewed. it seems you're the perfect person to help us with this.