Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90329 - Installer: collision-protect: Compiled python (.pyo) files collide with portage update
Summary: Installer: collision-protect: Compiled python (.pyo) files collide with porta...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: osx porters
URL:
Whiteboard:
Keywords:
: 99326 99661 100419 102956 103677 105497 107054 107105 107624 122210 (view as bug list)
Depends on: 107759
Blocks:
  Show dependency tree
 
Reported: 2005-04-24 22:26 UTC by Alexander Skwar
Modified: 2007-03-26 19:09 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2005-04-24 22:26:03 UTC
[07:24:55 vz6tml@exp01:/tmp] $ sudo emerge -vat portage
Password:

These are the packages that I would merge, in reverse order:

Calculating dependencies ...done!
[ebuild     U ] sys-apps/portage-2.0.51.20-r4 [2.0.51.19] -build (-selinux) 0 kB
[...]
* checking 146 files for package collisions
existing file /usr/lib/portage/pym/cvstree.pyo is not owned by this package
existing file /usr/lib/portage/pym/emergehelp.pyo is not owned by this package
existing file /usr/lib/portage/pym/getbinpkg.pyo is not owned by this package
existing file /usr/lib/portage/pym/output.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_checksum.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_const.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_data.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_cpickle.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_flat.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_db_template.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_dep.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exception.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_exec.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_file.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_gpg.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_localization.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_locks.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage.pyo is not owned by this package
existing file /usr/lib/portage/pym/portage_util.pyo is not owned by this package
existing file /usr/lib/portage/pym/xpak.pyo is not owned by this package
* spent 0.0579149723053 seconds checking for file collisions
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it
* as a bug for this package on http://bugs.gentoo.org

package sys-apps/portage-2.0.51.20-r4 NOT merged



[07:22:14 vz6tml@exp01:~] $ epm -qf /usr/lib/portage/pym/cvstree.pyo
file /usr/lib/portage/pym/cvstree.pyo is not owned by any package


I suspect, that all the other colliding files also aren't owned by any package.


[07:25:03 vz6tml@exp01:/tmp] $ emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20050125-r1, 2.6.10-ck5.03.no-nfs-directio.no-nfs4.only-deadline-sched i686)
=================================================================
System uname: 2.6.10-ck5.03.no-nfs-directio.no-nfs4.only-deadline-sched i686 Intel(R) Pentium(R) 4 CPU 1.80GHz
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 21 2005, 12:48:01)]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.5, 1.6.3, 1.8.5-r3, 1.7.9-r1, 1.5, 1.4_p6
sys-devel/binutils:  2.15.92.0.2-r8
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O3 -fomit-frame-pointer -pipe -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://localhost/~vz6tml/gentoo-files/ http://php2.ath.cx/~askwar/gentoo-files/ http://gentoo.phpquadrat.de/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ http://distro.ibiblio.org/pub/Linux/distributions/gentoo/ http://distfiles.gentoo.org/"
LANG="de_DE.UTF-8"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acl acpi apache2 artworkextra async audiofile avi bash-completion bcmath bzlib cap caps ccache cdr crypt cscope css cups curl curlwrappers divx4linux djbfft dvd dvdr encode ethereal evo evo2 exif fam flac foomaticdb ftp gd gdbm gif gimpprint gnome gnutls gphoto2 gtk gtk2 hal howl iconv imagemagick imlib imlib2 ithreads java javascript jbig jpeg jpeg2k kde kdeenablefinal kdexdeltas kerberos ldap libedit libwww lufsusermount lzw-tiff mad maildir mailwrapper matroska mbox mmap mmx mng mozcalendar mozdevelop mozilla moznoirc mp3 mpeg ncurses nis nls noantlr nobcel nobeanutils nobsh nocommonslogging nocommonsnet nodrm nojdepend nojoystick nojsch nojython nolog4j nooro noregexp norhino noxalan noxerces nptl offensive ogg oggvorbis pam parse-clocks pcntl pcre pdflib perl pic pie png posix ppds pwdb python qt quicktime quotes rdesktop readline real recode samba sasl sdl shared slang sndfile sockets spell sse sse2 ssl svg sysvipc tcltk tcpd theora threads tiff truetype truetype-fonts type1-fonts unicode usb videos vim vim-pager vim-with-x vorbis wmf xfs xml xml2 xprint xscreensaver xv xvid yp zlib linguas_de"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Marius Mauch (RETIRED) gentoo-dev 2005-04-24 22:28:34 UTC
nothing we can do about this, disable collision-protect for the update
Comment 2 Alexander Skwar 2005-04-24 22:31:49 UTC
Wouldn't it be possible to debug portage so, that collision-protect doesn't complain about compiled python files?
Comment 3 Marius Mauch (RETIRED) gentoo-dev 2005-04-24 22:58:49 UTC
sure that's possible, but why should we do that? The issue here was a bug in previous portage ebuilds, which was fixed now, so why should we keep and support a bug?
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-07-17 07:23:27 UTC
*** Bug 99326 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-07-20 06:28:26 UTC
*** Bug 99661 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-07-26 16:05:02 UTC
*** Bug 100419 has been marked as a duplicate of this bug. ***
Comment 7 Fabian Groffen gentoo-dev 2005-08-18 03:53:54 UTC
*** Bug 102956 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-08-25 02:25:24 UTC
*** Bug 103677 has been marked as a duplicate of this bug. ***
Comment 9 Konstantin Agouros 2005-08-25 02:32:55 UTC
And how do I disable that?

I commented out the FEATURES entry in make.conf
i explicitedly set FEATURES to ''
emerge -u portage and I still get the same message
Comment 10 Fabian Groffen gentoo-dev 2005-08-25 08:44:14 UTC
sorry:

make sure the FEATURES line is back in your make.conf

then emerge portage:

env FEATURES="-collision-protect" emerge --nodeps portage
Comment 11 Konstantin Agouros 2005-08-25 08:45:39 UTC
thanks that did the trick
Comment 12 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-08-25 13:30:42 UTC
(In reply to comment #9)
> And how do I disable that?
> 
> I commented out the FEATURES entry in make.conf
> i explicitedly set FEATURES to ''
> emerge -u portage and I still get the same message

FYI, Many of the variables in make.conf are cascaded, meaning they are confined 
from multiple files.  Just removing FEATUREs from make.conf won't make the 
variable go away, since FEATURES are also usually set in make.globals and in 
your profile.  In the future when you need to modify the environment you need to 
use FEATURES="-myfeature" or USE="-gtk" or whatnot.  
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2005-09-10 08:39:37 UTC
*** Bug 105497 has been marked as a duplicate of this bug. ***
Comment 14 Fabian Groffen gentoo-dev 2005-09-24 00:49:44 UTC
*** Bug 107054 has been marked as a duplicate of this bug. ***
Comment 15 Fabian Groffen gentoo-dev 2005-09-24 12:22:20 UTC
*** Bug 107105 has been marked as a duplicate of this bug. ***
Comment 16 Kito (RETIRED) gentoo-dev 2005-09-29 10:33:17 UTC
Re-Opening until next pkg installer is released.
Comment 17 Kito (RETIRED) gentoo-dev 2005-09-29 10:33:53 UTC
*** Bug 107624 has been marked as a duplicate of this bug. ***
Comment 18 Alexander Skwar 2005-09-29 13:03:30 UTC
Why has this been changed to prodcut "Gentoo for Darwin/OS X"? It happens on
"plain" Gentoo as well.

Changing back to product = Gentoo Linux.
Comment 19 Kito (RETIRED) gentoo-dev 2005-09-29 13:22:01 UTC
(In reply to comment #18)
> Why has this been changed to prodcut "Gentoo for Darwin/OS X"? It happens on
> "plain" Gentoo as well.

Because its fixed on current linux install media AFAICT. Its not fixed in the current OS X installer. Am I 
missing something?

> 
> Changing back to product = Gentoo Linux.

Comment 20 Fabian Groffen gentoo-dev 2005-09-29 13:24:09 UTC
we should make a new bug on the installer and list all the current problems,
CHOST, FETCH_COMMAND etc etc on it for that purpose.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-02-08 23:38:20 UTC
*** Bug 122210 has been marked as a duplicate of this bug. ***
Comment 22 Fabian Groffen gentoo-dev 2007-03-26 19:09:00 UTC
Don't use classic Gentoo for Mac OS X any more.  Consider Gentoo Prefix instead.  http://www.gentoo.org/proj/en/gentoo-alt/prefix/