Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90282 - Initio A100u2w controller hangs system
Summary: Initio A100u2w controller hangs system
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2005-04-24 13:18 UTC by Brett I. Holcomb
Modified: 2007-04-01 21:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Brett I. Holcomb 2005-04-24 13:18:29 UTC
When I boot the liveCD (universal) the system hangs if I have my A100u2w controller installed.  I have an Adaptec RAID 3210S that I boot from.  Checking google and the forums shows there appear to be issues with upstream code.  However, I would have thought 2005.0 would not have the problem so I'm reporting it.

One of the posts made mention of booting the non-smp kernel but I can't find one on the livecd.
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2005-04-25 05:35:20 UTC
There is no non-SMP kernel anymore.  You probably found a fairly old post.

You can try "gentoo nosmp noapic acpi=off" and see if it helps any.  You can also try noload=a100u2w if it appears the be the driver locking the system.
Comment 2 Brett I. Holcomb 2005-04-25 08:34:24 UTC
I'll try that.  Good idea on the noload.

What happens when I build the system and then create a new kernel for the sysetm - (genoo-sources 2.6.11-rx)?  Will it have the same error or is it fixed or patched?
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2005-04-25 08:45:23 UTC
It depends entirely on whether it was fixed since gentoo-sources-2.6.11-r3, which is what we used on the InstallCD.  I don't follow the kernel changes that closely, but I would suspect that unless it has been patched upstream since the release of, then it won't be fixed in our tree, either.
Comment 4 Brett I. Holcomb 2005-04-28 17:33:32 UTC
Nope.  I tried

gentoo no-smp noapic acpi=off noload=a100u2w

and it still hangs.  I guess I'll have to physically remove the board.

Why was the nosmp kernel removed.  It seems to me that if would be valuable in cases like this where people's system have trouble with smp.  It wasn't a casualty of the "make is smaller" drive was it?

Hopefully the next CD will have a fixed kernel - actually hopefully the current version of the kernel is fixed!
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2005-04-29 05:45:40 UTC
It is nosmp, not no-smp.

The kernel was axed because it isn't as useful as many people seem to think.  For one, we no longer offer a 2.4 kernel on the CD.  Second, it is possible to make a kernel behave like a uniprocessor kernel with nosmp.

Where exactly are you seeing a freeze?  Is there any errors shown?
Comment 6 Brett I. Holcomb 2005-04-29 10:07:10 UTC
I had nosmp because I remember seeing only one processor detected and not both.

Where it quits depends.  Sometimes the system boots, gets to hardware detection,finds the CPU type and then shortly after that before it starts gpm locks solid.  the spinning cursor freezes, ctl-alt-del will not work, I can't switch to another console either. Other times it goes all the way to giving me the livecd prompt and then dumps some SCSI info about the drives, then gives the SCP Reset error and freezes as above.
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2005-04-29 10:30:13 UTC
Ouch... I'm betting that it is because of hotplug/coldplug.  What if you try "gentoo nohotplug noload=a100u2w"?
Comment 8 Brett I. Holcomb 2005-04-29 18:22:17 UTC
That worked.  However a100u2w showed up in lsmod and I had to unload it, then reload dpt_i2o to get the RAID (/dev/sda) to be accessible.  
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2005-08-15 12:32:43 UTC
Hrrrmn... it shouldn't be showing up in lsmod at all if you have nohotplug in
there, too... strange
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-21 07:16:05 UTC
Can you try out the 2005.1-r1 CD that was just released and verify if this
problem is still present?  We updated the kenrel to 2.6.12-r10 and it may
resolve this issue.
Comment 11 Brett I. Holcomb 2005-11-21 09:38:35 UTC
Sure.  I'll have to put the card back in <G> so it may be some time before I get
that done.
Comment 12 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-21 10:36:53 UTC
Not a problem... I just don't have any way of testing this myself, so whenever
you get a chance it would be much appreciated.
Comment 13 Chris Gianelloni (RETIRED) gentoo-dev 2006-03-20 12:34:06 UTC
*** Bug 126599 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2007-04-01 21:13:21 UTC
Well, we need someone to test this.