Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90101 - transcode-0.6.14-r1 fails to provide subtitle2pgm
Summary: transcode-0.6.14-r1 fails to provide subtitle2pgm
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 82862 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-22 22:35 UTC by Kit Fenderson-Peters
Modified: 2005-05-15 10:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kit Fenderson-Peters 2005-04-22 22:35:51 UTC
subtitle2pgm should be installed with transcode, and it is in fact installed with transcode 0.6.11, but it is not installed with transcode 0.6.14-r1.  This is required for dvd::rip to take subtitles.

Reproducible: Always
Steps to Reproduce:
1. emerge transcode-0.6.14-r1


Actual Results:  
subtitle2pgm is not on my system

Expected Results:  
subtitle2pgm should be on my system

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20041102-r1,
2.6.11-gentoo-r6 i686)
=================================================================
System uname: 2.6.11-gentoo-r6 i686 Intel(R) Pentium(R) M processor 1300MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 28 2005, 13:01:54)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r3, 1.6.3, 1.7.9-r1, 1.4_p6, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.21-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium3 -pipe -frename-registers -fomit-frame-pointer
-fforce-addr -s -falign-functions=64 -fprefetch-loop-arrays -mfpmath=sse
-maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -pipe -frename-registers -fomit-frame-pointer
-fforce-addr -s -falign-functions=64 -fprefetch-loop-arrays -mfpmath=sse
-maccumulate-outgoing-args -fpermissive"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib acpi alsa apm audiofile avi bash-completion berkdb bitmap-fonts
cdparanoia cdr cups curl divx4linux dvd dvdread emboss encode ext3 f77 fam fbcon
flac foomaticdb fortran gcj gdbm gif gpm gtk gtk2 gtkhtml imagemagick imap imlib
ipv6 java jpeg junit kde libg++ libwww mad mikmod mmx mmx2 motif mp3 mpeg msn
ncurses nls ogg oggvorbis ooo-kde opengl oss pam pcmcia pda pdflib perl png
python qt qtmt quicktime radeon readline real rtc samba sdl slang speex spell
sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fontsusb vorbis
wifi xine xml2 xmms xv xvid zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-04-24 19:58:18 UTC
On transcode 0.6.14 (which is needed by dvdrip) subtitle2pgm program is no more in the contrib section, but needs to be installed via subtitleripper.

I've committed a new revision which adds a subtitles useflag which adds a runtime dependency on subtitleripper.

As subtitleripper is not marked ~ppc, and dvdrip is, the new revision has ~ppc keyword dropped until either subtitleripper is marked or subtitles useflag is use.masked on ppc.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-04-24 20:12:39 UTC
*** Bug 82862 has been marked as a duplicate of this bug. ***
Comment 3 Joe Jezak (RETIRED) gentoo-dev 2005-05-15 10:32:37 UTC
New dvdrip and subtitleripper marked ~ppc in CVS.