Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 89945 - mozilla-firefox builds a firefox with generic blue icon instead of red & blue logo
Summary: mozilla-firefox builds a firefox with generic blue icon instead of red & blue...
Status: RESOLVED DUPLICATE of bug 113971
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Mozilla Gentoo Team
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-21 10:44 UTC by Ben Kohler
Modified: 2005-12-22 20:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild fixed to use real firefox icons (mozilla-firefox-1.0.3.ebuild,8.13 KB, text/plain)
2005-04-21 10:46 UTC, Ben Kohler
Details
ebuild with artwork useflag to use the firefox artwork (mozilla-firefox-1.0.3.ebuild,8.09 KB, text/plain)
2005-05-09 16:17 UTC, Steev Klimaszewski
Details
patch using mozconfig_use_enable against mozilla-firefox-1.0.4.ebuild version 1.4 (patch,745 bytes, patch)
2005-05-12 08:38 UTC, Hugues Fournier
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Kohler 2005-04-21 10:44:03 UTC
Emerging mozilla-firefox gives you a firefox with a generic-looking blue globe icon in the taskbar and in the "about" dialog.  However, emerging mozilla-firefox-bin gives you a firefox with the familiar orange/blue firefox icon that we all know and love.

Reproducible: Always
Steps to Reproduce:
1.  run "emerge mozilla-firefox"
2.  run "firefox"

Actual Results:  
The icon in the taskbar of xfce/gnome/kde/etc is a blue one rather than the
orange/blue logo.  It is also a big blue globe in the "about" dialog rather than
a big pretty firefox logo.

Expected Results:  
The normal firefox icon should show whether you build from source or use the binary.
Comment 1 Ben Kohler 2005-04-21 10:46:30 UTC
Created attachment 56854 [details]
ebuild fixed to use real firefox icons

added lines are 61-65, found at the end of the src_unpack section
Comment 2 Steev Klimaszewski gentoo-dev 2005-05-09 16:17:30 UTC
Created attachment 58530 [details]
ebuild with artwork useflag to use the firefox artwork

This adds a useflag of "artwork" to the ebuild, allowing you to USE="artwork"
emerge mozilla-firefox and it will use the artwork, otherwise, it continues to
build it with the wonderful blue globe :)
Comment 3 Hugues Fournier 2005-05-12 08:38:08 UTC
Created attachment 58755 [details, diff]
patch using mozconfig_use_enable against mozilla-firefox-1.0.4.ebuild version 1.4

This is a patch against mozilla-firefox-1.0.4.ebuild revision 1.4 ebuild with
IMHO the right way to do it using mozconfig_use_enable.
Indeed Firefox and Thunderbird have an compilation option
--enable-official-branding that cleanly does what was done in the previous
suggested ebuild with some 'cp'
The same simple change could be done in Thunderbird.
Comment 4 deathlove 2005-08-14 06:22:43 UTC
Hello,

please do not forget added this "--enable-official-branding" to portage

thx
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-12-22 20:37:25 UTC
Branding is unfortunately not that easy as one patch (legal issues)...

*** This bug has been marked as a duplicate of 113971 ***