Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 896914 - dev-util/apitrace: needs upgrade to Python 3.11 (PythonCompatUpdate)
Summary: dev-util/apitrace: needs upgrade to Python 3.11 (PythonCompatUpdate)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Blocks: 896398
  Show dependency tree
Reported: 2023-02-25 09:40 UTC by Michał Górny
Modified: 2023-05-06 07:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2023-02-25 09:40:32 UTC
This package does not support Python 3.11.  Please test it with Python 3.11 as a matter of urgency as the default will change in early June, as per message on gentoo-dev:  Please check the information provided in the tracker.  Ask in #gentoo-python on IRC if need any help.
Comment 1 darkbasic 2023-05-02 08:20:25 UTC
The default has changed and I had to remove apitrace in order to get rid of python 3.10 on my system.
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-05-03 05:25:07 UTC
Ping. Python 3.11 is now default.
Comment 3 Miroslav Šulc gentoo-dev 2023-05-06 07:59:20 UTC
i tried to bump this one but i failed. the latest is 11.1. i came across two issues, one being media-libs/waffle not providing cmake file, the other one is that the brotli unbundle patch does not work for 11.1 anymore. the waffle issue is probably even with the current version.