Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 896418 - media-plugins/gst-plugins-v4l2-1.20.5 fails to compile (MUSL-CLANG-SYSTEM): gstv4l2object.c:539:23: error: incompatible function pointer types assigning to gint ()(gint, ioctl_req_t, ...) (aka int ()(int, unsigned long, ...)) from int (int, int, ...) [-W
Summary: media-plugins/gst-plugins-v4l2-1.20.5 fails to compile (MUSL-CLANG-SYSTEM): g...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
Keywords: PullRequest
Depends on:
Blocks: c99-porting
  Show dependency tree
Reported: 2023-02-25 07:32 UTC by Agostino Sarubbo
Modified: 2023-09-15 05:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,87.24 KB, text/plain)
2023-02-25 07:32 UTC, Agostino Sarubbo
Alternate build log (build.log,38.38 KB, text/plain)
2023-07-04 08:43 UTC, Elizabeth Doughty

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-02-25 07:32:49 UTC

Issue: media-plugins/gst-plugins-v4l2-1.20.5 fails to compile (MUSL-CLANG-SYSTEM).
Discovered on: amd64 (internal ref: tinderbox_musl)

(MUSL-CLANG-SYSTEM) in the summary means that bug was found on a machine that runs MUSL libc + clang16 but this bug MAY or MAY NOT BE related to musl/clang16.
Comment 1 Agostino Sarubbo gentoo-dev 2023-02-25 07:32:51 UTC
Created attachment 854524 [details]

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-02-25 07:32:53 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:

Dependency libsoup-2.4 from subproject libsoup found: NO (subproject failed to configure)
Dependency libsoup-3.0 from subproject libsoup3 found: NO (subproject failed to configure)
FAILED: sys/v4l2/ 
Message: Hotdoc not found, not building the documentation
Message: Orc Compiler not found, will use backup C code
Program hotdoc found: NO
Run-time dependency libsoup-2.4 found: NO (tried pkgconfig and cmake)
Run-time dependency libsoup-3.0 found: NO (tried pkgconfig and cmake)
Run-time dependency valgrind found: NO (tried pkgconfig)
Run-time dependency xdamage found: NO (tried pkgconfig and cmake)
../gst-plugins-good-1.20.5/sys/v4l2/gstv4l2object.c:539:23: error: incompatible function pointer types assigning to 'gint (*)(gint, ioctl_req_t, ...)' (aka 'int (*)(int, unsigned long, ...)') from 'int (int, int, ...)' [-Wincompatible-function-pointer-types]
Comment 3 Elizabeth Doughty 2023-07-04 08:43:20 UTC
Created attachment 865132 [details]
Alternate build log