Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 894328 - app-crypt/libsecret-0.20.5-r3 fails to compile (MUSL-CLANG-SYSTEM): test-vala-lang.c:1166:51: error: incompatible function pointer types passing void (gpointer) (aka void (void )) to parameter of type GTestDataFunc (aka void ()(const void )) [-Wincompati
Summary: app-crypt/libsecret-0.20.5-r3 fails to compile (MUSL-CLANG-SYSTEM): test-vala...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Keywords: PullRequest
Depends on: vala-clang16
Blocks: c99-porting, clang-16-porting
  Show dependency tree
Reported: 2023-02-14 08:38 UTC by Agostino Sarubbo
Modified: 2023-05-13 09:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,134.37 KB, text/plain)
2023-02-14 08:38 UTC, Agostino Sarubbo
const_ptr_fix.patch (const_ptr_fix.patch,2.25 KB, text/plain)
2023-05-07 19:03 UTC, nvinson234

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-02-14 08:38:29 UTC

Issue: app-crypt/libsecret-0.20.5-r3 fails to compile (MUSL-CLANG-SYSTEM).
Discovered on: amd64 (internal ref: tinderbox_musl)

(MUSL-CLANG-SYSTEM) in the summary means that bug was found on a machine that runs MUSL libc + clang16 but this bug MAY or MAY NOT BE related to musl/clang16.
Comment 1 Agostino Sarubbo gentoo-dev 2023-02-14 08:38:32 UTC
Created attachment 851020 [details]

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-02-14 08:38:34 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:

FAILED: libsecret/test-vala-lang.p/meson-generated_test-vala-lang.c.o 
FAILED: libsecret/test-vala-unstable.p/meson-generated_test-vala-unstable.c.o 
Program gjs found: NO
Run-time dependency tss2-esys found: NO (tried pkgconfig and cmake)
Run-time dependency tss2-mu found: NO (tried pkgconfig and cmake)
Run-time dependency tss2-rc found: NO (tried pkgconfig and cmake)
Run-time dependency tss2-tctildr found: NO (tried pkgconfig and cmake)
libsecret/test-vala-lang.p/test-vala-lang.c:1166:51: error: incompatible function pointer types passing 'void (gpointer)' (aka 'void (void *)') to parameter of type 'GTestDataFunc' (aka 'void (*)(const void *)') [-Wincompatible-function-pointer-types]
Comment 3 nvinson234 2023-05-07 19:03:10 UTC
Created attachment 861278 [details]

A patch to fix the issue.

clang complains about void (*)(void *) not being compatible with void (*)(const void *). This patch casts the function pointers to the proper type before passing them into the functions that need them.
Comment 4 nvinson234 2023-05-07 19:05:55 UTC
Upstream discussion of the issue: