Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 89430 - emerge reports I/O error attemping to emerge dev-perl/Time-Local
Summary: emerge reports I/O error attemping to emerge dev-perl/Time-Local
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
Depends on:
Reported: 2005-04-17 09:51 UTC by Joe Eversole
Modified: 2007-01-11 11:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge info output (emerge-info.txt,1.75 KB, text/plain)
2005-04-17 09:52 UTC, Joe Eversole

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Eversole 2005-04-17 09:51:56 UTC
I am attempting to install the application net-www/awstats. It depends on dev-perl/Time-Local. Portage attempts to bring this file in and dies with in IOError. I copied the file from /usr/portage/distfiles and verified that I was able to extract the contents manually to rule out a corrupt archive. I also manually verified the md5sum's matched.

Calculating dependencies ...done!
[ebuild  N    ] dev-perl/Time-Local-1.10  
[ebuild  N    ] net-www/awstats-6.3-r2  

Do you want me to merge these packages? [Yes/No] y
>>> emerge (1 of 2) dev-perl/Time-Local-1.10 to /
>>> Downloading
           => `/usr/portage/distfiles/Time-Local-1.10.tar.gz'
Connecting to[]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/linux/gentoo/distfiles ... done.
==> PASV ... done.    ==> RETR Time-Local-1.10.tar.gz ... done.
Length: 16,246 (unauthoritative)

100%[============================================>] 16,246        --.--K/s             

11:47:35 (206.47 KB/s) - `/usr/portage/distfiles/Time-Local-1.10.tar.gz' saved [16246]

Traceback (most recent call last):
  File "/usr/bin/emerge", line 3074, in ?
  File "/usr/bin/emerge", line 1848, in merge
  File "/usr/lib/portage/pym/", line 2613, in doebuild
    for mykey in self.get_provide(node):
  File "/usr/lib/portage/pym/", line 2201, in digestcheck
  File "/usr/lib/portage/pym/", line 2110, in digestParseFile
    def match(self,origdep,use_cache=1):
  File "/usr/lib/portage/pym/", line 24, in grabfile
IOError: [Errno 5] Input/output error

Reproducible: Always
Steps to Reproduce:
emerge Time-Local
Actual Results:  
IOError: [Errno5] Input/output error

Expected Results:  
Installation of package

emerge info in attachment
Comment 1 Joe Eversole 2005-04-17 09:52:23 UTC
Created attachment 56529 [details]
emerge info output
Comment 2 Joe Eversole 2005-04-17 10:01:29 UTC
I did some further testing and I get the same error message when I try any of the versions of dev-perl/Time-Local in portage.
Comment 3 Michael Cummings (RETIRED) gentoo-dev 2005-04-18 03:18:22 UTC
Have you tried emerging anything else? This isn't output from a perl module build - this is from portage itself. Please try emerging something else (Digest-MD5 is nice and small and fast if you dont' have anything else handy) and let me know if this still spews. If it does, I'll add the portage team to this bug.
Comment 4 Jason Stubbs (RETIRED) gentoo-dev 2005-04-18 06:40:45 UTC
`emerge info` please? at a guess, you have a /var/db/pkg/dev-perl/-MERGING* file that was left behind after a merge that failed during the actual move-files-to-filesystem process. Can't make sense of the traceback, but would like to see what your configuration is so as to try and reproduce it.
Comment 5 Joe Eversole 2005-04-18 07:09:47 UTC
Jason: The emerge info is included as an attachment. I figured it would be better than spamming the body of the bug report. My apologies for the confusion.

Digest-MD5 installed correctly and without errors (it was already installed). I was also able to successfully install dev-perl/Net-DNS and dev-perl/CDDB.
Comment 6 Jason Stubbs (RETIRED) gentoo-dev 2005-04-18 07:23:56 UTC
So no /var/db/pkg/dev-perl/-MERGING* file exists then?
Comment 7 Joe Eversole 2005-04-18 07:30:22 UTC
needs root # ls /var/db/pkg/dev-perl/-MERGING*
ls: /var/db/pkg/dev-perl/-MERGING*: No such file or directory
Comment 8 Jason Stubbs (RETIRED) gentoo-dev 2005-04-18 07:42:25 UTC
Does it work with FEATURES="-strict" ?
Comment 9 Joe Eversole 2005-04-18 07:47:24 UTC
Worked successfully with no errors:

needs root # FEATURES="-strict" emerge -a dev-perl/Time-Local

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] dev-perl/Time-Local-1.10

Do you want me to merge these packages? [Yes/No] y

>>> Recording dev-perl/Time-Local in "world" favorites file...
>>> clean: No packages selected for removal.
>>> Auto-cleaning packages ...
>>> No outdated packages were found on your system.
 * GNU info directory index is up-to-date.
needs root #

Comment 10 Jason Stubbs (RETIRED) gentoo-dev 2005-04-18 07:55:45 UTC
Does anything look strange at all about the files in /usr/portage/dev-perl/Time-Local? What about its Manifest file? Does that look abnormal in any way? Merging with FEATURES="strict" works fine here...
Comment 11 Joe Eversole 2005-04-18 10:41:42 UTC
Everything looks fine in the files. For fun, I moved the /usr/portage/dev-perl/Time-Local folder out of the portage tree, synched, deleted the contents of /usr/portage/distfiles, and attempted to emerge the package and it installed successfully.

I am no longer able to generate the error condition.
Comment 12 Michael Cummings (RETIRED) gentoo-dev 2005-04-18 12:44:48 UTC
Comment 13 Joe Eversole 2005-04-25 15:53:42 UTC
Since I cannot reproduce this error anymore, and no one else could in the first place, shall we close the ticket as INVALID?
Comment 14 Jason Stubbs (RETIRED) gentoo-dev 2005-04-25 16:16:46 UTC
Just in case it happens again..
Comment 15 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 11:01:29 UTC
Closing due to old age