Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 89290 - New ebuild: net-ftp/filezilla
Summary: New ebuild: net-ftp/filezilla
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Jason Smathers (RETIRED)
URL: http://filezilla.sourceforge.net/
Whiteboard:
Keywords:
: 193588 202281 (view as bug list)
Depends on: 145884
Blocks:
  Show dependency tree
 
Reported: 2005-04-16 01:52 UTC by Saurabh Singhvi
Modified: 2009-03-30 06:28 UTC (History)
33 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Filezilla 3 Beta 2 Ebuild (filezilla-3.0.0_beta2.ebuild,937 bytes, text/plain)
2006-10-26 21:21 UTC, Matthew Schultz
Details
net-ftp/filezilla-3.0.0_beta4.ebuild (filezilla-3.0.0_beta4.ebuild,962 bytes, text/plain)
2007-01-03 06:38 UTC, Kalidarn
Details
filezilla-3.0.0_beta4.ebuild (filezilla-3.0.0_beta4.ebuild,970 bytes, text/plain)
2007-01-03 07:57 UTC, Paul Bredbury
Details
filezilla-3.0.0_beta4-r1.ebuild (filezilla-3.0.0_beta4-r1.ebuild,961 bytes, text/plain)
2007-01-03 09:54 UTC, Kalidarn
Details
site-manager-fix.patch (site-manager-fix.patch,6.97 KB, patch)
2007-01-03 09:54 UTC, Kalidarn
Details | Diff
filezilla-3.0.0_beta4-r2.ebuild (filezilla-3.0.0_beta4-r2.ebuild,1.07 KB, text/plain)
2007-01-03 10:09 UTC, Kalidarn
Details
filezilla-3.0.0_beta4-r2.ebuild (filezilla-3.0.0_beta4-r2.ebuild,1.07 KB, text/plain)
2007-01-03 10:09 UTC, Kalidarn
Details
filezilla-3.0.0_beta4.ebuild (filezilla-3.0.0_beta4.ebuild,1.03 KB, text/plain)
2007-01-03 15:26 UTC, Paul Bredbury
Details
filezilla-3.0.0_beta5.ebuild (filezilla-3.0.0_beta5.ebuild,1.38 KB, text/plain)
2007-01-12 03:53 UTC, Paul Bredbury
Details
transfersocketpatch.patch (transfersocketpatch.patch,2.56 KB, patch)
2007-01-26 23:04 UTC, Kalidarn
Details | Diff
filezilla-3.0.0_beta5.ebuild (WORKING) (filezilla-3.0.0_beta5.ebuild,1.03 KB, text/plain)
2007-01-26 23:06 UTC, Kalidarn
Details
filezilla-3.0.0_beta5.ebuild (filezilla-3.0.0_beta5.ebuild,1.08 KB, text/plain)
2007-02-12 11:36 UTC, Kalidarn
Details
filezilla-3.0.0_beta5.ebuild (filezilla-3.0.0_beta5.ebuild,1.04 KB, text/plain)
2007-02-12 11:48 UTC, Kalidarn
Details
filezilla-3.0.0_beta5.ebuild (filezilla-3.0.0_beta5.ebuild,1.07 KB, text/plain)
2007-02-12 14:19 UTC, Kalidarn
Details
filezilla-3.0.0_beta5.ebuild (filezilla-3.0.0_beta5.ebuild,1.16 KB, text/plain)
2007-02-12 15:25 UTC, Kalidarn
Details
filezilla-3.0.0_beta6.ebuild (filezilla-3.0.0_beta6.ebuild,1.11 KB, text/plain)
2007-02-20 17:37 UTC, Kalidarn
Details
filezilla-3.0.0_beta7.ebuild (filezilla-3.0.0_beta7.ebuild,1.11 KB, text/plain)
2007-03-28 00:36 UTC, Kalidarn
Details
filezilla-3.0.0_beta7.ebuild (filezilla-3.0.0_beta7.ebuild,1017 bytes, text/plain)
2007-03-28 04:49 UTC, Paul Bredbury
Details
filezilla-3.0.0_beta7.ebuild (filezilla-3.0.0_beta7.ebuild,1.08 KB, text/plain)
2007-04-01 17:14 UTC, Kalidarn
Details
ssl-socket-fix.patch (ssl-socket-fix.patch,605 bytes, patch)
2007-04-01 17:14 UTC, Kalidarn
Details | Diff
filezilla-3.0.0_beta8.ebuild (filezilla-3.0.0_beta8.ebuild,1017 bytes, text/plain)
2007-05-16 10:20 UTC, Kalidarn
Details
filezilla-3.0.0_beta10.ebuild (filezilla-3.0.0_beta10.ebuild,1017 bytes, text/plain)
2007-06-05 03:57 UTC, Kalidarn
Details
filezilla-3.0.0_beta10.ebuild (filezilla-3.0.0_beta10.ebuild,1.01 KB, text/plain)
2007-06-27 16:03 UTC, Matthew Schultz
Details
filezilla-3.0.0_beta10.ebuild (filezilla-3.0.0_beta10.ebuild,1017 bytes, text/plain)
2007-07-02 17:12 UTC, Matthew Schultz
Details
filezilla-3.0.0_beta11.ebuild (filezilla-3.0.0_beta11.ebuild,1017 bytes, text/plain)
2007-07-23 03:43 UTC, Jason Smathers (RETIRED)
Details
filezila-rate-fix.patch (filezila-rate-fix.patch,371 bytes, patch)
2007-08-17 17:32 UTC, Kalidarn
Details | Diff
filezilla-3.0.0.ebuild (filezilla-3.0.0.ebuild,1.09 KB, text/plain)
2007-09-13 01:01 UTC, zhoumi
Details
filezilla-3.0.1.ebuild (filezilla-3.0.1.ebuild,1.11 KB, text/plain)
2007-10-11 16:33 UTC, Alois Hammer
Details
filezilla-3.0.2_rc1.ebuild (filezilla-3.0.2_rc1.ebuild,1.12 KB, text/plain)
2007-10-13 16:13 UTC, Alois Hammer
Details
filezilla-3.0.2.1.ebuild (filezilla-3.0.2.1.ebuild,1.14 KB, text/plain)
2007-10-22 00:01 UTC, Alois Hammer
Details
filezilla-3.0.3.ebuild (filezilla-3.0.3.ebuild,1.09 KB, text/plain)
2007-11-14 08:17 UTC, Pham Ngoc Hai
Details
filezilla-3.0.3.ebuild (filezilla-3.0.3.ebuild,1.13 KB, text/plain)
2007-11-15 10:02 UTC, Pham Ngoc Hai
Details
net-ftp/filezilla-3.0.4_rc1.ebuild (filezilla-3.0.4_rc1.ebuild,1.14 KB, text/plain)
2007-11-20 18:31 UTC, Alois Hammer
Details
net-libs/gnutls-2.0.4.ebuild (gnutls-2.0.4.ebuild,1.44 KB, text/plain)
2007-11-20 18:32 UTC, Alois Hammer
Details
net-ftp/filezilla-3.0.4.ebuild (filezilla-3.0.4.ebuild,1.14 KB, text/plain)
2007-11-27 06:03 UTC, Alois Hammer
Details
net-ftp/filezilla-3.0.9.ebuild (filezilla-3.0.9.ebuild,1.27 KB, text/plain)
2008-04-23 10:54 UTC, Pham Ngoc Hai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Saurabh Singhvi 2005-04-16 01:52:38 UTC
FileZilla is a fast and reliable FTP client and server with lots of useful features and an intuitive interface.
Comment 1 Matthew Schultz 2006-10-23 06:45:16 UTC
This request for ebuild should only be for the Filezilla 3 sftp/ftp client which is now a native linux program.  The Filezilla server is currently only written for windows.

http://sourceforge.net/project/showfiles.php?group_id=21558
Comment 2 Matthew Schultz 2006-10-26 21:21:13 UTC
Created attachment 100565 [details]
Filezilla 3 Beta 2 Ebuild
Comment 3 Matthew Schultz 2006-10-26 21:21:50 UTC
This website seems to be maintaining the filezilla ebuild:

http://gentoo.zugaina.org/net-ftp.html
Comment 4 Pacho Ramos gentoo-dev 2006-12-16 11:17:00 UTC
beta4 has been released
http://sourceforge.net/project/showfiles.php?group_id=21558&package_id=206762&release_id=471240

Thanks 
Comment 5 Matthew Schultz 2006-12-16 13:46:36 UTC
I'd post a beta4 version but it seems it has a wxGTK 2.8.0 dependency of which is not available in portage or bugs.gentoo.org yet. It seems like it is going to be a lot of work to get wxGTK 2.8 working.
Comment 6 Sven 2006-12-23 10:59:52 UTC
There is bug 145884 which is a request for wxGTK 2.8

Perhaps this bug should depend on it?
Comment 7 Kalidarn 2007-01-03 06:38:24 UTC
Created attachment 105298 [details]
net-ftp/filezilla-3.0.0_beta4.ebuild

I have updated wxGTK in http://bugs.gentoo.org/show_bug.cgi?id=145884 it must be installed into your overlay to use this ebuild.

Until it gets into the tree that is.
Comment 8 Kalidarn 2007-01-03 06:53:22 UTC
Also note, Beta4 offers SSL and TLS encryption over FTP. However, it is a know problem that the dev forgot to add them to the Site Manager.

To overcome this simply use the quick connect bar. ftps:// for implicit TLS, ftpes:// for explicit 

Will be fixed in the next version.
Comment 9 Kalidarn 2007-01-03 06:56:19 UTC
Also i'd like to get this into the tree as perhaps a hard masked ebuild. I know Zuguaina has offered this ebuild for the filezilla-cvs version originally considered to be updated too often to go into the official tree, thats why it was taken up on that overlay.

But now as the developer releases Beta versions every couple of months, and the popularity functions ie FTPS and the stability considered, I believe it deserves official attention in the official tree.

When of course wxGTK-2.8 is added and not before, which it will be as amule already depends on it also.
Comment 10 Paul Bredbury 2007-01-03 07:57:23 UTC
Created attachment 105301 [details]
filezilla-3.0.0_beta4.ebuild

Tidied ebuild, adding desktop entry.
Comment 11 Kalidarn 2007-01-03 09:54:09 UTC
Created attachment 105306 [details]
filezilla-3.0.0_beta4-r1.ebuild

Fixed Site Manager bug.
Comment 12 Kalidarn 2007-01-03 09:54:31 UTC
Created attachment 105307 [details, diff]
site-manager-fix.patch
Comment 13 Kalidarn 2007-01-03 09:55:54 UTC
Hang on, ill append your stuff to my ebuild then put a final up. mine includes patches + loads of tidying.
Comment 14 Kalidarn 2007-01-03 10:09:11 UTC
Created attachment 105309 [details]
filezilla-3.0.0_beta4-r2.ebuild

Includes fixed from Paul Bredbury.
Comment 15 Kalidarn 2007-01-03 10:09:30 UTC
Created attachment 105310 [details]
filezilla-3.0.0_beta4-r2.ebuild

Includes fixes from Paul Bredbury such as the menu item, and SRC_URI vars.
Comment 16 Kalidarn 2007-01-03 10:09:59 UTC
Comment on attachment 105309 [details]
filezilla-3.0.0_beta4-r2.ebuild

ack double post
Comment 17 Kalidarn 2007-01-03 12:40:52 UTC
Also forgot to mention, the upstream developer likes to use gentoo :)
Comment 18 Paul Bredbury 2007-01-03 15:26:55 UTC
Created attachment 105332 [details]
filezilla-3.0.0_beta4.ebuild

Fixes MY_PV and make_desktop_entry.
Comment 19 Kalidarn 2007-01-03 20:35:15 UTC
ooops didn't notice the typo in making desktop entry ;)
Comment 20 Kalidarn 2007-01-03 20:50:33 UTC
One of the gentoo devleopers said you only needed:

myconf="--with-wx-config=/usr/lib/wx/config/gtk2-unicode-release-2.8"

and you could remove the 'local' ;P the filezilla dev also said that.

Also i was instructed to use emake instead of make.
Comment 21 Saurabh Singhvi 2007-01-04 22:48:27 UTC
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../src/include -I./../include -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -I/usr/include -I/usr/include   -march=prescott -O2 -pipe -fomit-frame-pointer -Wall -g -fexceptions -MT libengine_a-notification.o -MD -MP -MF ".deps/libengine_a-notification.Tpo" -c -o libengine_a-notification.o `test -f 'notification.cpp' || echo './'`notification.cpp; \
then mv -f ".deps/libengine_a-notification.Tpo" ".deps/libengine_a-notification.Po"; else rm -f ".deps/libengine_a-notification.Tpo"; exit 1; fi
httpcontrolsocket.cpp:976: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [libengine_a-httpcontrolsocket.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/net-ftp/filezilla-3.0.0_beta4/work/filezilla-3.0.0-beta4/src/engine'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-ftp/filezilla-3.0.0_beta4/work/filezilla-3.0.0-beta4/src'
make: *** [all-recursive] Error 1

!!! ERROR: net-ftp/filezilla-3.0.0_beta4 failed.
Call stack:
  ebuild.sh, line 1580:   Called dyn_compile
  ebuild.sh, line 945:   Called src_compile
  filezilla-3.0.0_beta4.ebuild, line 39:   Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


I get this error. gcc-version 3.4.6. wxGTK-2.8 emerged. (with flags X -debug -doc gif gnome -joystick -odbc opengl sdl -stl unicode)
Comment 22 Kalidarn 2007-01-05 00:40:14 UTC
Why are you using sys-devel/gcc-3.4.6 its in ~arch when sys-devel/gcc-4.1.1-r1 is in stable?
Comment 23 Saurabh Singhvi 2007-01-05 03:07:57 UTC
my system isn't exactly a new one. I had gcc-3.4.6 when 4 branch wasn't in stable. But on the issue, it should still compile anyways, right?

Saurabh
Comment 24 Samuli Suominen gentoo-dev 2007-01-05 07:15:16 UTC
ebuild needs a bit work.. 

- everything else is RDEPEND except sys-devel/gettext is DEPEND (haven't checked but it's usual..)

- you can't just run ./autogen.sh, use autotools eclass instead.

- this is deprecated style, and /usr/lib might as well be /usr/lib64 so you need inherit multilib as well for get_libdir I believe. so..

myconf="--with-wx-config=/usr/lib/wx/config/gtk2-unicode-release-2.8"
econf ${myconf} || die "econf failed"

should be something like..

econf --with-wx-config=${get_libdir}/wx/config/gtk2-unicode-release-2.8

and that makes me wonder if it's allways 2.8 or not, perhaps it's 2.10 in newer versions?

- in src_install() instead of make ${DESTDIR} install, use emake ${DESTDIR} install.

these is all from my hat and I haven't verified anything.
Comment 25 Charlie Shepherd (RETIRED) gentoo-dev 2007-01-05 11:08:51 UTC
(In reply to comment #24)
> econf --with-wx-config=${get_libdir}/wx/config/gtk2-unicode-release-2.8

$(get_libdir) ;) (You are calling the function get_libdir, not the variable get_libdir)

> perhaps it's 2.10 in newer
> versions?

Quite possibly, in which case it would make sense to tighten the deps

> - in src_install() instead of make ${DESTDIR} install, use emake ${DESTDIR}
> install.

While this is technically true, a lot of make install's fail with parallel make.

> these is all from my hat and I haven't verified anything.

Most are correct :)
Comment 26 Paul Bredbury 2007-01-12 03:53:20 UTC
Created attachment 106618 [details]
filezilla-3.0.0_beta5.ebuild

Tried (but failed) to remove the execution of autogen.sh
Comment 27 Kalidarn 2007-01-26 23:04:40 UTC
Created attachment 108241 [details, diff]
transfersocketpatch.patch

Fixes an annoying listing problem.
Comment 28 Kalidarn 2007-01-26 23:06:01 UTC
Created attachment 108242 [details]
filezilla-3.0.0_beta5.ebuild (WORKING)

Same as the beta4 ebuild but renamed. Yeah I know it doesn't include the good ebuild practice additions mentioned above, but it does work. Unfortunately I don't have the expertise to fix the other beta5 ebuild.
Comment 29 Kalidarn 2007-02-12 11:36:50 UTC
Created attachment 109941 [details]
filezilla-3.0.0_beta5.ebuild

Cleaned up and works.
Comment 30 Kalidarn 2007-02-12 11:48:40 UTC
Created attachment 109942 [details]
filezilla-3.0.0_beta5.ebuild

REMOVED WANT ARGUMENTS
Comment 31 Kalidarn 2007-02-12 14:19:07 UTC
Created attachment 109946 [details]
filezilla-3.0.0_beta5.ebuild

Altered Dependencies.
Comment 32 Kalidarn 2007-02-12 15:25:24 UTC
Created attachment 109958 [details]
filezilla-3.0.0_beta5.ebuild

Fixed deps again :) ill try to stop this.
Comment 33 Kalidarn 2007-02-20 17:37:48 UTC
Created attachment 110743 [details]
filezilla-3.0.0_beta6.ebuild

NEW VERSION.

http://filezilla-project.org/changelog.php
Comment 34 Kalidarn 2007-03-28 00:36:54 UTC
Created attachment 114687 [details]
filezilla-3.0.0_beta7.ebuild
Comment 35 Paul Bredbury 2007-03-28 04:49:51 UTC
Created attachment 114695 [details]
filezilla-3.0.0_beta7.ebuild

Tidied ebuild.
Comment 36 Kalidarn 2007-04-01 17:14:18 UTC
Created attachment 115185 [details]
filezilla-3.0.0_beta7.ebuild

fixes an issue related to FTPS Implicit connections not listing.
Comment 37 Kalidarn 2007-04-01 17:14:46 UTC
Created attachment 115187 [details, diff]
ssl-socket-fix.patch
Comment 38 Kalidarn 2007-05-16 10:20:29 UTC
Created attachment 119426 [details]
filezilla-3.0.0_beta8.ebuild
Comment 39 Kalidarn 2007-06-05 03:57:33 UTC
Created attachment 121212 [details]
filezilla-3.0.0_beta10.ebuild
Comment 40 Matthew Schultz 2007-06-27 16:03:55 UTC
Created attachment 123219 [details]
filezilla-3.0.0_beta10.ebuild

Changed dependency of wxGTK to >=2.8.4 (it's required)
Since the ebuild doesn't exist on gentoo mirrors, it should be restricted to no mirrors.
Comment 41 Kalidarn 2007-06-27 16:36:16 UTC
Comment on attachment 121212 [details]
filezilla-3.0.0_beta10.ebuild

Agreed.
Comment 42 Gustavo Felisberto (RETIRED) gentoo-dev 2007-07-02 10:49:23 UTC
(In reply to comment #40)
> Created an attachment (id=123219) [edit]
> filezilla-3.0.0_beta10.ebuild
> 
> Changed dependency of wxGTK to >=2.8.4 (it's required)
> Since the ebuild doesn't exist on gentoo mirrors, it should be restricted to no
> mirrors.
> 

The nomirror is not for this. nomirror is to restrict the fetching of the SRC_URI to the gentoo mirrors when upstream does not allow us to have a copy of the file.

If this depends on something that does not exist you should:

1-Search for a open bug about >=2.8.4 and make this depend on that bug.
2-If one does not exist, open such a bug and make this depend on that.
Comment 43 Matthew Schultz 2007-07-02 13:07:11 UTC
(In reply to comment #42)
> (In reply to comment #40)
> > Created an attachment (id=123219) [edit]
> > filezilla-3.0.0_beta10.ebuild
> > 
> > Changed dependency of wxGTK to >=2.8.4 (it's required)
> > Since the ebuild doesn't exist on gentoo mirrors, it should be restricted to no
> > mirrors.
> > 
> 
> The nomirror is not for this. nomirror is to restrict the fetching of the
> SRC_URI to the gentoo mirrors when upstream does not allow us to have a copy of
> the file.
> 
> If this depends on something that does not exist you should:
> 
> 1-Search for a open bug about >=2.8.4 and make this depend on that bug.
> 2-If one does not exist, open such a bug and make this depend on that.
> 

1. This bug already depends on wxGTK.
2. This ebuild doesn't exist in portage and gentoo mirrors don't always time out in a timely manner.  If this ebuild ever makes it into portage, then remove restrict at that point.  I don't see the point in having to wait long periods of time so the gentoo mirrors can time out just for testing purposes.
Comment 44 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-07-02 16:13:02 UTC
(In reply to comment #43)
> restrict at that point.  I don't see the point in having to wait long periods
> of time so the gentoo mirrors can time out just for testing purposes.

GENTOO_MIRRORS="" ebuild foo.ebuild compile
GENTOO_MIRRORS="" emerge foo
...

Comment 45 Paul Bredbury 2007-07-02 16:25:56 UTC
> so the gentoo mirrors can time out just for testing purposes.

You're waiting for a "file not found" error, not a timeout. For me it takes about 2 seconds or less. Consider changing GENTOO_MIRRORS in /etc/make.conf. I use:

GENTOO_MIRRORS="http://gentoo.virginmedia.com"
Comment 46 Matthew Schultz 2007-07-02 17:10:54 UTC
(In reply to comment #44)
> (In reply to comment #43)
> > restrict at that point.  I don't see the point in having to wait long periods
> > of time so the gentoo mirrors can time out just for testing purposes.
> 
> GENTOO_MIRRORS="" ebuild foo.ebuild compile
> GENTOO_MIRRORS="" emerge foo
> ...
> 

Ok, thanks for the tip.  I was thinking more about when I have to generate a new digest so this works:

GENTOO_MIRRORS="" ebuild filezilla-3.0.0_beta10.ebuild digest
Comment 47 Matthew Schultz 2007-07-02 17:12:31 UTC
Created attachment 123703 [details]
filezilla-3.0.0_beta10.ebuild

Removed restrict due to previous comments above.
Comment 48 Jason Smathers (RETIRED) gentoo-dev 2007-07-23 03:43:37 UTC
Created attachment 125718 [details]
filezilla-3.0.0_beta11.ebuild

beta10 version tested and working for beta11
Comment 49 Roy Marples (RETIRED) gentoo-dev 2007-07-23 14:54:55 UTC
net-ftp herd as no time for filezilla atm.
If anyone here would like to join the herd then we can get this into portage
Comment 50 Jason Smathers (RETIRED) gentoo-dev 2007-07-24 01:20:37 UTC
It seems that it will be some time before wxGTK is in portage and because of the wxGTK situation, we cannot get the ebuild into Sunrise.  From the time being filezilla-3.0.0_beta11.ebuild is now in drizzt-overlay along with wxGTK 2.8.4
Comment 51 Jason Smathers (RETIRED) gentoo-dev 2007-08-16 05:03:00 UTC
Bumped to filezilla-3.0.0_rc1.ebuild
Current ebuild tested and working for rc1.
Tested on x86.

I've asked drizzt to kindly revbump in his overlay.
Comment 52 Kalidarn 2007-08-17 17:32:36 UTC
Created attachment 128417 [details, diff]
filezila-rate-fix.patch

http://filezilla.svn.sourceforge.net/viewvc/filezilla/FileZilla3/trunk/src/engine/backend.cpp?r1=1343&r2=1573&view=patch

to be used in net-ftp/filezilla-3.0.0_rc1 this fixes a bug with the rate limiter.
Comment 53 Kalidarn 2007-08-27 12:04:17 UTC
Comment on attachment 128417 [details, diff]
filezila-rate-fix.patch

Not required anymore as it's merged with RC2 which is now out
Comment 54 Jason Smathers (RETIRED) gentoo-dev 2007-08-27 13:15:59 UTC
the same ebuild works for RC2
Comment 55 Vasilis Lourdas 2007-09-03 17:54:21 UTC
It would be nice to see Filezilla in portage. This client rocks in Windows.
Comment 56 Jason Smathers (RETIRED) gentoo-dev 2007-09-04 03:36:38 UTC
Vasileios P. Lourdas et al,
It is in drizzt's overlay for now.  We will get it into portage once bug #145884 is resolved.
-Jason
Comment 57 Kalidarn 2007-09-05 22:28:10 UTC
THe same ebuild works for RC3
Comment 58 Ludovic Fauvet 2007-09-10 23:22:00 UTC
Filezilla 3.0.0 (stable) is now officially out.
http://filezilla.sourceforge.net/forum/viewtopic.php?t=4203
Comment 59 Vasilis Lourdas 2007-09-11 09:54:38 UTC
The beta11 ebuild as it exists in the drizzt-overlay, works fine in my local overlay, except for the 'doicon src/interface/resources/${PN}.xpm || die "doicon failed"' statement in the src_install() function. It fails on the .xpm file, the file does not exist. Comment it and the install completes.

wxGTK-2.8.4.0 has a lot of warnings in the ebuild. Other than that, the application seems to work fine.
Comment 60 Vasilis Lourdas 2007-09-11 09:55:19 UTC
Oh, I forgot to mention that I tested the ebuild against the 3.0.0 final version.
Comment 61 zhoumi 2007-09-13 01:01:57 UTC
Created attachment 130781 [details]
filezilla-3.0.0.ebuild

filezilla-3.0.0 final version test success.

--- doicon src/interface/resources/${PN}.xpm || die "doicon failed"
+++ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"

--- make_desktop_entry ${PN} "FileZilla" ${PN}.xpm
+++ make_desktop_entry ${PN} "FileZilla" ${PN}.png
Comment 62 zhoumi 2007-09-13 01:04:07 UTC
Comment on attachment 130781 [details]
filezilla-3.0.0.ebuild

filezilla-3.0.0 final version test success.

--- doicon src/interface/resources/${PN}.xpm || die "doicon failed"
+++ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"

--- make_desktop_entry ${PN} "FileZilla" ${PN}.xpm
+++ make_desktop_entry ${PN} "FileZilla" ${PN}.png
Comment 63 Jakub Moc (RETIRED) gentoo-dev 2007-09-24 06:02:15 UTC
*** Bug 193588 has been marked as a duplicate of this bug. ***
Comment 64 ascii 2007-10-03 20:47:53 UTC
the filezilla-3.0.0.ebuild doesn't work for me

nopaste filezilla.log
http://rafb.net/p/q8OTKq14.html

 emerge  --info
Portage 2.1.3.11 (default-linux/amd64/2007.0/desktop, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r6 x86_64 Dual-Core AMD Opteron(tm) Processor 1218
Timestamp of tree: Tue, 02 Oct 2007 18:30:06 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -mtune=opteron -O2 -pipe -msse2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=opteron -mtune=opteron -O2 -pipe -msse2"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fix-packages metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.gentoo.skynet.be/pub/gentoo/"
LANG="de_DE"
LINGUAS="de en_US en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/sunrise /usr/local/xeffects/xeffects/trunk /usr/local/gnome-experimental-old"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xgl a52 aac acl acpi alsa amd64 bash-completion berkdb beryl bitmap-fonts bzip2 cairo cdr chroot cli cracklib crypt cups curl dbus directfb dri drscheme dts dvd dvdr dvdread eds emboss encode evo expat fam ffmpeg firefox flac fortran ftp gaim gdbm gif gimpprint gnome gnutls gphoto2 gpm gstreamer gtk gtk2 hal iconv imagemagick ipv6 isdnlog java jpeg jpeg2k kerberos latin1 lzo mad matroska midi mikmod mjpeg mmx mp3 mp4 mpeg msn mudflap nautilus ncurses nfs nls nptl nptlonly nsplugin ntfs ogg opengl openmp openssl pam pcre pdf perl pic png pppd print profile python qt3 qt3support qt4 quicktime rdesktop readline reflection samba screen sdl session sockets socks5 source speex spell spl srt sse sse2 ssl svg tcl tcltk tcpd themes theora tiff tk truetype truetype-fonts type1-fonts unicode usb vorbis wxwindows xgl xinerama xml xorg xprint xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en_US en" USERLAND="GNU" VIDEO_CARDS="vesa vga nvidia nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


eix wxGTK
[D] x11-libs/wxGTK
     Available versions:  (2.6)  2.6.3.3 2.6.4.0
        {X debug doc gnome joystick odbc opengl sdl unicode}
     Installed versions:  2.6.4.0(2.6)(22:11:19 18.09.2007)(X gnome opengl sdl unicode -debug -doc -joystick -odbc)
                          2.8.4.0(2.8)[1](22:19:07 03.10.2007)(X gif gnome opengl sdl unicode -debug -doc -joystick -odbc -stl)
     Homepage:            http://wxwidgets.org/
     Description:         GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit.

[1] "ascii-local" /usr/local/portage


nopaste /usr/local/portage/x11-libs/wxGTK/wxGTK-2.8.4.0.ebuild 
http://rafb.net/p/08NHby64.html
Comment 65 Alois Hammer 2007-10-11 16:33:03 UTC
Created attachment 133155 [details]
filezilla-3.0.1.ebuild

This bumps support to FileZilla 3.0.1 and fixes compilation (the configure script can't detect the location of wxrc on its own).
Comment 66 Alois Hammer 2007-10-11 16:39:51 UTC
What would it take to get a maintainer for this package?  I'm up for it...

Good build of 3.0.1 on ~x86:

Portage 2.1.3.12 (default-linux/x86/no-nptl, gcc-4.2.1, glibc-2.5-r4, 2.6.23-gentoo i686)
=================================================================
System uname: 2.6.23-gentoo i686 Intel(R) Pentium(R) D CPU 2.80GHz
Timestamp of tree: Thu, 11 Oct 2007 07:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r5
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /opt/sun-jdk-1.4.2.15/jre/lib/i386"
CXXFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://spatha.bcas.lan/ http://gentoo.mirrors.tera-byte.com/ http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://ftp.jaist.ac.jp/pub/Linux/Gentoo/ http://ftp.iij.ad.jp/pub/linux/gentoo/ http://ftp.twaren.net/Linux/Gentoo/"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnome-experimental /usr/portage/local/layman/sunrise /usr/portage/local/layman/java-overlay /usr/portage/local/layman/custom-kernels /usr/portage/local/layman/vmware /usr/portage/local/layman/gentopia /usr/portage/local/layman/secondlife /usr/portage/local/layman/xeffects /usr/portage/local/layman/berkano /usr/portage/local/layman/dirtyepic /usr/portage/local/gcc /usr/portage/local/greycstoration /usr/portage/local/ksquirrel /usr/portage/local/vlc-svn /usr/portage/local/filezilla"
SYNC="rsync://spatha.bcas.lan/gentoo-portage"
USE="16bit 16bit-indices 64bit 7zip S3TC X a52 aac acct ace acl acpi addbookmarks additions adns adplug agg aim aio alias alsa amazon amr amrnb amrwb animgif ao aoss aotuv apache2 ares asf asm aspnet2 async audiofile authlib bash-completion bdf berkdb bgpclassless binary-drivers binfilter bl bluetooth bonobo bookmarks boost branding bzip2 cairo cardbus catalogs cdda cddb cdparanoia cdr chardet chm chroot clamav cli colordiff connectionstatus console contactnotes corba courier cpudetection cracklib crypt css cups curl curlwrappers custom-cflags dbus dbx deprecated depth32 device-mapper devil dga disk-partition divx djvu dmi domain-aware dri dts dv dvd dvdr dvdread dvi dynamic ecc emboss emf emovix enca enchant encode erandom exif extensions extraengine extrafilters fam fame fat fdftk ffmpeg fftw firefox fix-connected-rt flac flash flexresp2 fluidsynth font-server fontconfig foomaticdb fortran fpx freetts ftp fuse galago gd gdbm geoip gif gimp glib glibc-omitfp glitz glut gmedia gmp gnutls gps graphviz groupwise gs gstreamer gtk guile gzip hal hddtemp hdri hfs highlight history howl howl-compat hpn html ibam iconv icq icu idea idn ignore-case imagemagick imap imlib injection inline innodb insecure-savers ipv6 irc ithreads jabber jack java java-external java5 javascript jbig jce jfs jikes jingle joystick jpeg jpeg2k jrtplib kde kdeenablefinal kdehiddenvisibility kdexdeltas kdm keyring kipi ladspa lame lash libclamav libnotify libsamplerate libsexy libwww linuxthreads-tls live lm_sensors log4j logitech-mouse logrotate lua lzo lzw mad madwifi magic maildir matroska mbrola meanwhile memlimit metalink mfd-rewrites midi mikmod mime mjpeg mmap mmkeys mmx mng mod modplug motif mozdom mp2 mp3 mp4 mpeg mpi mplayer msn mudflap musepack music musicbrainz nautilus ncurses nemesi netcdf network new-reg-alloc newspr nls nodrm nolvm1 nolvmstatic nsplugin nspr nss ntfs ntp nut obex odbc offensive ofx ogg ole openal openexr opengl openssl osc oscar oss pam pam_console pam_timestamp pango parse-clocks pch pci pcntl pcre pcsc-lite pdf perl plugin png posix postfix postscript ppds pppd prediction pulseaudio pwdb python q32 qq qt3support qt4 quotes rar rc5 rdesktop readline real realmedia reflection reiserfs remix replaygain rle rpm rtc rtsp samba sametime sdl session sharedmem shorten shout silc skins slang smp sms sndfile snmp sockets sound sox speex spell spl sqlite sqlite3 srt sse sse2 ssl ssse3 startup-notification subtitles svg svgz symlink sysfs sysvipc szip t1lib tagwriting texteffect theora threads threadsafe tiff timidity tntc trayicon truetype truetype-fonts tta type1 unicode urandom usb userlocales utempter uuencode vcd voice vorbis vorbis-psy wavpack webdav webpresence wideband win32codecs winpopup wma wmf wmp x264 x86 xanim xattr xcb xcomposite xext xfs xft xgetdefault xml xmldoclet xmlreader xmlrpc xmlwriter xorg xosd xpm xprint xrandr xscreensaver xsl xslt xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="maestro3 asihpi darla20 darla24 echo3g gina20 gina24 hdsp hdspm indigo indigoio korg1212 layla20 layla24 mia mixart mona pcxhr sb16 usbusx2y vx222" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 67 Bernd Steinhauser 2007-10-13 12:27:18 UTC
(In reply to comment #65)
> Created an attachment (id=133155) [edit]
> filezilla-3.0.1.ebuild
> 
> This bumps support to FileZilla 3.0.1 and fixes compilation (the configure
> script can't detect the location of wxrc on its own).
> 

I get an error, but that seems to be related to the wxwidget eclass.

Just one question: 
> if use unicode; then
You use use flag unicode, but you didn't put it in IUSE. Forgot to do so?

!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/bin/wxgtk2u-2.4-config not found
!!! set-wxconfig:         /usr/bin/wxgtk2ud-2.4-config not found

I fixed it by changing 
if [ "${WX_GTK_VER}" = "2.6" ]; then
to
if [ "${WX_GTK_VER}" = "2.6" -o "${WX_GTK_VER}" = "2.8" ]; then
(I know, that one should not really do this. ;))
Comment 68 Alois Hammer 2007-10-13 16:13:22 UTC
Created attachment 133341 [details]
filezilla-3.0.2_rc1.ebuild

I didn't forget to include unicode in IUSE, exactly; I just started with the 3.0.0 ebuild posted by zhoumi.  Anyhow, I included unicode in IUSE and bumped to 3.0.2_rc1 because-- hey, we all like living on the bleeding edge, or we wouldn't use Gentoo, right? ;)

As for your wxconfig problems, I'm not sure what's going on.  Are you sure your wx* packages are correctly installed?  Run revdep-rebuild?
Comment 69 Bernd Steinhauser 2007-10-13 17:32:19 UTC
> As for your wxconfig problems, I'm not sure what's going on.  Are you sure your
> wx* packages are correctly installed?  Run revdep-rebuild?
> 

Almost sure. wx-config is where it should be:
ls -l /usr/lib/wx/config/
insgesamt 168
-rwxr-xr-x 1 root root 39446 19. Aug 11:48 gtk2-ansi-release-2.6
-rwxr-xr-x 1 root root 41895 12. Okt 17:41 gtk2-ansi-release-2.8
-rwxr-xr-x 1 root root 39474 19. Aug 11:48 gtk2-unicode-release-2.6
-rwxr-xr-x 1 root root 41923 12. Okt 17:41 gtk2-unicode-release-2.8

The thing is, that the wxwidgets eclass chooses the wrong path:
    if [ "${WX_GTK_VER}" = "2.6" ] ; then
        wxconfig_prefix="/usr/$(get_libdir)/wx/config"
        wxconfig_name="${1}-release-${WX_GTK_VER}"
        wxconfig="${wxconfig_prefix}/${wxconfig_name}"
        wxconfig_debug_name="${1}-debug-${WX_GTK_VER}"
        wxconfig_debug="${wxconfig_prefix}/${wxconfig_debug_name}"
    else
        # Default is 2.4:
        wxconfig_prefix="/usr/bin"
        wxconfig_name="${1}-${WX_GTK_VER}-config"
        wxconfig="${wxconfig_prefix}/${wxconfig_name}"
        wxconfig_debug_name="${1}d-${WX_GTK_VER}-config"
        wxconfig_debug="${wxconfig_prefix}/${wxconfig_debug_name}"
    fi

Because the first (obviously) doesn't match, since in the ebuild WX_GTK_VER
is set to 2.8 it selects the second one, where it doesn't find anything,
because wxGTK-2.4 is no more and the paths are different for wxGTK-2.8s paths.
The resolution was (as I stated above) to add 2.8 to the test, so that the
first case is chosen.

What bothers me about this is, that it seems, that only I get this error.
Shouldn't that error exist for everyone?
wxGTK is 2.8.5 from the wxGTK bug.
Comment 70 Alois Hammer 2007-10-13 18:43:35 UTC
I'm using x11-libs/wxGTK-2.8.6.0 - dirtyepic overlay.  Give that a spin?
Comment 71 ascii 2007-10-13 20:35:09 UTC
(In reply to comment #70)
> I'm using x11-libs/wxGTK-2.8.6.0 - dirtyepic overlay.  Give that a spin?
> 

works like a charm here.

the new releases works here.
the old wasn't. There was a invaild pointer.
Comment 72 Bernd Steinhauser 2007-10-14 11:29:54 UTC
The new wxwidgets eclass hit the tree, all problems gone for me.
Comment 73 Alois Hammer 2007-10-22 00:01:30 UTC
Created attachment 134093 [details]
filezilla-3.0.2.1.ebuild

Bump to 3.0.2.1 stable.
Comment 74 Akshay Shah 2007-10-31 19:35:40 UTC
New version of filezilla is out today (3.0.3_rc1). Ebuild for filezilla-3.0.2.1 works fine on ~amd64.

$ emerge --info
Portage 2.1.3.16 (default-linux/amd64/2007.0/desktop, gcc-4.2.2, glibc-2.6.1-r0, 2.6.23-gentoo x86_64)
=================================================================
System uname: 2.6.23-gentoo x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz
Timestamp of tree: Wed, 31 Oct 2007 12:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.5.1-r3
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks metadata-transfer nodoc noinfo parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://gentoo.netnitco.net"
LINGUAS="en en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/local/portage"
SYNC="rsync://mccoy/gentoo-portage"
USE="X a52 aac acpi alsa amd64 bash-completion bitmap-fonts branding bzip2 cairo cdr cli cracklib crypt cups curl dbus dri dts dvd dvdr dvdread eds emboss evo fam ffmpeg firefox fortran gdbm gif gmp gnome gnutls gtk hal iconv imagemagick isdnlog java jpeg jpeg2k kde libnotify mad md5sum midi mikmod mmx mng motif mp3 mpeg mudflap ncurses network-cron nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pcre pdf perl pertty png ppds pppd python qt3 qt3support quicktime readline reflection samba scanner sdl session sndfile spl sse sse2 ssl startup-notification svg tcpd theora tiff transparency truetype truetype-fonts type1-fonts unicode vcd vim-syntax vorbis wmf x264 xcb xinerama xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 75 Alois Hammer 2007-11-01 01:59:50 UTC
Just rename filezilla-3.0.2.1.ebuild to filezilla-3.0.3_rc1.ebuild, rebuild manifests, and emerge.  Compiles fine.  I'm going to stop releasing ebuilds unless something significant changes in the code and/or required build process.

Still compiling against wxGTK 2.8.
Comment 76 Vasilis Lourdas 2007-11-11 00:05:43 UTC
Copying 3.0.2.1 ebuild to 3.0.3 and trying to emerge it, it fails with the message:

checking if i686-pc-linux-gnu-gfortran supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-gfortran linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for wx-config... /usr/lib/wx/config/gtk2-unicode-release-2.8
checking for wxWidgets version >= 2.8.6... no (version 2.8.4 is not new enough)
configure: error:
        	wxWidgets must be installed on your system
		but wx-config script couldn't be found.

		Please check that wx-config is in path, the directory
		where wxWidgets libraries are installed (returned by
		'wx-config --libs' command) is in LD_LIBRARY_PATH or
		equivalent variable and wxWidgets version is 2.8.6 or above.
	

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/net-ftp/filezilla-3.0.3/work/filezilla-3.0.3/config.log
 * 
 * ERROR: net-ftp/filezilla-3.0.3 failed.
 * Call stack:
 *                ebuild.sh, line 1701:  Called dyn_compile
 *                ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                ebuild.sh, line   44:  Called src_compile
 *   filezilla-3.0.3.ebuild, line   41:  Called econf '--with-wx-config=/usr/lib/wx/config/gtk2-unicode-release-2.8'
 *                ebuild.sh, line  638:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-ftp/filezilla-3.0.3/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/portage/'

xwGTK-2.8.6 is now required.
Comment 77 Alois Hammer 2007-11-11 05:06:46 UTC
(In reply to comment #76)

> xwGTK-2.8.6 is now required.

Well, yeah.  It's the current stable release of wxWindows for GTK+.  It's what *should* be in x86, or at least ~x86.
Comment 78 Pham Ngoc Hai 2007-11-14 08:16:20 UTC
Here is my filezilla-3.0.3 ebuild, you need >=wxGTK-2.6.8 for it to compile.
Comment 79 Pham Ngoc Hai 2007-11-14 08:17:40 UTC
Created attachment 135941 [details]
filezilla-3.0.3.ebuild
Comment 80 Vasilis Lourdas 2007-11-14 15:59:29 UTC
(In reply to comment #79)
> Created an attachment (id=135941) [edit]
> filezilla-3.0.3.ebuild

I am sorry to disappoint you, but your 3.0.3 ebuild is not an ebuild, because it does not satisfy the required dependencies. :-)
Comment 81 Alois Hammer 2007-11-14 17:20:58 UTC
(In reply to comment #79)
> Created an attachment (id=135941) [edit]
> filezilla-3.0.3.ebuild
> 

This doesn't compile because it doesn't handle WXRC, and it really needs RESTRICT="mirror", because the source code can't be obtained from official Gentoo mirror sites.
Comment 82 Kalidarn 2007-11-14 21:42:09 UTC
I think you mean it needs >=x11-libs/wxGTK-2.8.6 ;)
Comment 83 Pham Ngoc Hai 2007-11-15 10:02:30 UTC
Created attachment 136034 [details]
filezilla-3.0.3.ebuild

This is a fix for the previous ebuild, thanks to all your comments.
This is the first time I post an ebuild anyway :)
Comment 84 Alois Hammer 2007-11-20 18:31:14 UTC
Created attachment 136514 [details]
net-ftp/filezilla-3.0.4_rc1.ebuild

Okay, we've got a new ebuild for 3.0.4-rc1.  I'm also posting an ebuild for gnutls 2.0.4 because 3.0.4 won't build without it.  The gnutls ebuild is just a renamed copy of the official Portage 2.0.3.
Comment 85 Alois Hammer 2007-11-20 18:32:10 UTC
Created attachment 136515 [details]
net-libs/gnutls-2.0.4.ebuild

...and the supporting ebuild for fz 3.0.4_rc1.
Comment 86 Alois Hammer 2007-11-20 18:35:29 UTC
(In reply to comment #84)
> Created an attachment (id=136514) [edit]
> net-ftp/filezilla-3.0.4_rc1.ebuild
> 
> Okay, we've got a new ebuild for 3.0.4-rc1.  I'm also posting an ebuild for
> gnutls 2.0.4 because 3.0.4 won't build without it.  The gnutls ebuild is just a
> renamed copy of the official Portage 2.0.3.

NOTE: This ebuild does not appear to compile yet because there's a bug in the code:

ftpcontrolsocket.h:108: error: extra qualification 'CFtpControlSocket::' on member 'GetLoginSequence'
Comment 87 Bernd Steinhauser 2007-11-26 18:03:33 UTC
(In reply to comment #84)
> Created an attachment (id=136514) [edit]
> net-ftp/filezilla-3.0.4_rc1.ebuild
> 
> Okay, we've got a new ebuild for 3.0.4-rc1.  I'm also posting an ebuild for
> gnutls 2.0.4 because 3.0.4 won't build without it.  
Then you should update the dependency as well in the ebuild.
Currently it is:
>=net-libs/gnutls-1.6.1

BTW, if this is needed for compile it shouldn't go in RDEPEND, but in DEPEND.
The same for wxGTK, which you should update to 2.8.6 as well. ;)
Comment 88 Alois Hammer 2007-11-27 06:03:05 UTC
Created attachment 137100 [details]
net-ftp/filezilla-3.0.4.ebuild

This ebuild has had DEPENDS and RDEPENDS rearranged and adjusted to take feedback into account.  Builds and runs fine, unlike 3.0.4-rc1.  gcc 4.2.2, glibc 2.7, all that jazz.
Comment 89 Kalidarn 2007-11-27 06:24:17 UTC
I've opened a version bump for gnutls-2.0.4
Comment 90 Vasilis Lourdas 2007-11-27 18:01:01 UTC
OK. And where do we get wxGTK-2.8.6? Is there an overlay for this?
Comment 91 Bernd Steinhauser 2007-11-27 18:30:52 UTC
(In reply to comment #90)
> OK. And where do we get wxGTK-2.8.6? Is there an overlay for this?
> 

layman -S
layman -a dirtyepic
Comment 92 Alex Waite 2007-11-30 01:54:07 UTC
wxGTK is in the tree now, but is hard masked until the eselect stuff gets in.  http://gentoo-portage.com/x11-libs/wxGTK

---Alex
Comment 93 Bernd Steinhauser 2007-12-06 01:31:55 UTC
Hm, unicode useflag should now be activated by default and therefore be unneeded.
Also gnutls attachment is obsolete now, it's in the tree.
Comment 94 Alois Hammer 2007-12-06 03:06:32 UTC
Comment on attachment 136515 [details]
net-libs/gnutls-2.0.4.ebuild

GNUTLS 2.0.4 has finally made it into mainline Portage.
Comment 95 Pandor 2007-12-08 17:53:00 UTC
Doesn't seem to compile against wxGTK-2.8.7.1 (unmasked).


/usr/lib/libwx_gtk2u_richtext-2.8.so: undefined reference to `wxColour::IsOk() const'
collect2: ld returned 1 exit status
make[3]: *** [filezilla] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src/interface'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src/interface'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src'
make: *** [all-recursive] Error 1


Comment 96 Pandor 2007-12-08 18:08:59 UTC
(In reply to comment #95)
> Doesn't seem to compile against wxGTK-2.8.7.1 (unmasked).
> 
> 
> /usr/lib/libwx_gtk2u_richtext-2.8.so: undefined reference to `wxColour::IsOk()
> const'
> collect2: ld returned 1 exit status
> make[3]: *** [filezilla] Error 1
> make[3]: Leaving directory
> `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src/interface'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory
> `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src/interface'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/src'
> make: *** [all-recursive] Error 1
> 

My full log:
http://pastebin.com/m664911f0
Comment 97 Bernd Steinhauser 2007-12-08 19:05:59 UTC
(In reply to comment #95)
> Doesn't seem to compile against wxGTK-2.8.7.1 (unmasked).
> 
It does compile here.
Comment 98 Pandor 2007-12-11 15:18:13 UTC
(In reply to comment #97)
> (In reply to comment #95)
> > Doesn't seem to compile against wxGTK-2.8.7.1 (unmasked).
> > 
> It does compile here.
> 
Re-compiled wxGTK-2.8.7.1 without 'fvisibility-inlines-hidden' flag and filezilla compiled just fine.
Comment 99 Jakub Moc (RETIRED) gentoo-dev 2007-12-14 18:00:42 UTC
*** Bug 202281 has been marked as a duplicate of this bug. ***
Comment 100 onip 2007-12-22 13:41:07 UTC
I would comment out the line in which it does .desktop file because it makes a double entry in the menu.

ps shouldn't wxGTK be in RDEPEND too? I built filezilla on my desk and then emerged -k on the notebook.

It died while chechinx if wx would support X because portage didn't require wxGTK to be installed with a binary installation.

p.s. i'm using portage ebuild
Comment 101 Jason Smathers (RETIRED) gentoo-dev 2007-12-22 14:52:05 UTC
Andrea, I committed again with these changes made.
Comment 102 Pham Ngoc Hai 2008-04-23 10:54:19 UTC
Created attachment 150692 [details]
net-ftp/filezilla-3.0.9.ebuild

Version bump.
Comment 103 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-04-23 11:32:56 UTC
(In reply to comment #102)
> Created an attachment (id=150692) [edit]
> net-ftp/filezilla-3.0.9.ebuild
> 
> Version bump.

This bug is about adding filezilla to tree which was done and bug is thus closed. For version bumps please open a new bug. Or in this case look at bug 206600.