Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88980 - boa-constructor-0.3.1_alpha crashes with on startup on AMD64
Summary: boa-constructor-0.3.1_alpha crashes with on startup on AMD64
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-13 09:54 UTC by Morten Alver
Modified: 2007-01-30 05:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Alver 2005-04-13 09:54:04 UTC
boa-constructor-0.3.1_alpha crashes on startup with the output reproduced below.  The output appears as the application shows the splash screen. After the splash screen the final error message appears in a dialog box (and in the console). After closing the dialog box, the application seems frozen.

This is on AMD64 - when testing on a Pentium 4 the application works perfectly. I have confirmed that a simple wxPython application runs normally.

Python version: 
Python 2.3.4 (#1, Mar  2 2005, 00:28:24) 
[GCC 3.4.3 20041125 (Gentoo Linux 3.4.3-r1, ssp-3.4.3-0, pie-8.7.7)] on linux2

vxPython version: 2.4.2.4

Output from Boa Constructor:

Starting Boa Constructor v0.3.1
importing wxPython

(process:2989): Gdk-WARNING **: locale not supported by Xlib

(process:2989): Gdk-WARNING **: can not set locale modifiers
reading user preferences
running main...
creating Palette
importing Palette
importing PropertyEditors
importing Companions
importing Companions.FrameCompanions
importing Companions.WizardCompanions
importing Companions.ContainerCompanions
importing Companions.SizerCompanions
importing Companions.BasicCompanions
importing Companions.ButtonCompanions
importing Companions.ListCompanions
importing Companions.GizmoCompanion
importing Companions.LibCompanions
importing Companions.UtilCompanions
importing Companions.DialogCompanions
importing ZopeLib.ZopeCompanions
importing Explorers.ExplorerNodes
importing Models.PythonControllers
importing Models.Controllers
importing Models.EditorModels
importing Views
importing Views.SourceViews
importing PythonEditorModels
importing Views.AppViews
importing Views.PySourceView
importing Views.ProfileView
importing Views.OGLViews
importing Explorers.FileExplorer
importing Models.wxPythonControllers
importing Models.wxPythonEditorModels
importing Views.Designer
importing Views.InspectableViews
importing Views.CollectionEdit
importing Views.DataView
importing Views.SizersView
importing Models.ConfigSupport
importing Models.CPPSupport
importing Models.HTMLSupport
importing Models.XMLSupport
importing ZopeLib.ZopeEditorModels
executing plug-ins...
importing Explorers
importing ZopeLib.ZopeViews
importing ZopeLib.ZopeExplorer
importing Explorers.PrefsExplorer
creating Inspector
importing Inspector
creating Editor
importing Editor
importing Explorers.CVSExplorer
importing Explorers.ZipExplorer
importing Explorers.FTPExplorer
importing Explorers.DAVExplorer
importing Explorers.SSHExplorer
Traceback (most recent call last):
  File "./Boa.py", line 657, in ?
    main()
  File "./Boa.py", line 639, in main
    app = BoaApp()
  File "./Boa.py", line 458, in __init__
    wxApp.__init__(self, false)
  File "/usr/lib/python2.3/site-packages/wxPython/wx.py", line 1951, in __init__
    _wxStart(self.OnInit)
  File "./Boa.py", line 493, in OnInit
    self.main.componentSB, self, self.main)
  File "/usr/lib/python2.3/site-packages/boa/Editor.py", line 296, in __init__
    self.setupToolBar(viewIdx = 0)
  File "/usr/lib/python2.3/site-packages/boa/Editor.py", line 481, in setupToolB
ar
    Utils.duplicateMenu(self.blankEditMenu), 'Edit').Destroy()
AttributeError: 'NoneType' object has no attribute 'Destroy'


Reproducible: Always
Steps to Reproduce:
1. (as root): add line to /etc/portage/package.keywords: dev-util/boa-constructor ~*
2. (as root): emerge boa-constructor
3. (as normal user): boa-constructor

Actual Results:  
See "Details"

Expected Results:  
Show the application window.
Comment 1 Grant Goodyear (RETIRED) gentoo-dev 2005-08-08 10:07:23 UTC
Just as an aside, 0.4.0 does not seem to have this error on amd64.
Comment 2 Steve Dibb (RETIRED) gentoo-dev 2007-01-30 05:39:24 UTC
closing since amd64 isnt even keyworded, not to mention this is old.