Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88868 - Dead keys don't work with openoffice-ximian-1.3.9, and they worked with 1.3.8
Summary: Dead keys don't work with openoffice-ximian-1.3.9, and they worked with 1.3.8
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-12 08:36 UTC by Santiago Gala
Modified: 2005-10-16 15:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Attachment from Novell Bugzilla (vcl-unx-gtk-frame-m110.diff,7.67 KB, text/x-patch)
2005-06-29 08:13 UTC, Pep
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Santiago Gala 2005-04-12 08:36:40 UTC
After I emerged openoffice-ximian-1.3.9 (LINGUAS="es_ES es en_US en") which built a Spanish l10n, dead keys don't work. The same build with 1.3.8 worked right.

Note that other high characters like &ntilde work perfectly. and that acute+p beeps, as in other X apps. It just inserts a plain vowel with them: acute+a=a (instead of á ) Also, I can pasted the chars or use the spelling correction right.

Reverted to 1.3.8 and it works again.



Reproducible: Always
Steps to Reproduce:
1. upgrade to 1.3.9
2. set keyboard distribution to Spanish (gnome allows to check where the accents go)
3. try accent and then a -> a in the document. accent and then p, a beep



Expected Results:  
behave like 1.3.8

~ $ emerge info
Portage 2.0.51.19 (default-linux/ppc/2005.0, gcc-3.4.3-20050110,
glibc-2.3.4.20050125-r1, 2.6.11.6 ppc)
=================================================================
System uname: 2.6.11.6 ppc 7455, altivec supported
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 18 2005, 18:55:22)]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.7.9-r1, 1.4_p6, 1.5, 1.9.5, 1.8.5-r3, 1.6.3
sys-devel/binutils:  2.15.90.0.3-r4
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/bind
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig buildpkg ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://www.ibiblio.org/pub/Linux/distributions/gentoo
http://ftp.easynet.nl/mirror/gentoo/ ftp://ftp.easynet.nl/mirror/gentoo/
ftp://mirror.switch.ch/mirror/gentoo/"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LINGUAS="es_ES es en_US en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X aac aalib aavm accessibility adns alsa altivec apache2
bash-completion berkdb bitmap-fonts bluetooth bonobo cdr cjk crypt cups curl
directfb dv dvd dvdr dvdread emacs emboss esd fam fbcon flac fortran gd gdbm gif
glitz gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal howl icq
imagemagick imlib ipv6 jabber java jpeg junit lcms ldap mad mono motif mozilla
mozsvg mp3 mpeg mysql nas ncurses nls nptl ogg opengl pam pcmcia pcre pdflib
perl pic plotutils png pnp postgres python qt readline ruby samba sasl scanner
sdl slang snmp spell sqlite ssl svg tcltk tcpd threads tiff truetype
truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis xinerama xml xml2 xmms
xosd xprint xv xvid yahoo zlib video_cards_radeon linguas_es_ES linguas_es
linguas_en_US linguas_en"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS
Comment 1 Santiago Gala 2005-04-17 09:17:39 UTC
I did: diff -ur ooo-build-1.3.* 2>&1 | less
between 1.3.8 (works) and 1.3.9 (doesn't), and this struck my eye:

+       * Version 1.3.9
+
+2005-04-04  Michael Meeks  <michael.meeks@novell.com>
+
+       * patches/OOO_1_1/vcl-im-key-plug-m79.diff:
+       remove stray SetIcon change.
+
+       * patches/OOO_1_1/vcl-gtk-mainloop-m79.diff: fix
+       acute slowness with very short timeouts; spinning
+       g_main_context_iteration.

It looks like it is related, at least the description makes it a reasonable candidate for completely breaking the acute accent.

Can anybody who knows ooo-x internals or just gtk confirm?

I'll try to build removing this patch and see if it makes a difference WRT acute handling in Spanish, but it will take looooong time.
Comment 2 Santiago Gala 2005-04-17 11:49:39 UTC
More info: xev on acute+a (notice that keypress event is "
Comment 3 Santiago Gala 2005-04-17 11:49:39 UTC
More info: xev on acute+a (notice that keypress event is "á", but keyrelease is "a", which is what ooo-ximian-1.3.9 inserts in my document:

KeyPress event, serial 29, synthetic NO, window 0x4000001,
    root 0x48, subw 0x0, time 24718521, (286,188), root:(298,284),
    state 0x0, keycode 48 (keysym 0xfe51, dead_acute), same_screen YES,
    XLookupString gives 2 bytes: (c2 b4) "´"
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: True

KeyRelease event, serial 29, synthetic NO, window 0x4000001,
    root 0x48, subw 0x0, time 24718681, (286,188), root:(298,284),
    state 0x0, keycode 48 (keysym 0xfe51, dead_acute), same_screen YES,
    XLookupString gives 2 bytes: (c2 b4) "´"

KeyPress event, serial 29, synthetic NO, window 0x4000001,
    root 0x48, subw 0x0, time 24719141, (286,188), root:(298,284),
    state 0x0, keycode 38 (keysym 0x61, a), same_screen YES,
    XLookupString gives 1 bytes: (61) "a"
    XmbLookupString gives 1 bytes: (61) "a"
    XFilterEvent returns: True

KeyPress event, serial 29, synthetic NO, window 0x4000001,
    root 0x48, subw 0x0, time 24719141, (286,188), root:(298,284),
    state 0x0, keycode 0 (keysym 0x10000e1, U00E1), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 2 bytes: (c3 a1) "á"
    XFilterEvent returns: False

KeyRelease event, serial 29, synthetic NO, window 0x4000001,
    root 0x48, subw 0x0, time 24719290, (286,188), root:(298,284),
    state 0x0, keycode 38 (keysym 0x61, a), same_screen YES,
    XLookupString gives 1 bytes: (61) "a"

The patches between 1.3.8 and 1.3.9 make lots of changes in this area, which I don't understand: see for instance patches/vclplug/vcl-im-key-plug-m79.diff
Comment 4 Santiago Gala 2005-04-18 01:32:03 UTC
More problem isolation: running OpenOffice.org like this:

export OOO_FORCE_DESKTOP=kde
xoowriter &

it works and inserts accented character, though the kde ui is clumsy, because I have only small parts of kde installed here. Running it with:

export OOO_FORCE_DESKTOP=none
xoowriter &

it works too, it behaves like "classic" openoffice.org

trying with =cde brings the gtk ui and it does not work.

This point further towards the patches I signaled previously.
Comment 5 Santiago Gala 2005-04-18 06:59:57 UTC
I posted it upstream: https://bugzilla.novell.com/show_bug.cgi?id=78372
Comment 6 Santiago Gala 2005-04-25 05:54:51 UTC
Same situation with openoffice-ximian-1.3.10:

xoowriter (gtk+) <- dead keys insert unaccented letters, acute+p beeps (as if the input method had recognized an illegal combination) and inserts nothing. All other applications work right.

OO_FORCE_DESKTOP=none xoowriter works as expected
OO_FORCE_DESKTOP=kde xoowriter works as expected
Comment 7 Pep 2005-04-29 03:40:23 UTC
This bug affects x86 arch too.
Comment 8 Santiago Gala 2005-05-05 05:48:52 UTC
Would you be so kind as to "testify" in the Novell bugzilla bug? see comment #4

As an example, I've spent a whole evening try to convince gaim developers about a crash with glib 2.6, and they only accepted the report when a "huh, GNU/Debian, hub GNU/Linux" person arrived confirming the crash.

I'm getting tired of trying to push bugs just to have the reports ignored, I think I'll refrain from further effort until slow distributions (say debian, redhat, etc.) find it and confirm it. For history: it is a regression provoked by gtk backend changes between 1.3.8 and 1.3.9 ximian builds.

Where I wrote OO_FORCE_DESKTOP=none, I should have written OOO_FORCE_DESKTOP=none, BTW. This workaround is good, at the expense of horrible dialogs. It also works for the "F5 navigation below presentation in slide mode" bug.
Comment 9 Pep 2005-05-05 13:58:19 UTC
Por supuesto
Comment 10 Leonel Câmara 2005-05-06 06:08:03 UTC
As was said before this is not only ppc.
I am running x86 (athlon-xp) and I have the exact same problem.
I updated to 1.3.10 and the problem is still here, the only one without it is 1.3.6
Comment 11 Pep 2005-05-06 12:24:22 UTC
The steps to reproduce this bug in x86 arch are the same has been described by Santiago.

gentoo root # emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r6 i686)
=================================================================
System uname: 2.6.11-gentoo-r6 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 28 2005, 00:17:47)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.4_p6, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="es_ES@euro"
LC_ALL="es_ES@euro"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X aalib alsa apm avi berkdb bitmap-fonts cdr crypt cups curl divx4linux dvd dvdr dvdread eds emboss encode esd fam flac foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2 howl imagemagick imlib ipv6 java jpeg ldap libg++ libwww mad mikmod mmx motif mozilla mp3 mpeg ncurses nls nntp nptl nvidia ogg oggvorbis opengl oss pam pdflib perl png ppds python quicktime readline samba scanner sdl spell ssl svga tcpd tiff truetype truetype-fonts type1-fonts usb vga vorbis xine xml xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS, LINGUAS
Comment 12 Andreas Proschofsky (RETIRED) gentoo-dev 2005-05-07 11:54:51 UTC
*** Bug 91074 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Proschofsky (RETIRED) gentoo-dev 2005-05-07 12:01:28 UTC
@Santiago: I can understand you frustration, the current situation is really unfortunate, my bugs are usually also ignored. To add to this, it's not even 100 percent clear, where to report bugs, as besides bugzilla.novell.com there is still bugzilla.ximian.com....

Thanks anyway for your work in this area, am going to try, again, to sort this out with the Novell people...
Comment 14 Erik Östlund 2005-05-07 13:45:50 UTC
My bug report, 91074, was marked as a duplicate of this one. This thread however seems to focus on the Ximian version of Open Office. I have the same problem in the regular and the Ximian version.
Comment 15 Erik Östlund 2005-05-07 13:50:16 UTC
Another thing just struck me. Isn't a dead-key something you press that acts as a modifier for the next key pressed? The characters that won't work for me are directly mapped to keys on my keyboard. There's no need to press anything before using them. Are you sure this is the same problem as bug 91074?
Comment 16 Pep 2005-05-10 02:04:24 UTC
I updated to 1.3.11 and the problem is still here.
Comment 17 Lars De Richter 2005-05-26 12:29:03 UTC
I am experiencing the same problem. I did not touch the Linguas setting or
anything. (Just simple emerge openoffice-ximian, ACCEPT_KEYWORDS="x86" and no
special optimisation.) I have this on my desktop with a Belgian keyboard and
with a French keyboard lay-out on my laptop.
Comment 18 Luis Carlos Cobo 2005-05-28 10:33:24 UTC
Same problem here with 1.3.11 (binary version). The OOO_FORCE_DESKTOP=none
workaround indeed works, apart from the ugly appearance :-)
Comment 19 Pep 2005-06-17 10:07:56 UTC
I updated to 1.3.14 and the problem is still here.
Comment 20 Alexandre Hannud Abdo 2005-06-20 19:18:41 UTC
I have this bug also, ooo-ximian-1.3.14 on a x86.

This bug does not depend on having "LINGUAS" set to anything special.

This bug is also a x86 bug, not just PPC.
Comment 21 Pep 2005-06-21 13:12:07 UTC
Alexandre, post in Novell Bugzilla to, please
Comment 22 Santiago Gala 2005-06-26 07:37:17 UTC
Still happens in 1.3.14, I just built it.

OOO_FORCE_DESKTOP=none works around it, which makes obvious that the problem is
in the gtk+ frontend

I'll take a round of comments in the different upstream bugs, but given the zero
responsivity we've got so far, I doubt it will be of any help.
Comment 23 Pep 2005-06-29 08:13:49 UTC
Created attachment 62234 [details]
Attachment from Novell Bugzilla

https://bugzilla.novell.com/show_bug.cgi?id=78372
Comment 24 Andreas Proschofsky (RETIRED) gentoo-dev 2005-06-29 13:50:40 UTC
I've tested the patch, works fine for me, so already added it to portage.
Special thanks for Santiago for not giving up with upstream. Thanks a lot.

Closing
Comment 25 Pep 2005-06-30 12:44:06 UTC
It works of for me too
Comment 26 pjv 2005-10-16 15:37:43 UTC
I have exactly the same problem. Nice that other people are having this as well.
I had posted this on several places already but to no avail (also upstream). I
don't seem to be very good at posting bug reports either, no one believes me as
well ;-) : http://qa.openoffice.org/issues/show_bug.cgi?id=44841 .