Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88467 - parport joystick db9 driver not working with gentoo-sources 2.6.x / functional with vanilla
Summary: parport joystick db9 driver not working with gentoo-sources 2.6.x / functiona...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-04-09 06:25 UTC by Janis Kruse
Modified: 2005-05-17 13:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

dmesg output booting vanilla kernel (vanilla2.6.11.7.dmesg.out,10.53 KB, text/plain)
2005-05-13 09:41 UTC, Janis Kruse
dmesg output booting gentoo sources kernel 2.6.11-gentoo-r5 (gentoo-sources2.6.11-gentoo-r5.dmesg.out,12.84 KB, text/plain)
2005-05-13 09:42 UTC, Janis Kruse
dmesg output 2.6.11-gentoo-r5 with patch WORKING (gentoo-sources2.6.11-gentoo-r5.dmesg.WORKING.out,12.90 KB, text/plain)
2005-05-13 10:31 UTC, Janis Kruse
dmesg output 2.6.11-gentoo-r9 WORKING (dmesg.out,12.36 KB, text/plain)
2005-05-17 13:01 UTC, Janis Kruse

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Kruse 2005-04-09 06:25:17 UTC
using gentoo-sources 2.6.x, the db9 driver does not recognize my parport and thus fails to create my joystick dev files. Works fine with vanilla sources.
I guess the problem is, since i have db9 compiled in (no modules), it is executed before the parport is initialized. This is from my dmesg:
input: PS/2 Generic Mouse on isa0060/serio1
db9.c: no such parport
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
parport0: irq 7 detected
io scheduler noop registered

As i said before the problem does not exist with vanilla 2.6.x but i want to use gentoo-sources. Do i have to use modules and get db9 out of the kernel so it is executed after parport init?

Reproducible: Always
Steps to Reproduce:
1. use gentoo-sources 2.6.x
2. boot with kernel line including,9

Actual Results:  
no joystick files /dev/input/js0 /dev/input/js1 created

Expected Results:  
create joystick files /dev/input/js0 /dev/input/js1

i am pretty sure it has something to do with the order the drivers are processed
in gentoo-sources, since it works fine under vanilla...
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2005-04-13 09:27:39 UTC
Which gentoo-sources and vanilla-sources versions are you trying?
Comment 2 Janis Kruse 2005-04-13 09:43:20 UTC
gentoo-sources version 2.6.11-gentoo-r5
vanilla-sources version

i have used 2.6-vanilla since 2.6.7 with db9 working
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2005-04-28 10:05:24 UTC
Please attach dmesg output from both working and non-working kernels.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2005-05-12 10:26:38 UTC
see comment #3
Comment 5 Janis Kruse 2005-05-13 09:41:05 UTC
Created attachment 58822 [details]
dmesg output booting vanilla kernel
Comment 6 Janis Kruse 2005-05-13 09:42:08 UTC
Created attachment 58823 [details]
dmesg output booting gentoo sources kernel 2.6.11-gentoo-r5
Comment 7 Janis Kruse 2005-05-13 09:44:29 UTC
sorry for reacting so late i was on holiday...
i posted the requested dmesg output files.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2005-05-13 10:03:10 UTC
Please try reverting this patch:

To do that:
# cd /usr/src/linux
# patch -p1 -R -i /path/to/speakup.patch

Then recompile kernel, reinstall, and reboot as normal. Does it work then?
Comment 9 Janis Kruse 2005-05-13 10:31:54 UTC
Created attachment 58826 [details]
dmesg output 2.6.11-gentoo-r5 with patch WORKING
Comment 10 Janis Kruse 2005-05-13 10:34:26 UTC
Works now, i attached the dmesg output.

Yeah !!! Thanks a lot, what did this patch do?
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2005-05-13 11:39:32 UTC
The patch provides an optional feature where it will synthesize the text of your console and read it out to you (requires special hardware) - this is for users with impaired sight abilities. It rearranges the driver loading sequence slightly, so that the speech synthesization can start as early on as possible. I'll contact the author about this issue and see how it can be solved.
Comment 12 Jeremy Huddleston (RETIRED) gentoo-dev 2005-05-13 18:05:59 UTC
In drivers/Makefile, can you try swapping these two lines (after the patch is applied):

obj-$(CONFIG_INPUT)            += input/
obj-$(CONFIG_PARPORT)          += parport/


obj-$(CONFIG_PARPORT)          += parport/
obj-$(CONFIG_INPUT)            += input/
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2005-05-17 03:56:01 UTC
Please try gentoo-sources-2.6.11-r9 - it includes the modification mentioned above.
Comment 14 Janis Kruse 2005-05-17 13:01:19 UTC
Created attachment 59148 [details]
dmesg output 2.6.11-gentoo-r9 WORKING
Comment 15 Janis Kruse 2005-05-17 13:05:44 UTC
I tried gentoo-sources 2.6.11-r9 and it seems to work fine. I posted the dmesg
output as well.

Thanks for fixing this Bug, I just played Wizard of Wor via Vice C64 emulator
with the original C64 Joysticks again and it ROCKS !!!

Great work!
Comment 16 Daniel Drake (RETIRED) gentoo-dev 2005-05-17 13:15:37 UTC
Great, thanks for letting us know. I'll send the fix to the speakup author.