Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 884145 - net-print/hplip-3.22.10 (and net-print/hplip-3.22.6) breaks compatibility with sane/xsane
Summary: net-print/hplip-3.22.10 (and net-print/hplip-3.22.6) breaks compatibility wit...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Daniel Pielmeier
Depends on:
Reported: 2022-12-03 11:15 UTC by Guido
Modified: 2023-05-02 00:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

result of hp-check (hp-check.log,48.79 KB, text/x-log)
2022-12-03 11:19 UTC, Guido
hp-scan result on display and system log (journal.txt,57.15 KB, text/plain)
2022-12-03 11:54 UTC, Guido
ebuild modified (hplip-3.22.2.ebuild,7.79 KB, text/plain)
2022-12-05 11:05 UTC, Guido
patch from gentoo repository (hplip-3.22.2-patches-1.tar.xz,17.15 KB, application/octet-stream)
2022-12-05 11:08 UTC, Guido

Note You need to log in before you can comment on or make changes to this bug.
Description Guido 2022-12-03 11:15:51 UTC
With these versions "scanimage -L" regularly detects the printer on the network but it is not possible to acquire anything. While with the previous version everything worked normally (unfortunately it is out of the repositories). I attach the documentation.

Reproducible: Always

Steps to Reproduce:
2. run SCAN option, after several minutes XSANE frontend appears
3. pressed "acquire" and you wait again several minutes
Actual Results:  
only an xsane pop-up comes on the display: "the scanner cannot be started. an error occurred during I/O on the device" (original message in Italian: non è possibile avviare lo scanner. si è verificato un errore durante l'i/o sul dispositivo)

Expected Results:  
the image of the scanned document

I believe it is relevant to attach when highlighted by journalctl and of course hp-check.log. these are the use flags used:

[ebuild   R    ] net-print/hplip-3.22.10::gentoo  USE="X hpcups kde libnotify (policykit) qt5 scanner snmp -doc -fax -hpijs -libusb0 -minimal -parport -static-ppds" PYTHON_SINGLE_TARGET="python3_10 -python3_8 -python3_9

[ebuild   R    ] media-gfx/sane-backends-1.1.1-r5::gentoo  USE="systemd threads zeroconf -gphoto2 -snmp -usb -v4l -xinetd" ABI_X86="(64) -32 (-x32)" SANE_BACKENDS="-abaton -agfafocus -apple -artec -artec_eplus48u -as6e -avision -bh -canon -canon630u -canon_dr -canon_lide70 -canon_pp -cardscan -coolscan -coolscan2 -coolscan3 -dc25 -dc210 -dc240 -dell1600n_net -dmc -epjitsu -epson -epson2 -epsonds -escl -fujitsu -genesys -gt68xx -hp -hp3500 -hp3900 -hp4200 -hp5400 -hp5590 -hpljm1005 -hpsj5s -hs2p -ibm -kodak -kodakaio -kvs20xx -kvs40xx -kvs1025 -leo -lexmark -ma1509 -magicolor -matsushita -microtek -microtek2 -mustek -mustek_pp -mustek_usb -mustek_usb2 -nec -net -niash -p5 -pie -pieusb -pixma -plustek -plustek_pp -pnm -qcam -ricoh -ricoh2 -rts8891 -s9036 -sceptre -sharp -sm3600 -sm3840 -snapscan -sp15c -st400 -stv680 -tamarack -teco1 -teco2 -teco3 -test -u12 -umax -umax1220u -umax_pp -xerox_mfp"

[ebuild   R    ] media-gfx/xsane-0.999-r4::gentoo  USE="gimp jpeg lcms nls png tiff -ocr"
Comment 1 Guido 2022-12-03 11:19:18 UTC
Created attachment 839223 [details]
result of hp-check
Comment 2 Guido 2022-12-03 11:54:02 UTC
Created attachment 839225 [details]
hp-scan result on display and system log

guido@desktop ~ $ hp-scan --logging=debug

HP Linux Imaging and Printing System (ver. 3.22.10)
Scan Utility ver. 2.2

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: No destinations specified. Adding 'file' destination by default.
Using device hpaio:/net/HP_LaserJet_MFP_M28-M31?ip=
Opening connection to device...

Resolution: 300dpi
Mode: gray
Compression: JPEG
Scan area (mm):
  Top left (x,y): (0.000000mm, 0.000000mm)
  Bottom right (x,y): (215.900009mm, 297.010681mm)
  Width: 215.900009mm
  Height: 297.010681mm
Destination(s): file
Output file: 
warning: File destination enabled with no output file specified.
Setting output format to PNG for greyscale mode.
warning: Defaulting to '/home/guido/hpscan001.png'.

Warming up...

error: SANE: Error during device I/O (code=9)
Closing device.
guido@desktop ~ $
Comment 3 Daniel Pielmeier gentoo-dev 2022-12-04 15:44:14 UTC
Sorry, can not reproduce this with my Photosmart 6510 connected using USB.

Looks like this scanner is connected over the network?
Did you try to connect it over USB and check if the issue persists.

What about a firewall preventing the connection to the device?
Comment 4 Guido 2022-12-04 17:41:52 UTC
(In reply to Daniel Pielmeier from comment #3)
> Sorry, can not reproduce this with my Photosmart 6510 connected using USB.
> Looks like this scanner is connected over the network?
> Did you try to connect it over USB and check if the issue persists.
> What about a firewall preventing the connection to the device?

considers that:
- the (multifunction) printer is regularly connected to the network and the CUPS printing system works very well.
- there is no firewall inside the "home network".
- I checked the correct operation of the scanner by windows on virtualbox
About the connection via USB, it is a bit more complicated because SANE is compiled without USB support.....
Comment 5 Daniel Pielmeier gentoo-dev 2022-12-04 17:53:09 UTC
Also works here if configure my printer as a network printer.
There were issues regarding the always on configuration (iptables rule) i use for vpn. Disabling it let me print.

I don't think I can do much here. If you want this solved try recompiling sane with usb support and test as requested. Also open a bug upstream at the hplip tracker and provide this information there.
Comment 6 Guido 2022-12-05 11:04:41 UTC
I deem it appropriate to inform you that I have recovered the files necessary to install the 3.22.2 version (with a small modification to the ebuild to use the gentoo patch ver. 3.22.2).
I replaced it with the current version without changing anything else and now everything works. If it can be useful, I attach the packages used.
Comment 7 Guido 2022-12-05 11:05:41 UTC
Created attachment 840207 [details]
ebuild modified
Comment 8 Guido 2022-12-05 11:08:28 UTC
Created attachment 840213 [details]
patch from gentoo repository
Comment 9 Guido 2022-12-05 11:11:13 UTC
hplip-3.22.2.tar.gz and
I downloaded these from the HP repository
Comment 10 Daniel Pielmeier gentoo-dev 2022-12-05 12:06:37 UTC
This is not the ebuild from the Gentoo repository. LiGurOS is not Gentoo. I am not comparing this one. Please test the official ebuild. You can get it here:

Also what about hplip-3.22.4. did this version work? You mention 3.22.6 and 3.22.10 not working. It makes sense to determine the last version working and then check for differences in the source, the ebuild and the patches.
3.22.4 you can get here:

According to this page ( your printer is not requiring the binary plug-ins (

I compared the source code of 3.22.4, 3.22.4 and 3.22.6. Nothing suspicious there. The ppd files for the printer changed. Did you remove the printer using hp-setup or the cups web interface and set it up new with the new version?

Sorry, but I have to let you know that I can not spend to much time on this. Hplip supports a multitude of printers. I alone can not assure all of them work. If we can not solve this quickly I kindly ask you to report your problem at:
Comment 11 Guido 2022-12-05 18:03:31 UTC
I'm sorry for opening the "bug". I didn't consider HP discontinuing support of my printer (which works great and I don't intend to replace).

Version 3.22.4 works (as I remembered). I specify, however, that the scanner only works if I install the relative plugin.

Thanks a lot for your support and for the 3.22.4 ebuild which I will keep in the local repositories.

Best regards.
Comment 12 Daniel Pielmeier gentoo-dev 2022-12-05 20:02:08 UTC
No need to be sorry. I am sorry I can't help you.

The printer is still supported! You can see this on the page I linked. If you open a bug at the hplip tracker there is a small chance it will get fixed.

It is interesting that the plugin is required for scanning as the page suggests otherwise.

Can you try uninstalling and reinstall the hplip and hplip-plugin. I hope you used the ebuild. Also remove the printer configuration and set it up again.

I again compared 3.22.4 and 3.22.6 and found nothing suspicious.
Comment 13 Alexis 2023-05-02 00:26:18 UTC
My 4100C scanner recently stopped working, having worked fine on 2 April, and after trying to work out why, i'm still not sure whether it's a software or hardware issue. (The latter certainly seems plausible, given how old the unit is.) Adding this comment to this bug in case they're connected somehow.

Context: sys-kernel/gentoo-kernel 6.2.13, dev-libs/libusb 1.0.26, dev-libs/libusb-compat 0.1.8, media-gfx/sane-backends 1.2.1, net-print/hplip 3.23.3-plugin, net-print/hplip 3.23.3

    # scanimage -L
    device `hp:libusb:001:015' is a Hewlett-Packard ScanJet 4100C flatbed scanner

    # hp-setup
    Searching... (bus=usb, search=(None), desc=0)
    error: No devices found on bus: usb

    # simple-scan
    Failed to scan
    Error communicating with scanner

When running simple-scan, the scanner _starts_ to scan, but quickly fails. It stays in this borked state until USB-disconnected and reconnected.

This also happens when trying to scan from GIMP, although sometimes it simply doesn't work at all.

Some related output from `genlop -l`:

     Sun Apr 16 22:54:29 2023 >>> net-print/hplip-plugin-3.22.10
     Sun Apr 16 23:38:25 2023 >>> net-print/hplip-3.23.3
     Sun Apr 16 23:38:44 2023 >>> net-print/hplip-plugin-3.23.3
     Sun Apr 16 23:41:54 2023 >>> media-gfx/sane-frontends-1.0.14-r6
     Sun Apr 16 23:53:45 2023 >>> dev-libs/libusb-compat-0.1.8
     Sun Apr 16 23:53:58 2023 >>> virtual/libusb-0-r2
     Sun Apr 16 23:55:48 2023 >>> net-print/hplip-3.23.3

i've not yet tried downgrading various things; if i can get to it, i'll report the results here.