Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 884 - emerge sodipodi fails (ld: cannot find -lgdk_pixbuf_xlib)
Summary: emerge sodipodi fails (ld: cannot find -lgdk_pixbuf_xlib)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-02-27 21:36 UTC by Chris Piro
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Chris Piro 2002-02-27 21:36:22 UTC
sodipodi fails to merge because while "test-widgets" ld can't link
gdk_pixbuf_xlib.  A lot of code earlier in the ebuild compiles without failing.
 I'm pretty confused ... I don't know what gdk_pixbuf_xlib is, or what provides
it,  but the deps in sodipodi's ebuild don't.  I tried taking -lgdk_pixbuf_xlib
out of the Makefile, but something breaks.  Hopefully this is enough to go on,
e-mail me if you need more info / can't reproduce it.

$ emerge sodipodi --buildpkg
make[3]: Entering directory
rm -f libspwidgets.a
ar cru libspwidgets.a sp-toolbox.o sp-color-slider.o sp-color-selector.o
gradient-image.o gradient-position.o 
ranlib libspwidgets.a
gcc  -mcpu=i686 -march=i686 -O3 -pipe -I/usr/include/gdk-pixbuf-1.0
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/X11R6/include -Wall -Wunused   -o test-widgets  test-widgets.o
sp-color-slider.o sp-color-selector.o -rdynamic -L/usr/lib -L/usr/X11R6/lib
-lgal -lgnomecanvaspixbuf -lgdk_pixbuf_xlib -lglade-gnome -lglade -lgnomeprint
-lgnomeui -lgdk_imlib -lSM -lICE -lgnome -lgnomesupport -lesd -lasound
-laudiofile -ldb1 -lgdk_pixbuf -lgtk -lgdk -lgmodule -lglib -ldl -lXi -lXext
-lX11 -lart_lgpl -lm -lfreetype -lxml -lz -lpng -lz 
/usr/i686-pc-linux-gnu/bin/ld: cannot find -lgdk_pixbuf_xlib
collect2: ld returned 1 exit status
make[3]: *** [test-widgets] Error 1
make[3]: Leaving directory

Comment 1 Grant Goodyear (RETIRED) gentoo-dev 2002-03-01 12:35:38 UTC
emerge gdk-pixbuf (although it should be already installed)
and see if that works.  There was a problem where gdk-pixbuf had to
be emerged twice to get it to work properly.
Comment 2 Chris Piro 2002-03-01 20:33:51 UTC
Thank you.  That worked.  I thought gdk-pixbuf-0.16.0-r4 was supposed to clear
up that bug, but apparently not (I had -r4 installed).  Should we look into this?
Comment 3 LordVan(Thomas Raschbacher) 2002-03-07 16:28:25 UTC
i had the same problem...
i just changed /usr/lib/ removed the '_xlib' in the
linker-line... maybe a bug in gdk_pixbuf[-scripts]?)
Comment 4 Grant Goodyear (RETIRED) gentoo-dev 2002-03-13 14:15:31 UTC
Handing off to Azarah because I know he's handled this problem.
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2002-03-24 07:56:20 UTC
If you could try with gdk-pixbuf-0.16.0-r5, it would be appreciated.
Just make sure you have the latest unmasked sys-devel/libtool installed
(should be 1.4.1-r3)
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2002-05-26 14:43:20 UTC
Is this solved ?  Any new comments ?
Comment 7 Chris Piro 2002-05-26 18:12:09 UTC
I've built a bunch of systems with sodipodi without a problem ... I guess that
means it's solved :)