Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 883117 - sci-geosciences/viking-1.10 - terraservermapsource.c: error: incompatible function pointer types
Summary: sci-geosciences/viking-1.10 - terraservermapsource.c: error: incompatible fun...
Status: RESOLVED DUPLICATE of bug 930262
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: c99-porting
  Show dependency tree
 
Reported: 2022-11-26 10:19 UTC by Toralf Förster
Modified: 2024-06-26 11:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.17 KB, text/plain)
2022-11-26 10:19 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,79.70 KB, text/plain)
2022-11-26 10:19 UTC, Toralf Förster
Details
environment (environment,85.05 KB, text/plain)
2022-11-26 10:19 UTC, Toralf Förster
Details
etc.clang.tar.bz2 (etc.clang.tar.bz2,697 bytes, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,23.84 KB, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,13.46 KB, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details
sci-geosciences:viking-1.10:20221126-042636.log.bz2 (sci-geosciences:viking-1.10:20221126-042636.log.bz2,31.69 KB, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,70.66 KB, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details
var.tmp.clang.tar.bz2 (var.tmp.clang.tar.bz2,1.48 KB, application/x-bzip)
2022-11-26 10:19 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-11-26 10:19:09 UTC
too long lines were shrinked:

clang -DHAVE_CONFIG_H -I.  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -pthread  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/us
clang -DHAVE_CONFIG_H -I.  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -pthread  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/us
clang -DHAVE_CONFIG_H -I.  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -pthread  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/us
clang -DHAVE_CONFIG_H -I.  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/json-glib-1.0 -pthread  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/us
terraservermapsource.c:137:37: error: incompatible function pointer types
      assigning to 'DownloadFileOptions *(*)(VikMapSourceDefault *, MapCoord *)'
      (aka

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j4-20221125-150027

  -------------------------------------------------------------------

GNUMAKEFLAGS="$GNUMAKEFLAGS --jobserver-style=pipe"
CC=clang
CXX=clang++
gcc-config -l:
 [1] x86_64-pc-linux-gnu-12 *
clang/llvm (if any):
clang version 15.0.5
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
Configuration file: /etc/clang/clang.cfg
/usr/lib/llvm/15
15.0.5
Python 3.10.8
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.65.0 *
The following VMs are available for generation-2:
1)	IcedTea JDK 3.16.0 [icedtea-bin-8]
2)	OpenJDK 17.0.5_p8 [openjdk-17]
*)	Eclipse Temurin JDK 17.0.5_p8 [openjdk-bin-17]
4)	Eclipse Temurin JDK 8.352_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8 
  [2]   openjdk-17 
  [3]   openjdk-bin-8 
  [4]   openjdk-bin-17  system-vm

php cli (if any):

  HEAD of ::gentoo
commit d31c9984f0ede2e6f833536b764c0f418f8daf60
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sat Nov 26 03:33:52 2022 +0000

    2022-11-26 03:33:51 UTC

emerge -qpvO sci-geosciences/viking
[ebuild  N    ] sci-geosciences/viking-1.10  USE="exif magic nls -doc -geoclue -gps -libexif -oauth"
Comment 1 Toralf Förster gentoo-dev 2022-11-26 10:19:10 UTC
Created attachment 836905 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-11-26 10:19:12 UTC
Created attachment 836907 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2022-11-26 10:19:13 UTC
Created attachment 836909 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-11-26 10:19:14 UTC
Created attachment 836911 [details]
etc.clang.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-11-26 10:19:15 UTC
Created attachment 836913 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-11-26 10:19:16 UTC
Created attachment 836915 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2022-11-26 10:19:17 UTC
Created attachment 836917 [details]
sci-geosciences:viking-1.10:20221126-042636.log.bz2
Comment 8 Toralf Förster gentoo-dev 2022-11-26 10:19:18 UTC
Created attachment 836919 [details]
temp.tar.bz2
Comment 9 Toralf Förster gentoo-dev 2022-11-26 10:19:19 UTC
Created attachment 836921 [details]
var.tmp.clang.tar.bz2
Comment 10 Hans de Graaff gentoo-dev Security 2024-06-26 11:53:31 UTC

*** This bug has been marked as a duplicate of bug 930262 ***