Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 881039 - net-misc/netifrc-0.7.3: dhcpcd not passing args in stop function
Summary: net-misc/netifrc-0.7.3: dhcpcd not passing args in stop function
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: netifrc (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: netifrc Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-11-12 00:50 UTC by kevinmbecause
Modified: 2022-12-25 19:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to add args to dhcpcd upon stop (netifrc_stop_fix.patch,548 bytes, patch)
2022-11-12 00:52 UTC, kevinmbecause
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kevinmbecause 2022-11-12 00:50:51 UTC
The dhcpcd module goes through all the trouble of saving the arguments to a file in dhcpcd_start() and retrieving them in dhcpcd_stop(), but it never actually passes the arguments to dhcpcd. This can cause the stop function to miss the running dhcpcd instance and never stop it if certain arguments are specified by the user.

Reproducible: Always

Steps to Reproduce:
1. Set dhcpcd_wan0="-4" in /etc/conf.d/net
2. Start net.wan0
3. Stop net.wan0
Actual Results:  
"dhcpcd not running" in the output and dhcpcd process is still running after stopping the interface

Expected Results:  
"sending signal TERM to pid 3376" and "waiting for pid 3376 to exit" in the output and the dhcpcd process is no longer running after the interface is stopped
Comment 1 kevinmbecause 2022-11-12 00:52:17 UTC
Created attachment 831683 [details, diff]
Patch to add args to dhcpcd upon stop
Comment 2 Larry the Git Cow gentoo-dev 2022-12-25 19:07:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/proj/netifrc.git/commit/?id=bd8ff4aa89e1d56e9886dad32bb2406c8f43c747

commit bd8ff4aa89e1d56e9886dad32bb2406c8f43c747
Author:     kmartin36 <Kevin.Martin@gtri.gatech.edu>
AuthorDate: 2022-12-17 08:26:21 +0000
Commit:     Robin H. Johnson <robbat2@gentoo.org>
CommitDate: 2022-12-25 19:06:36 +0000

    Adding the saved args to the stop command
    
    Closes: https://bugs.gentoo.org/881039
    Signed-off-by: Kevin Martin <kevinmbecause@gmail.com>
    (cherry picked from commit 0e1c19959a6d82accdb57fa7a1f5b0036037a001)
    Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
    Closes: https://github.com/gentoo/netifrc/pull/41

 net/dhcpcd.sh | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)