Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88097 - bootstrap stops at linux-headers-
Summary: bootstrap stops at linux-headers-
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Lowest normal (vote)
Assignee: Jeremy Huddleston (RETIRED)
Depends on:
Reported: 2005-04-05 15:43 UTC by BlinkEye
Modified: 2005-04-19 10:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description BlinkEye 2005-04-05 15:43:45 UTC
for christ sake's, what's wrong lately? first, the amd64 gentoo 2005.0 minimal boot cd has some buggy raiddrivers which forced me to use a 2004.0 and now not even bootstraping finishes. i tried a lot, for example i moved the linux-headers- to linux-headers- but it's not working neither: IT SETS THE WRONG CPU in the .config, simple as that. 

* Cryptographic options
Cryptographic API (CRYPTO) [N/y/?] n
* Library routines
CRC-CCITT functions (CRC_CCITT) [N/m/y/?] (NEW) n
CRC32 functions (CRC32) [Y/?] y
CRC32c (Castagnoli, et al) Cyclic Redundancy-Check (LIBCRC32C) [M/n/y/?] m
  SPLIT   include/linux/autoconf.h -> include/config/*
  CC      scripts/mod/empty.o
scripts/mod/empty.c:1: error: CPU you selected does not support x86-64 instruction set
scripts/mod/empty.c:1: error: CPU you selected does not support x86-64 instruction set
make[2]: *** [scripts/mod/empty.o] Error 1
make[1]: *** [scripts/mod] Error 2
make: *** [scripts] Error 2

!!! ERROR: sys-kernel/linux-headers- failed.
!!! Function compile_headers, Line 243, Exitcode 2
!!! prepare failed
!!! If you need support, post the topmost build error, NOT this status message.

the corresponding /tmp/portage/linux-headers-
* Processor type and features
Subarchitecture Type
> 1. PC-compatible (X86_PC)
  2. AMD Elan (X86_ELAN)
  3. Voyager (NCR) (X86_VOYAGER)
  4. NUMAQ (IBM/Sequent) (X86_NUMAQ)
  5. Summit/EXA (IBM x440) (X86_SUMMIT)
  6. Support for other sub-arch SMP systems with more than 8 CPUs (X86_BIGSMP)
  7. SGI 320/540 (Visual Workstation) (X86_VISWS)
  8. Generic architecture (Summit, bigsmp, ES7000, default) (X86_GENERICARCH)
  9. Support for Unisys ES7000 IA32 series (X86_ES7000)
choice[1-9]: 1
Processor family
  1. 386 (M386)
  2. 486 (M486)
  3. 586/K5/5x86/6x86/6x86MX (M586)
  4. Pentium-Classic (M586TSC)
  5. Pentium-MMX (M586MMX)
  6. Pentium-Pro (M686)
  7. Pentium-II/Celeron(pre-Coppermine) (MPENTIUMII)
  8. Pentium-III/Celeron(Coppermine)/Pentium-III Xeon (MPENTIUMIII)
  9. Pentium M (MPENTIUMM)
> 10. Pentium-4/Celeron(P4-based)/Pentium-4 M/Xeon (MPENTIUM4)
  11. K6/K6-II/K6-III (MK6)
  12. Athlon/Duron/K7 (MK7)
  13. Opteron/Athlon64/Hammer/K8 (MK8)
  14. Crusoe (MCRUSOE)
  15. Winchip-C6 (MWINCHIPC6)
  16. Winchip-2 (MWINCHIP2)
  17. Winchip-2A/Winchip-3 (MWINCHIP3D)
  19. VIA C3-2 (Nehemiah) (MVIAC3_2)[/code]
what a surprise it isn't working, isn't it? i tried to manually copy a working .config to that location while it is patching and building but it stops due to a changing .config.

my emerge --info:
emerge --info
Portage (default-linux/amd64/2005.0, gcc-3.4.3, glibc-, 2.6.3-gentoo-r2-up x86_64)
System uname: 2.6.3-gentoo-r2-up x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar  4 2005, 16:47:04)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  [Not Present]
sys-devel/automake:  [Not Present]
sys-devel/libtool:   [Not Present]
CFLAGS="-march=x86-64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=x86-64 -O2 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
USE="X acpi alsa berkdb bitmap-fonts cdr crypt dvd font-server fortran gcj gif gpm imap java jp2 jpeg kde locales lzw lzw-tiff maildir mp3 ncurses nls opengl oss pam perl png python qt readline sasl ssl symlink tcpd tiff truetype truetype-fonts type1-fonts usb userlocales xine xml2 xpm xrandr xv zlib"
Comment 1 BlinkEye 2005-04-05 15:47:29 UTC
don't get me wrong - i'm just on the edge because i tried a lot and a long time but couldn't solve the problem.
Comment 2 SpanKY gentoo-dev 2005-04-05 17:26:01 UTC
multilib bug
Comment 3 BlinkEye 2005-04-05 22:34:39 UTC
meaning what?
Comment 4 Jeremy Huddleston (RETIRED) gentoo-dev 2005-04-06 03:40:32 UTC
What stage tarball are you using?  What portage snapshot are you using, or are you using the latest sync?
Comment 5 Jeremy Huddleston (RETIRED) gentoo-dev 2005-04-19 10:48:36 UTC
No response.  Please reopen if you have further information.
Comment 6 BlinkEye 2005-04-19 10:54:30 UTC
i'm sorry i forgot to post back. i used a stage1-amd64-2005.0 tarball and the latest sync.

the problem was i used CHOST="i686-pc-linux-gnu" instead of CHOST="x86_64-pc-linux-gnu" in /etc/make.conf.

so, problem solved