Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87888 - --getbinpkgonly asks for out-of-tree package
Summary: --getbinpkgonly asks for out-of-tree package
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 118652 (view as bug list)
Depends on:
Blocks: 155723
  Show dependency tree
 
Reported: 2005-04-04 03:42 UTC by Aniruddha Shankar
Modified: 2010-08-16 07:23 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
root awaaz # emerge -uvDdG world output (emergedebug.bz2,32.58 KB, application/octet-stream)
2005-04-04 03:58 UTC, Aniruddha Shankar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aniruddha Shankar 2005-04-04 03:42:17 UTC
I admin Gentoo machines and build packages on one and install the binaries on the other machines. I use --getbinpkgonly for this  with the command : emerge --update --verbose --deep --getbinpkgonly world . The build machine, "bhim", also hosts the  local portage tree. 

On a machine called awaaz, I run emerge -uvDG world but I get this error: 
awaaz root # emerge -uvDG world
Fetching binary packages info...
 * No password provided for username 'anonymous'

Loaded metadata pickle.
cache miss: 'x' --- cache hit: 'o'
ooooooooooooo(truncated)
  -- DONE!

Calculating world dependencies ...done!
>>> emerge (1 of 47) net-www/mozilla-launcher-1.23 to /
Fetching 'net-www/mozilla-launcher-1.23'

Error: A file called mozilla-launcher-1.23.tbz2 was not found on the server
Fetcher exited with a failure condition.
!!! CATEGORY info missing from info chunk, aborting...

On bhim, ls -lh /usr/portage/packages/All/mozilla-launcher* gives the following:
-rw-r--r--  1 root root 25K Apr  4 13:44 /usr/portage/packages/All/mozilla-launcher-1.30.tbz2

which is not surprising, since mozilla-launcher-1.23 is out of the portage tree :

awaaz root # etcat -v mozilla-launcher
[ Results for search key           : mozilla-launcher ]
[ Candidate applications found : 2 ]

 Only printing found installed programs.

*  www-client/mozilla-launcher :
        [  I] 1.30 (0)
        [M~ ] 1.32 (0)


The output of awaaz root # emerge -uvDG --debug is tarbz2ed and appended. I think the problem lies in stale metadata being present in two mammoth files in /var/cache/edb/metadata.idx.most_recent (93MB) and /var/cache/edb/remote_metadata.pickle (93MB). Permissions on both are 
-rw-r--r--  1 root root. 




On another machine with an identical configuration, deleting the two 90MB files caused the problem to be resolved. as the files are 30mb in size, I can't upload them to bugzilla (or can I ? ) ;)  

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




emerge info for awaaz is appeneded: 

awaaz edb # emerge info
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20041102-r1,
2.6.11-ck2 i686)
=================================================================
System uname: 2.6.11-ck2 i686 Intel(R) Pentium(R) 4 CPU 1.80GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 15 2005, 16:33:52)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium3 -O2 -pipe -mmmx -msse -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -pipe -mmmx -msse -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig buildpkg ccache distcc distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://bhim/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://bhim/gentoo-portage"
USE="x86 X aalib acpi acpi4linux alsa apache2 apm arts artswrappersuid audiofile
avi berkdb bitmap-fonts bzlib cdparanoia cdr cpdflib crypt cups curl dba dga
dhcp dnd dv dvb dvd dvdr dvdread edl encode esd exif faac faad fam fftw fla flac
fltk font-server foomaticdb fortran ftp gd gdbm gif gimp gimpprint gkrellm gnome
gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal i8x0 imagemagick imap imlib imlib2
jack jack-tmpfs java javascript jbig jpeg kde kdeenablefinal lcms ldap libcaca
libclamav libg++ libwww lzo mad mailbox maildir mbox mime ming mmx mmx2 mng
motif mozilla mozsvg mp3 mpeg mpi mysql nas ncurses nethack network nls nptl
oggvorbis openal opengl oss pam pcre pdf pdflib perl pic png posix ppds python
qt quicktime readline real recode rtc samba scanner sdl session silc slang slp
sockets speex spell sqlite sse sse2 ssl svga tcltk tcpd tga theora tiff truetype
truetype-fonts type1-fonts underscores unicode usb v4l v4l2 vim-with-x wmf xml
xml2 xmms xpm xprint xscreensaver xv xvid zlib video_cards_i810 linguas_hi"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS
Comment 1 Aniruddha Shankar 2005-04-04 03:58:11 UTC
Created attachment 55265 [details]
root awaaz # emerge -uvDdG world output

here's the output of emerge --update --verbose --debug --deep --getbinpkgonly
Comment 2 Aniruddha Shankar 2005-05-12 00:51:08 UTC
13:10 <Kream> the way that I've been solving problems is this: if --getbinpkgonly screws up, make sure all /usr/local/portage, USE flags, /etc/portage/package.keywords are IDENTICAL... then i try to delete the remote metadata files (two of em)... then I try --getbinpkg ... then I resort to manually copying the binaries into /usr/portage/packages/All .... then a --usepkgonly usually works. By then I've been swearing for a long time.. :)

This problem was fixed by method 3... spoken to ferringb on #gentoo-portage at Thu May 12 07:47:37 UTC 2005 ... the logs should shed more light on the matter... basically we came to the conclusion that the binpkg flakiness is due to some underlying issues with the binpkg code.. I will be starting a blog to document my experiments with binpkg
cheers :)
Comment 3 Jason Stubbs (RETIRED) gentoo-dev 2005-05-12 08:03:16 UTC
Reopening... If we closed every bug that is planned on being fixed in the next major version, we'd have no open bugs. ;)
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-06 02:30:41 UTC
*** Bug 118652 has been marked as a duplicate of this bug. ***
Comment 5 Gilles Dartiguelongue gentoo-dev 2007-12-26 16:50:21 UTC
I've been using getbinpkgonly on at least 2 different set of boxes in the last 2 years and my observations are that if portage trees (and use flags) are in sync, no problem of this sort occurs. 

Given the first comment here, it's not clear to me if the build box and the binary box are in sync wrt to portage tree state.
Comment 6 Zac Medico gentoo-dev 2010-08-16 00:15:44 UTC
This should be fixed since the binhost protocal is completely different since portage-2.1.6. However, you must point PORTAGE_BINHOST directly at $PKGIDIR, and not the All/ subdirectory. It's documented in `man make.conf`.
Comment 7 Aniruddha Shankar 2010-08-16 07:23:28 UTC
5 years.... jeez.