Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87495 - Can't have vlan shutdown while the main if is still on.
Summary: Can't have vlan shutdown while the main if is still on.
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://bugzilla.kernel.org/show_bug.c...
Whiteboard:
Keywords:
: 88290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-31 20:18 UTC by Chan Min Wai
Modified: 2006-03-21 04:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Kernel config Files (2.6.10-gentoo-r7) (config,49.06 KB, text/plain)
2005-04-03 18:55 UTC, Chan Min Wai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chan Min Wai 2005-03-31 20:18:43 UTC
I've manage to get vlan working with the following configure.
ifconfig_eth4=( "0.0.0.0" )
iface_eth4_vlans="1000 1001 1002"
ifconfig_eth4_1000=( "203.73.10.1 broadcast 203.73.10.31 netmast 255.255.224" )
ifconfig_eth4_1001=( "204.115.210.249 broadcast 204.115.210.255 netmask 255.255.255.248" )
ifconfig_eth4_1002=( "204.115.210.17 broadcast 204.115.210.23 netmask 255.255.255.248" )
However I'm having a problem in shuting down them.

Accodring to the /etc/init.d/net.eth4.conf
ifconfig eth4.1000 down
vconfig rem eth4.1000

ifconfig eth4.1001 down
vconfig rem eth4.1001

ifconfig eth4.1002 down
vconfig rem eth4.1002


The error message after using the command /etc/init.d/net.eth4 stop are
unregister_netdevice: waiting for eth4.1000 to become free. Usage count = 6
in a numbers of times.

This kind of configuration will not work nice with me and I've to manually use this command 

ifconfig eth4 down
vconfig rem eth4.1001

Then it will work Nice

Program Version
net-misc/vconfig-1.8 *
sys-apps/baselayout-1.9.4-r6 *

NIC
Intel
Comment 1 Chan Min Wai 2005-03-31 20:18:43 UTC
I've manage to get vlan working with the following configure.
ifconfig_eth4=( "0.0.0.0" )
iface_eth4_vlans="1000 1001 1002"
ifconfig_eth4_1000=( "203.73.10.1 broadcast 203.73.10.31 netmast 255.255.224" )
ifconfig_eth4_1001=( "204.115.210.249 broadcast 204.115.210.255 netmask 255.255.255.248" )
ifconfig_eth4_1002=( "204.115.210.17 broadcast 204.115.210.23 netmask 255.255.255.248" )
However I'm having a problem in shuting down them.

Accodring to the /etc/init.d/net.eth4.conf
ifconfig eth4.1000 down
vconfig rem eth4.1000

ifconfig eth4.1001 down
vconfig rem eth4.1001

ifconfig eth4.1002 down
vconfig rem eth4.1002


The error message after using the command /etc/init.d/net.eth4 stop are
unregister_netdevice: waiting for eth4.1000 to become free. Usage count = 6
in a numbers of times.

This kind of configuration will not work nice with me and I've to manually use this command 

ifconfig eth4 down
vconfig rem eth4.1001

Then it will work Nice

Program Version
net-misc/vconfig-1.8 *
sys-apps/baselayout-1.9.4-r6 *

NIC
Intel® PRO/1000 Dual Port Adapters


Reproducible: Always
Steps to Reproduce:
1. get a vlan supported NIC, emerge vconfig
2. create a vlan like above in the /etc/conf.d/net
3. Start it with /etc/init.d/net.ethx start
4. Stop it with /etc/init.d/net.ethx stop
5. Wait for the error
P.S You have to be on the terminal to see the error message, it will not prompt throught the net terminal screen.

Actual Results:  
unregister_netdevice: waiting for eth4.1000 to become free. Usage count = 6

Alot of times...

Expected Results:  
Personally I think the net script should turn off eth4
ifconfig eth4 down
then only run 
vconfig rem eth4.1001
And other

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20041102-r1,
2.6.11-gentoo-r4 i686)
=================================================================
System uname: 2.6.11-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 11 2005, 17:34:27)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe -falign-functions=64
-mmmx -msse -msse2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe -falign-functions=64
-mmmx -msse -msse2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig buildpkg candy ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.gentoo.gr.jp/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
USE="x86 acl acpi alsa apm avi bash-completion berkdb bitmap-fonts bzlib caps
ccache crypt dio doc emboss encode foomaticdb gdbm gif gpm imlib jpeg ldap
libg++ libwww lm_sensors mad mikmod motif mp3 mpeg mysql mysqli ncurses nls nptl
oggvorbis opengl oss pam pdflib perl png posix python quicktime readline sdl
snmp sockets socks5 spell ssl svga tcpd threads truetype truetype-fonts
type1-fonts xml2 xmms xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS
Comment 2 Roy Marples (RETIRED) gentoo-dev 2005-04-01 01:22:04 UTC
Could you please test baselayout-1.11.10-r5 and see if the problem remains?
Comment 3 Chan Min Wai 2005-04-01 21:18:58 UTC
I'm now on
baselayout-1.11.10-r6
net-tools-1.60-r11

I found that I still can't use the following command (As what is being use on net.ethx script)
ipconfig eth4.1001 down 
vconfig rem eth4.1001

I've to shutdown the interface "ifconfig eth4 down" totally, then only I can remove the vlan savely...

The same error is there.

I'm kind of suspect that it is a problem of the net-tools, Or the driver.
Because I can do what ever way in Fedora Core 2.

In Summary:
-----------

Fedora Core 2
-------------
Fedora is using 
vconfig 1.8.2
net-tools 1.6.2
vconfig rem eth4.1001 [Work and remove eth4.1001]
ifconfig eth4.1001 && vconfig rem eth4.1001 [WORK]

My Gentoo
--------------
vconfig rem eth4.1001 [Don't Work]
ifconfig eth4.1001 && vconfig rem eth4.1001 [Don't WORK]
ifconfig eth4 && vconfig rem eth4.1001 [work]


Suggestion feedback.
Comment 4 SpanKY gentoo-dev 2005-04-01 21:33:07 UTC
are your fc2 and gentoo boxes running same kernel ?

we could update the vconfig package in gentoo to 1.8.2 ...
Comment 5 Chan Min Wai 2005-04-02 11:49:53 UTC
Sorry it was an FC3... (Forgot about that it was the only fc3 box I've)
Kernel version 2.6.10-1.766_FC3
Information of the software are

vconfig-1.8-4
net-tools-1.60-37.FC3.1


After checking the net for a while for the error message. 
I'm suspecting that it WAS a kernel problem, as state in 
http://www.ussg.iu.edu/hypermail/linux/kernel/0501.3/2226.html

Anyway I'm trying it with the old kernel 2.6.10-r8 and see what will be the result.
Comment 6 Chan Min Wai 2005-04-03 18:55:28 UTC
Created attachment 55240 [details]
Kernel config Files (2.6.10-gentoo-r7)

I'm trying with 2.6.10-gentoo-r7 but still no luck with it.
Maybe it have something to do with my kenrel config.
With attach is my kernel config files.
Comment 7 Chan Min Wai 2005-04-03 21:02:36 UTC
OK lastest information.
Problem happen even in FC2 (on this machine)
But not on eth0 

(I've 6 eth in this system for fun)

When ever an ifconfig ethx.xxx abc.abc.abc.abc
then I'll have the the same problem 

Moving bug to CoreCode.
I'm with Motheboard 
Intel SE7210TP1-E
Comment 8 Chan Min Wai 2005-04-04 04:17:45 UTC
Created a Bug in kernel.org
http://bugzilla.kernel.org/show_bug.cgi?id=4441
Comment 9 Chan Min Wai 2005-04-05 10:16:12 UTC
Problem related to ipv6
When ipv6 kernel module is not load Everythings work fine.

alias net-pf-10 off
Don't SEEM to help...

Anyone know why?

Thank for all help.
Comment 10 Roy Marples (RETIRED) gentoo-dev 2005-04-06 09:07:05 UTC
I don't think it's IPv6 related as such as my vlan setup works fine and all boxes have IPv6 addresses
Comment 11 Chan Min Wai 2005-04-07 09:59:12 UTC
But for my situation, Disabling ipv6 on kernel compile seem to solved all the problem.

So how can I track the problem down to the track?
Comment 12 Daniel Drake (RETIRED) gentoo-dev 2005-04-13 08:48:05 UTC
Please test vanilla-sources-2.6.12_rc2
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2005-04-13 16:31:17 UTC
*** Bug 88290 has been marked as a duplicate of this bug. ***
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2005-04-28 10:03:15 UTC
see comment #11
Comment 15 Chan Min Wai 2005-05-13 00:03:18 UTC
2.6.11-r6 seem to able to get the problem solved...
Comment 16 Daniel Drake (RETIRED) gentoo-dev 2005-06-03 08:01:05 UTC
Please also close the upstream bug at
http://bugzilla.kernel.org/show_bug.cgi?id=4441
Comment 17 Kerin Millar 2006-03-21 04:31:38 UTC
This was resolved quite a while ago. Re-opening to change resolution and bring to closure.
Comment 18 Kerin Millar 2006-03-21 04:32:07 UTC
Marking as FIXED.
Comment 19 Kerin Millar 2006-03-21 04:32:39 UTC
And finally, closing.