Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 874054 - dev-libs/OpenNI-1.5.7.10-r3 - ../.../SceneDrawer.cpp: error:
Summary: dev-libs/OpenNI-1.5.7.10-r3 - ../.../SceneDrawer.cpp: error:
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-02 13:31 UTC by Toralf Förster
Modified: 2024-05-09 18:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.30 KB, text/plain)
2022-10-02 13:31 UTC, Toralf Förster
Details
dev-libs:OpenNI-1.5.7.10-r3:20221002-125006.log (dev-libs:OpenNI-1.5.7.10-r3:20221002-125006.log,66.72 KB, text/plain)
2022-10-02 13:31 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,103.16 KB, text/plain)
2022-10-02 13:31 UTC, Toralf Förster
Details
environment (environment,136.21 KB, text/plain)
2022-10-02 13:32 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,12.11 KB, application/x-bzip)
2022-10-02 13:32 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,35.26 KB, application/x-bzip)
2022-10-02 13:32 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-10-02 13:31:54 UTC
too long lines were shrinked:

clang++ -MD -MP -MT "./x64-Release/main.d x64-Release/main.o" -c -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -fno-strict-aliasing -O2 -DNDEBUG -I../../../../../Include -I../../../../../Samples/NiHandTracker  -o x64-Release/main.o ../../..
2 warnings generated.
clang++ -MD -MP -MT "./x64-Release/Menu.d x64-Release/Menu.o" -c -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -fno-strict-aliasing -O2 -DNDEBUG -I../../../../../Include -I../../../../../Samples/NiViewer  -o x64-Release/Menu.o ../../../../.
clang++ -o ../../../Bin/x64-Release/Sample-NiHandTracker ./x64-Release/NiHandTracker.o ./x64-Release/NiHandViewer.o ./x64-Release/NiSimpleViewer.o ./x64-Release/main.o -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0  -L../../../Bin/x64-Release -lglut -lGL -lOpenNI
../../../../../Samples/NiUserSelection/SceneDrawer.cpp:154:26: error: 
      non-constant-expression cannot be narrowed from type 'XnUInt16'
      (aka 'unsigned short') to 'GLfloat' (aka 'float') in initializer list

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-j4-20221001-224558

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.2.0 *
clang/llvm (if any):
clang version 15.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
/usr/lib/llvm/15
15.0.1
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.64.0 *
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
The following VMs are available for generation-2:
*)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
2)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-bin-17  system-vm

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
  [1]   php8.1 *
GNU Make 4.3

  HEAD of ::gentoo
commit ffd974ef87604e20495370342e9dbcb42a4dbc82
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sun Oct 2 11:31:48 2022 +0000

    2022-10-02 11:31:48 UTC

emerge -qpvO dev-libs/OpenNI
[ebuild  N    ] dev-libs/OpenNI-1.5.7.10-r3  USE="opengl -doc -java"
Comment 1 Toralf Förster gentoo-dev 2022-10-02 13:31:55 UTC
Created attachment 815488 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-10-02 13:31:57 UTC
Created attachment 815491 [details]
dev-libs:OpenNI-1.5.7.10-r3:20221002-125006.log
Comment 3 Toralf Förster gentoo-dev 2022-10-02 13:31:58 UTC
Created attachment 815494 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2022-10-02 13:32:00 UTC
Created attachment 815497 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2022-10-02 13:32:01 UTC
Created attachment 815500 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-10-02 13:32:03 UTC
Created attachment 815503 [details]
temp.tar.bz2
Comment 7 NHO 2024-03-26 10:03:44 UTC
OpenNI is dead. For last 15 years.
Site is unreachable. Wiki is unreacheble.
Mask IUSE=openni, drop it in favor of OpenNI2: everything in main tree that supports first, supports second. And OpenNI2 has been dead for only 9 years.