Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87300 - The following QA KEYWORDS are not documented in `man repoman`
Summary: The following QA KEYWORDS are not documented in `man repoman`
Status: VERIFIED FIXED
Alias: None
Product: [OLD] Docs-developer
Classification: Unclassified
Component: Portage Documentation (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 120474
  Show dependency tree
 
Reported: 2005-03-30 09:40 UTC by Sandro Bonazzola (RETIRED)
Modified: 2006-06-03 00:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
repoman.generate (repoman.generate,1.22 KB, text/plain)
2006-02-03 21:14 UTC, SpanKY
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Bonazzola (RETIRED) gentoo-dev 2005-03-30 09:40:38 UTC
The following QA KEYWORDS are not documented in `man repoman`:

DEPEND.badindev
DEPEND.badmaskedindev
DEPEND.syntax
IUSE.invalid
IUSE.missing
KEYWORDS.invalid
LICENSE.invalid
LICENSE.syntax
PDEPEND.bad
PDEPEND.badindev
PDEPEND.badmasked
PDEPEND.badmaskedindev
PDEPEND.syntax
RDEPEND.badindev
RDEPEND.badmaskedindev
changelog.notadded
digest.fail
digest.partial
digest.unmatch
digest.unused
ebuild.allmasked
ebuild.badheader
ebuild.majorsyn
ebuild.minorsyn
ebuild.nesteddie
ebuild.nostable
metadata.bad
metadata.missing
variable.readonly
IUSE.missing

Reproducible: Always
Steps to Reproduce:
man repoman

Actual Results:  
Some QA Flags not documented.

Expected Results:  
All QA Flags documented.

Most of the QA Flags undocumented are easy to understand, but some are not
trivial: DEPEND.badindev, DEPEND.badmaskedindev, variable.readonly, ...
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-02-03 10:51:31 UTC
Waiting on this one...We are looking at autogenerating documentation for emerge, repoman should be similar.
Comment 2 SpanKY gentoo-dev 2006-02-03 21:14:11 UTC
Created attachment 78844 [details]
repoman.generate

ghetto bash script to generate manpage from `repoman -h`
Comment 3 Mark Loeser (RETIRED) gentoo-dev 2006-05-19 20:45:29 UTC
So, can someone use spanky's script to make a new manpage so we can close this out? :)
Comment 4 Marius Mauch (RETIRED) gentoo-dev 2006-05-19 21:53:39 UTC
seems to be done already
Comment 5 Sandro Bonazzola (RETIRED) gentoo-dev 2006-06-03 00:42:37 UTC
Verified, all the keywords are documented or removed (IUSE.missing) from the actual version of repoman. Good work. Closing.