Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87285 - mod_php & PHP 5.0.3-r1; Configure Error; ming 0.2a-r1
Summary: mod_php & PHP 5.0.3-r1; Configure Error; ming 0.2a-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: PHP Bugs
: 94979 102559 108547 (view as bug list)
Depends on:
Blocks: 60438 222319
  Show dependency tree
Reported: 2005-03-30 07:43 UTC by Ryan M Ong
Modified: 2008-06-08 23:03 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,94.57 KB, text/plain)
2005-04-07 02:25 UTC, Martin Mokrejš

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan M Ong 2005-03-30 07:43:49 UTC
mod_php and PHP will not compile because it cannot parse the 0.2a-r1 version for ming when checking for Ming_useSWFVersion. It says
configure: error: Ming library 0.2a or greater required

This applies to all ebuilds that use Ming
Comment 1 Martin Mokrejš 2005-04-07 02:21:52 UTC
confirming this bug:

checking for Java support... yes
checking Java Jar location... /opt/blackdown-jdk- cf
checking Java C location... /opt/blackdown-jdk-
checking Checking for libjava... /opt/blackdown-jdk-
checking for LDAP support... no
checking whether to enable multibyte string support... yes
checking whether to enable multibyte regex support... yes
checking for external libmbfl... no
checking for MCAL support... yes
checking for mcrypt support... yes
checking for mcrypt_module_open in -lmcrypt... yes
checking for mcrypt_generic_deinit in -lmcrypt... yes
checking for MCVE support... no
checking OpenSSL dir for MCVE... no
checking for mhash support... yes
checking whether to include mime_magic support... yes
checking for MING support... yes
checking for sin in -lm... (cached) yes
checking for Ming_useSWFVersion in -lming... no
configure: error: Ming library 0.2a or greater required.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/mod_php-4.3.10-r1/work/php-4.3.10/config.log

!!! ERROR: dev-php/mod_php-4.3.10-r1 failed.

# emerge info
Portage (default-linux/x86/2004.0, gcc-3.4.3-20050110, glibc-, i686)
System uname: i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 21 2005, 21:57:42)]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.5, 1.9.5, 1.4_p6, 1.6.3, 1.8.5-r3, 1.7.9-r1
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.4.19-r1, 2.4.22-r1
CFLAGS="-O3 -mmmx -msse -msse2 -fomit-frame-pointer -march=pentium4 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -mmmx -msse -msse2 -fomit-frame-pointer -march=pentium4 -funroll-loops -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="x86 FFmpeg X Xaw3d aalib acpi adns afs alsa apache2 apm arts ati avcodec avi berkdb bidi bitmap-fonts bonobo caca cdparanoia cdr crypt cscope cups curl dba dga directfb divx divx4 divx4linux divx5 divx5linux doc dv dvb dvd dvdr dvdread emacs emacs-w3 emboss encode esd ethereal evo f77 faac faad faad2 fam fame fbcon ffmpeg flac flash font-server foomaticdb fortran fvwm fvwm2 gb gd gdbm ggi gif gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile i8x0 icc imagemagick imlib imlib2 innodb java jpeg junit lcms leim libg++ libwww live lpthread lzo lzw-tiff mad mcal mesa mikmod mmx mmx2 motif mozilla mp3 mpeg mule mysql ncurses network nls oggvorbis opengl oss pam pda pdflib perl php php4 plotutils png ppds pthread pthreads python qt qtx quicktime readline rtc ruby samba scanner sdl slang slp speex spell sse sse2 ssl svga tcltk tcpd tetex theora thread threads tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 win32 winvidix wmf xml xml2 xmms xosd xv xvid xvmc yv12 zeo zlib video_cards_radeon linguas_cs linguas_cz linguas_en"
Comment 2 Martin Mokrejš 2005-04-07 02:25:14 UTC
Created attachment 55544 [details]
Comment 3 Martin Mokrejš 2005-04-07 02:29:06 UTC
I have installed:

*  media-libs/libswf
      Latest version available: 0.99
      Latest version installed: 0.99
      Size of downloaded files: 567 kB

*  media-libs/ming
      Latest version available: 0.2a-r1
      Latest version installed: 0.2a-r1
      Size of downloaded files: 309 kB
Comment 4 Christopher Covington 2005-04-09 09:13:29 UTC
I've got the same problem. A similar thing is happening with <a href="">PHP 4.2.0</a>. I'm going to investigate their solution.
Comment 5 Christopher Covington 2005-04-09 09:23:51 UTC
The solution those guys had was evidently making the ebuild for 0.2a... only it's installed. I synced right before I tried to emerge (I guess that was april 8th) and although I have ming-0.2a (I don't remember if it's r1 or not but I do know that I don't have that package unmasked) php can't detect. Any sort of temporary patch would  be cool. I'd like to get php emerged so I can continue on to emerging kde and completing my system, or at least getting to the point of not as many new things emerged every day.
Comment 6 Ryan M Ong 2005-04-11 16:24:40 UTC
easy fix is to mask the ming-0.2-r1 then rebuild
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-06-04 00:26:00 UTC
*** Bug 94979 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-08-15 00:50:12 UTC
*** Bug 102559 has been marked as a duplicate of this bug. ***
Comment 9 Luca Longinotti (RETIRED) gentoo-dev 2005-08-25 12:09:49 UTC
The -r1 has nothing to do with how the ming library calls itself, PHP is able to
find it. Your config.log shows that the problem is not that it can't find the
library but that it can't find some expected functions in it:
/usr/lib/ undefined reference to `swf5parse'
/usr/lib/ undefined reference to `swf5lval'
Rebuild libswf and ming, run revdep-rebuild generally and use saner CFLAGS, -O3
can cause problems in some situations.
I tried building PHP with ming-0.2a-r1 and it worked, at least the one from the
overlay (link: ), if you still
encounter problems please try the overlay. Thanks, CHTEKK.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2005-08-25 12:18:21 UTC
Comment 11 Luca Longinotti (RETIRED) gentoo-dev 2005-08-26 16:39:39 UTC
We actually managed to reproduce the bug by chance on one of the boxes and
managed to track it down. You can't install both libswf and ming, if you do, PHP
will die complaining that ming is not the correct version. ming does not need
libswf as dependency and ming is the new, correct way to support Flash stuff in
both PHP4 and PHP5, _not_ libswf. The PHP Overlay was fixed in this regard, it
requires you to uninstall libswf and then you can use ming without problems. To
fix mod_php5 compile issues you're getting now, just unmerge both libswf and
ming and then reemerge only ming, that will fix it. Be careful though, "flash"
USE flag in mod_php4 still neds libswf, so you can't use both atm with the
Portage ebuilds, with the PHP Overlay ebuilds you can, they all use ming!
Best regards, CHTEKK.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2005-08-26 16:42:11 UTC
Reopening to mark this bug FIXED.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2005-08-26 16:42:33 UTC
FIXED, closing again.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2005-10-08 16:00:34 UTC
*** Bug 108547 has been marked as a duplicate of this bug. ***