Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 870862 - sci-calculators/hcalc-1.2-r1 - /.../input.c: error: call to undeclared function set_bits; ISO C99 and later do not support implici
Summary: sci-calculators/hcalc-1.2-r1 - /.../input.c: error: call to undeclared functi...
Status: RESOLVED DUPLICATE of bug 870514
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-09-17 16:04 UTC by Toralf Förster
Modified: 2022-09-28 22:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.56 KB, text/plain)
2022-09-17 16:04 UTC, Toralf Förster
Details
clang.tar.bz2 (clang.tar.bz2,2.62 KB, application/x-bzip)
2022-09-17 16:04 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,134.15 KB, text/plain)
2022-09-17 16:04 UTC, Toralf Förster
Details
environment (environment,100.48 KB, text/plain)
2022-09-17 16:04 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,12.92 KB, application/x-bzip)
2022-09-17 16:04 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,3.36 KB, application/x-bzip)
2022-09-17 16:04 UTC, Toralf Förster
Details
sci-calculators:hcalc-1.2-r1:20220917-153710.log (sci-calculators:hcalc-1.2-r1:20220917-153710.log,10.58 KB, text/plain)
2022-09-17 16:04 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,28.24 KB, application/x-bzip)
2022-09-17 16:04 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-09-17 16:04:13 UTC
too long lines were shrinked:

3 warnings and 2 errors generated.
[2/6] /var/tmp/portage/sci-calculators/hcalc-1.2-r1/temp/clang    -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -I/usr/include -MD -MT CMakeFiles/hcalc.dir/input.c.o -MF CMakeFiles/hcalc.dir/input.c.o.d -o CMakeFiles/h
FAILED: CMakeFiles/hcalc.dir/input.c.o 
/var/tmp/portage/sci-calculators/hcalc-1.2-r1/temp/clang    -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -I/usr/include -MD -MT CMakeFiles/hcalc.dir/input.c.o -MF CMakeFiles/hcalc.dir/input.c.o.d -o CMakeFiles/hcalc.d
/var/tmp/portage/sci-calculators/hcalc-1.2-r1/work/hcalc-1.2/input.c:72:5: error: call to undeclared function 'set_bits'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
    set_bits(q);
    ^

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-j4-20220916-040004

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.1
 [2] x86_64-pc-linux-gnu-12.2.0 *
clang/llvm (if any):
clang version 15.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
/usr/lib/llvm/15
15.0.0
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby31 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.63.0 *
The following VMs are available for generation-2:
*)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
2)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-bin-17  system-vm

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3.90

  HEAD of ::gentoo
commit 27e349751fc08f79c6f96f84652edf0c93ba9a1f
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sat Sep 17 14:46:52 2022 +0000

    2022-09-17 14:46:52 UTC

emerge -qpvO sci-calculators/hcalc
[ebuild  N    ] sci-calculators/hcalc-1.2-r1
Comment 1 Toralf Förster gentoo-dev 2022-09-17 16:04:14 UTC
Created attachment 808225 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-09-17 16:04:15 UTC
Created attachment 808228 [details]
clang.tar.bz2
Comment 3 Toralf Förster gentoo-dev 2022-09-17 16:04:16 UTC
Created attachment 808231 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2022-09-17 16:04:18 UTC
Created attachment 808234 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2022-09-17 16:04:19 UTC
Created attachment 808237 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-09-17 16:04:20 UTC
Created attachment 808240 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2022-09-17 16:04:21 UTC
Created attachment 808243 [details]
sci-calculators:hcalc-1.2-r1:20220917-153710.log
Comment 8 Toralf Förster gentoo-dev 2022-09-17 16:04:23 UTC
Created attachment 808246 [details]
temp.tar.bz2
Comment 9 Ionen Wolkens gentoo-dev 2022-09-28 22:36:42 UTC

*** This bug has been marked as a duplicate of bug 870514 ***