Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 866320 - app-text/ronn-ng-0.9.1-r2: fatal: the 'kramdown' library is required (gem install kramdown)
Summary: app-text/ronn-ng-0.9.1-r2: fatal: the 'kramdown' library is required (gem ins...
Status: RESOLVED DUPLICATE of bug 835156
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 898414
  Show dependency tree
 
Reported: 2022-08-24 13:33 UTC by Yixun Lan
Modified: 2023-04-07 14:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (build.log,1.98 KB, text/x-log)
2022-08-24 13:34 UTC, Yixun Lan
Details
kramdown info (kramdown.txt,4.98 KB, text/plain)
2022-08-24 13:34 UTC, Yixun Lan
Details
emerge --info (emerge_info.txt,6.78 KB, text/plain)
2022-08-24 13:37 UTC, Yixun Lan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yixun Lan archtester gentoo-dev 2022-08-24 13:33:56 UTC
I'm confused, the kramdown is actually installed

fatal: the 'kramdown' library is required (gem install kramdown)
 * ERROR: app-text/ronn-ng-0.9.1-r2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:


Reproducible: Always
Comment 1 Yixun Lan archtester gentoo-dev 2022-08-24 13:34:20 UTC
Created attachment 800791 [details]
full build log
Comment 2 Yixun Lan archtester gentoo-dev 2022-08-24 13:34:42 UTC
Created attachment 800794 [details]
kramdown info
Comment 3 Yixun Lan archtester gentoo-dev 2022-08-24 13:37:40 UTC
Created attachment 800797 [details]
emerge --info
Comment 4 Yixun Lan archtester gentoo-dev 2022-08-25 09:34:56 UTC
this actually due to ronn-ng pull in ruby31, while following packages only support version up to ruby30, force upgrade USE_RUBY to ruby31 will solve the issue, please help to double check if this is a proper fix

dev-ruby/kramdown-2.4.0
dev-ruby/mustache-1.1.1-r1
dev-ruby/stringex-2.8.5-r2
Comment 5 Hans de Graaff gentoo-dev 2022-08-27 07:42:38 UTC
(In reply to Yixun Lan from comment #4)
> this actually due to ronn-ng pull in ruby31, while following packages only
> support version up to ruby30, force upgrade USE_RUBY to ruby31 will solve
> the issue, please help to double check if this is a proper fix
> 
> dev-ruby/kramdown-2.4.0
> dev-ruby/mustache-1.1.1-r1
> dev-ruby/stringex-2.8.5-r2

Yes, this would be the correct fix, but unfortunately stringex is not compatible with ruby31 yet, as can be seen from the test failures.
Comment 6 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-04-07 14:05:33 UTC

*** This bug has been marked as a duplicate of bug 835156 ***