Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 864827 - www-apps/redmine-4.2.7: fails during use (Psych::DisallowedClass (Tried to load unspecified class: ActiveSupport::HashWithIndifferentAccess):)
Summary: www-apps/redmine-4.2.7: fails during use (Psych::DisallowedClass (Tried to lo...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Azamat H. Hackimov
Keywords: PullRequest
Depends on:
Reported: 2022-08-10 18:02 UTC by Peter Gustafson
Modified: 2022-12-24 07:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Gustafson 2022-08-10 18:02:09 UTC
Redmine superficially starts and users can log in, however, any attempt to examine an issue causes an error. (i.e., click on the issues list on a project)  This renders the sofware useless because all the major functions of the software resolve around creating/examining/closing issues.

Reproducible: Always

Steps to Reproduce:
1. Upgrade redmine to 4.2.7
2. emerge --config "=www-apps/redmine-4.2.7"
3. start apache
4. login, open project
5. click on issues
Actual Results:  
Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

Remine logs show the below:

I, [2022-08-10T13:30:01.525737 #39761]  INFO -- : Started GET "/redmine/issues" for at 2022-08-10 13:30:01 -0400
I, [2022-08-10T13:30:01.527387 #39761]  INFO -- : Processing by IssuesController#index as HTML
I, [2022-08-10T13:30:01.537504 #39761]  INFO -- :   Current user: pete (id=5)
I, [2022-08-10T13:30:01.704914 #39761]  INFO -- : Completed 500 Internal Server Error in 177ms (ActiveRecord: 16.5ms)
F, [2022-08-10T13:30:01.705705 #39761] FATAL -- :   
F, [2022-08-10T13:30:01.705739 #39761] FATAL -- : Psych::DisallowedClass (Tried to load unspecified class: ActiveSupport::HashWithIndifferentAccess):
F, [2022-08-10T13:30:01.705758 #39761] FATAL -- :   
F, [2022-08-10T13:30:01.705782 #39761] FATAL -- : app/models/custom_field.rb:221:in `full_width_layout?'

Expected Results:  
redmine issues list should come up.

I've tried a number of combinations of dependencies to make it work, all to no avail. (for example, install dev-ruby/psych<4).  These actions lead to different breakage.
Comment 1 Azamat H. Hackimov 2022-09-01 19:25:42 UTC

Please attach emerge --info and content of http://localhost:3000/admin/info and http://localhost:3000/admin/plugins
Comment 2 Azamat H. Hackimov 2022-12-09 13:28:32 UTC
Seems related to, should be fixed in 4.2.9/5.0.4.
Comment 3 Larry the Git Cow gentoo-dev 2022-12-24 07:42:45 UTC
The bug has been closed via the following commit(s):

commit c88e7e9b7e2698e9bfad3df18d43d344a80a603d
Author:     Azamat H. Hackimov <>
AuthorDate: 2022-12-09 13:00:06 +0000
Commit:     Sam James <>
CommitDate: 2022-12-24 07:41:38 +0000

    www-apps/redmine: add 4.2.9, 5.0.4
    Fixes security issue CVE-2022-44030.
    Signed-off-by: Azamat H. Hackimov <>
    Signed-off-by: Sam James <>

 www-apps/redmine/Manifest             |   2 +
 www-apps/redmine/redmine-4.2.9.ebuild | 240 ++++++++++++++++++++++++++++++++
 www-apps/redmine/redmine-5.0.4.ebuild | 254 ++++++++++++++++++++++++++++++++++
 3 files changed, 496 insertions(+)