Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 86138 - w3m-i18n fails to compile.
Summary: w3m-i18n fails to compile.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: CJK Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-21 07:51 UTC by Masatomo Nakano (RETIRED)
Modified: 2005-03-21 08:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
error log (error_log,48.99 KB, text/plain)
2005-03-21 07:52 UTC, Masatomo Nakano (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masatomo Nakano (RETIRED) gentoo-dev 2005-03-21 07:51:16 UTC
w3m-i18n (not sure about w3m) fails to compile due to missing gdk-pixbuf's headers.

I looked into the ebuild...
this package seems to require media-libs/gdk-pixbuf even if USE="imlib" is set.

So, DEPEND logic should be like this?
    X? ( !nopixbuf? ( >=media-libs/gdk-pixbuf-0.22.0 )
        || ( imlib2? ( >=media-libs/imlib2-1.0.5 )
        imlib? ( >=media-libs/imlib-1.9.8 )
        virtual/libc )
    )

By the way, why does it have virtual/libc there?


# emerge -pv w3m-m17n
(snip)
[ebuild  N    ] www-client/w3m-m17n-0.4.2  +X +gpm +imlib -imlib2 +migemo -nopixbuf +ssl -xface 0 kB

# emerge info
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11-gentoo-r1 i686)
=================================================================
System uname: 2.6.11-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 1500MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 18 2005, 10:14:37)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.2-r5
virtual/os-headers:  2.4.22-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://www.mirror.ac.uk/sites/www.ibiblio.org/gentoo/ ftp://gentoo.blueyonder.co.uk/mirrors/gentoo"
LANG="en_US.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/work"
PORTDIR="/usr/portage"
SYNC="rsync://192.168.0.5/gentoo-portage"
USE="x86 X apm arts avi berkdb bitmap-fonts cjk crypt cups emacs emboss encode font-server foomaticdb gif gpm gtk gtk2 imlib ipv6 jpeg libg++ libwww mad migemo mikmod motif mp3 mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline ruby sdl spell ssl svga tcpd truetype truetype-fonts type1-fonts unicode xml2 xmms xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Masatomo Nakano (RETIRED) gentoo-dev 2005-03-21 07:52:04 UTC
Created attachment 54059 [details]
error log
Comment 2 Mamoru KOMACHI (RETIRED) gentoo-dev 2005-03-21 08:11:05 UTC
Yep, this is a problem, but I'm not going to fix it.
Please use www-client/w3m instead. w3m-m17n doesn't detect
required libs correctly, and the problem was fixed in
>=w3m-0.5 (w3m-m17n patch was merged to mainstream somewhere
near 0.5).