Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 85932 - 2.6.11-gentoo-r4 breaks the ALPS pointing stick.
Summary: 2.6.11-gentoo-r4 breaks the ALPS pointing stick.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All All
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 98397
  Show dependency tree
 
Reported: 2005-03-19 12:15 UTC by Andy Wang
Modified: 2005-09-06 14:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Wang 2005-03-19 12:15:58 UTC
I have an Dell Inspiron 8500 which an ALPS dualpoint device. This thing has the touchpad and one of the eraser nub pointing sticks. there are also 2 sets of buttons. With 2.6.11-gentoo-r4 the stick doesn't work anymore. The buttons don't respond either. If I boot to windows first, the stick will work, but the buttons for the stick still don't respond.

ALPS Touchpad (Dualpoint) detected
input: AlpsPS/2 ALPS TouchPad on isa0060/serio1

The kernel does properly detect this device though.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-03-19 12:30:13 UTC

*** This bug has been marked as a duplicate of 84657 ***
Comment 2 Micheal Marineau (RETIRED) gentoo-dev 2005-07-08 14:26:41 UTC
Re-opening as per comment 37 in bug #84657
Comment 3 Micheal Marineau (RETIRED) gentoo-dev 2005-07-08 14:38:00 UTC
> Bug 85932 was made a duplicate of this bug.  It's the trackpoint not working on
> my dell inspiron 8500 with an alps dualpoint device.  This is still not fixed in
> 2.6.12.  It's also intermittent (was before too) if i reboot a few times,
> sometimes the trackpoint will initialize, other times it will not.  Perhaps my
> bug should be re-opened standalone since it doesn't seem to be the same problem.

I also have an 8500, I saw this in the past but on the 2.6.12 kernel the only
time the stick dies for me is after a suspend/resume cycle.  What's the exact
kernel version that you are using?
Comment 4 Andy Wang 2005-07-08 17:18:00 UTC
I'm using 2.6.12-gentoo-r4.  Just built it today.
I haven't ever actually got suspend/resume to work ever, so I wouldn't know if
that's where it's breaking :).

If you have, would you be willing to e-mail me any scripts you have?
Comment 5 Micheal Marineau (RETIRED) gentoo-dev 2005-07-09 00:36:33 UTC
(In reply to comment #4)
> I'm using 2.6.12-gentoo-r4.  Just built it today.

Could you attach your kernel config so I can try your exact kernel/config, and
check to see if there is any in /proc/bus/input/devices between when it works
and when it doesn't.  Might as well also do a cat on /dev/input/mouse0 or mouse1
(which ever one it is on your system) when it isn't working and try to fiddle
with the mouse to check that it is indeed the kernel doing it.

> I haven't ever actually got suspend/resume to work ever, so I wouldn't know if
> that's where it's breaking :).
> 
> If you have, would you be willing to e-mail me any scripts you have?

lets keep this bug on alps, I should post some documentation on what I'm doing
on my system sometime. :-)

Comment 6 Micheal Marineau (RETIRED) gentoo-dev 2005-07-09 00:39:24 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > I'm using 2.6.12-gentoo-r4.  Just built it today.
> 
> Could you attach your kernel config so I can try your exact kernel/config, and
> check to see if there is any in /proc/bus/input/devices between when it works
*any difference in*
> and when it doesn't.  Might as well also do a cat on /dev/input/mouse0 or mouse1
> (which ever one it is on your system) when it isn't working and try to fiddle
> with the mouse to check that it is indeed the kernel doing it.

Comment 7 Micheal Marineau (RETIRED) gentoo-dev 2005-07-10 01:08:41 UTC
Try this patch on for size:

http://dev.gentoo.org/~marineam/files/alps-dell8500-dualpoint.patch

it fixes the resume issue for mine, maybe it'll fix your's as well.

If that still doesn't work, open up drivers/input/mouse/alps.c and change #undef
DEBUG to #define DEBUG and post the alps.c: dmesg lines that pop up.
Comment 8 Micheal Marineau (RETIRED) gentoo-dev 2005-07-10 13:24:14 UTC
Hrm, that might not actually fix anything at all... there's something else funky
going on here.
Comment 9 Andy Wang 2005-07-17 13:45:31 UTC
This hasn't occured in a few weeks.  I haven't rebooted my laptop very often
though.  I am 100% sure that there were at least 1 or 2 boots since going to
2.6.12-gentoo-r4 that my alps pointing stick did not work (but the touchpad
did).  But it hasn't happened in quite some time.  I probably won't have time to
test this more thoroughly for a few weeks though, but when I do, I'll see what I
can find.
Comment 10 Micheal Marineau (RETIRED) gentoo-dev 2005-07-26 01:53:42 UTC
It's just one of those magical things I think, with acpi resume (the only way I
have seen a similar issue on recent kernels) I managed to make things work
differently by just adding some printk statements here and there.  I didn't get
far enough to see where the timing was being weird though. hopefully I'll get
back to this one soon.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2005-09-01 12:24:12 UTC
If this bug is still present in 2.6.13 and you have some time to give us some
more info, then please reopen this bug.
Comment 12 Andy Wang 2005-09-06 14:25:50 UTC
I was able to reproduce this problem one more time after my last post.  However,
i did something stupid and had to reboot before I could gather any more
information and since then it hasn't occurred again.  I'm thinking I agree with
Micheal that it's some kind of horrible timing thing that causes it to happen.