Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 85865 - error emerge media-video/transcode-0.6.14
Summary: error emerge media-video/transcode-0.6.14
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 85877 86809 88502 88568 88990 88993 89000 89003 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-19 00:50 UTC by Alexey Maximov
Modified: 2005-04-13 12:33 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New ebuild compiles with libquicktime-0.9.4 (transcode-0.6.14-r1.ebuild,3.81 KB, text/plain)
2005-04-12 17:15 UTC, Jürgen Hötzel
Details
New ebuild compiles with libquicktime-0.9.4 (patch-only) (transcode-0.6.14-r1.ebuild.patch,739 bytes, patch)
2005-04-12 17:16 UTC, Jürgen Hötzel
Details | Diff
compiles with libquicktime-0.9.4 (transcode-0.6.14-libquicktime094.patch,3.79 KB, patch)
2005-04-12 17:17 UTC, Jürgen Hötzel
Details | Diff
Fix: undefined reference to `yuv2rgb_init_mmx' (transcode-0.6.14-amd64_mmx.patch,743 bytes, patch)
2005-04-12 17:18 UTC, Jürgen Hötzel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Maximov 2005-03-19 00:50:58 UTC
/bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -march=i686 -O2 -pipe -fomit-frame-pointer -DDCT_YUV_PRECISION=1  -Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -o tcdecode  tcdecode-tcdecode.o tcdecode-decode_ac3.o tcdecode-decode_mpeg2.o tcdecode-decode_yuv.o tcdecode-fileinfo.o tcdecode-ioaux.o tcdecode-decode_dv.o tcdecode-decode_mp3.o tcdecode-mpg123.o tcdecode-decode_a52.o tcdecode-decode_af6.o tcdecode-scan_dv.o tcdecode-decode_lavc.o tcdecode-decode_xvid.o tcdecode-decode_ogg.o tcdecode-decode_mov.o tcdecode-decode_lzo.o -L/usr/lib -lavcodec -L/usr//lib -lmp3lame ../libac3/libac3_tc.la ../libmpeg2/libmpeg2cvs.la ../libvo/libvout.la -ldv -lpthread -lm -lvorbisfile -ltheora -logg -lm -lvorbis -logg -lm -logg -lquicktime -lpng -lz -lpthread -lm -ldv -lpthread -lm -ldl -L/usr//lib -llzo ../aclib/libac.la -lm -lz -ldl
i686-pc-linux-gnu-gcc -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -march=i686 -O2 -pipe -fomit-frame-pointer -DDCT_YUV_PRECISION=1 -Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -o tcdecode tcdecode-tcdecode.o tcdecode-decode_ac3.o tcdecode-decode_mpeg2.o tcdecode-decode_yuv.o tcdecode-fileinfo.o tcdecode-ioaux.o tcdecode-decode_dv.o tcdecode-decode_mp3.o tcdecode-mpg123.o tcdecode-decode_a52.o tcdecode-decode_af6.o tcdecode-scan_dv.o tcdecode-decode_lavc.o tcdecode-decode_xvid.o tcdecode-decode_ogg.o tcdecode-decode_mov.o tcdecode-decode_lzo.o  -L/usr/lib -lavcodec -L/usr//lib /usr/lib/libmp3lame.so ../libac3/.libs/libac3_tc.a ../libmpeg2/.libs/libmpeg2cvs.a ../libvo/.libs/libvout.a /usr/lib/libvorbisfile.so /usr/lib/libtheora.so /usr/lib/libvorbis.so /usr/lib/libogg.so /usr/lib/libquicktime.so -lpng /usr/lib/libdv.so -lpthread /usr/lib/liblzo.so ../aclib/.libs/libac.a -lm -lz -ldl
tcdecode-decode_mov.o(.text+0x4d7): In function `decode_mov':
: undefined reference to `quicktime_read_audio'
collect2: ld returned 1 exit status
make[3]: *** [tcdecode] Error 1
make[3]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14/import'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14/import'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14'
make: *** [all] Error 2

!!! ERROR: media-video/transcode-0.6.14 failed.
!!! Function src_compile, Line 103, Exitcode 2
!!! (no error message)                                
-----------------------------------

amazing ~ # emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3, glibc-2.3.4.20050125-r1, 2.6.11.4-cko2 i686)
=================================================================
System uname: 2.6.11.4-cko2 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Mar 17 2005, 16:36:13)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.8.5-r3, 1.9.5, 1.5, 1.6.3, 1.7.9-r1, 1.4_p6
sys-devel/binutils:  2.15.92.0.2-r6
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/media/MEDIA1/gentoo/distfiles"
FEATURES="autoaddcvs autoconfig buildpkg distlocks prelink sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="ru_RU.CP1251"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags"
MAKEOPTS="-j1"
PKGDIR="/media/MEDIA1/gentoo/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/media/MEDIA1/gentoo/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acl acpi acpi4linux activefilter alsa apm arts artswrappersuid audiofile avi bash-completion bitmap-fonts bluetooth caps cdda cddb cdio cdparanoia cdr crypt cups curl dga directfb dts dv dvb dvd dvdr dvdread emboss encode exif fam fbcon ffmpeg flac foomaticdb freetype ftp gd ggi gif gimp glitz gnokii gnutls gphoto2 gpm gstreamer gtk2 guile hal howl iconv ieee1394 imagemagick imap imlib innodb jack jack-tmpfs joystick jpeg jpeg2k kde kdeenablefinal kerberos ladcca ladspa ldap libcaca libg++ libwww lirc live lm_sensors lmtp logitech-mouse lua lufsusermount lzo mad maildir mailwrapper matroska mbox mikmod mjpeg mmx mng mozilla mozsvg mp3 mpeg mppe-mppc nas ncurses network nntp no-old-linux nptl nptlonly ntlm oav odbc ogg oggvorbis openal opengl pam pcmcia pcre pda pdflib pic plotutils png portaudio povray pvm pwdb qt quicktime quotas rdesktop readline real rtc samba sasl scanner sdl silc skey slang slp smartcard socks5 speex spell ssl stream svg svga svgz symlink sysfs tcltk tcpd tetex theora threads tidy tiff transcode truetype truetype-fonts usb utf8 v4l v4l2 vcd vcdimager vidix vlm wifi wmf wxwindows xine xml xml2 xv xvid yv12 zeroconf zlib linguas_ru"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL
Comment 1 Alexey Maximov 2005-03-19 00:51:33 UTC
USE=-quicktime works
Comment 2 Jan Brinkmann (RETIRED) gentoo-dev 2005-03-20 10:56:40 UTC
*** Bug 85877 has been marked as a duplicate of this bug. ***
Comment 3 Tristan RENAUD 2005-03-20 12:21:48 UTC
I also have this error.
seem to be the same error as when compiling mjpegtools-1.6.2-r3.
Look at bug #85432.
Comment 4 Olivier Castan 2005-03-22 14:05:24 UTC
The link in bug #85432 :
http://www.mail-archive.com/mjpeg-users@lists.sourceforge.net/msg05238.html

talks about some clean-up in libquicktime, but it was quickly done :
$ grep read_audio /usr/include/quicktime/* /usr/include/quicktime/lqt_codecapi.h:int lqt_read_audio_chunk(quicktime_t * file, int track,
/usr/include/quicktime/quicktime.h:long quicktime_read_audio(quicktime_t *file, char *audio_buffer, long samples, int track);

$ locate -r libquicktime.*so /usr/lib/libquicktime.so
/usr/lib/libquicktime.so.0
/usr/lib/libquicktime.so.0.0.0
/usr/lib/libquicktime/lqt_audiocodec.so
/usr/lib/libquicktime/lqt_videocodec.so
/usr/lib/libquicktime/lqt_opendivx.so
/usr/lib/libquicktime/lqt_rtjpeg.so
/usr/lib/libquicktime/lqt_mjpeg.so
/usr/lib/libquicktime/lqt_dv.so
/usr/lib/libquicktime/lqt_png.so
/usr/lib/libquicktime/lqt_vorbis.so
/usr/lib/libquicktime/lqt_lame.so
/usr/lib/libquicktime/lqt_ffmpeg.so

$ locate -r libquicktime.*so | xargs readelf -s | grep read_audio
   213: 0000f700   384 FUNC    GLOBAL DEFAULT   10 lqt_read_audio_chunk
   213: 0000f700   384 FUNC    GLOBAL DEFAULT   10 lqt_read_audio_chunk
   213: 0000f700   384 FUNC    GLOBAL DEFAULT   10 lqt_read_audio_chunk
    15: 00000000     0 NOTYPE  GLOBAL DEFAULT  UND lqt_read_audio_chunk
    24: 00000000     0 NOTYPE  GLOBAL DEFAULT  UND lqt_read_audio_chunk

quicktime_read_audio is still in include files but not in shared libraries...

Here is the diff from transcode cvs :
diff -u -r1.6 -r1.7
--- transcode/import/import_mov.c	2004/10/18 01:51:35	1.6
+++ transcode/import/import_mov.c	2005/01/24 09:26:12	1.7
@@ -136,11 +136,13 @@
     if(quicktime_supported_audio(qt_audio, 0)!=0) {
       rawAudioMode = 0;
     } 
+#if !defined(LIBQUICKTIME_000904)
     /* RAW PCM is directly supported */
     else if(strcasecmp(codec,QUICKTIME_RAW)==0) {
       rawAudioMode = 1;
       fprintf(stderr,"[%s] using RAW audio mode!\n",MOD_NAME);
     }
+#endif
     /* unsupported codec */
     else {
       fprintf(stderr, "error: quicktime audio codec '%s' not supported!\n",
@@ -334,12 +336,14 @@
     }
 
     /* raw read mode */
+#if !defined(LIBQUICKTIME_000904)
     if(rawAudioMode) {
       bytes_read = quicktime_read_audio(qt_audio, 
 					param->buffer, param->size, 0);
-    } 
-    /* decode audio mode */
-    else {
+    } else
+#endif
+    {
+      /* decode audio mode */
       long pos = quicktime_audio_position(qt_audio,0);
       long samples = param->size;
       if(bits==16)
Comment 5 Jan Brinkmann (RETIRED) gentoo-dev 2005-03-26 16:28:59 UTC
*** Bug 86809 has been marked as a duplicate of this bug. ***
Comment 6 Doug Goldstein (RETIRED) gentoo-dev 2005-03-27 23:07:38 UTC
Olivier, so the patch included fixes it or what?
Comment 7 Olivier Castan 2005-03-28 12:25:44 UTC
libquicktime includes does not define LIBQUICKTIME_000904, so I checked configure.in :
RCS file: /cvstc/transcode/configure.in,v
retrieving revision 1.108
retrieving revision 1.109
diff -u -r1.108 -r1.109
--- transcode/configure.in      2005/01/23 10:25:10     1.108
+++ transcode/configure.in      2005/01/24 09:26:12     1.109
@@ -967,6 +967,10 @@
   [quicktime/lqt.h], quicktime, quicktime_open)
 if test x"$have_libquicktime" = x"yes" ; then
   AC_DEFINE([HAVE_LIBQUICKTIME], 1, [have libquicktime support])
+  AC_CHECK_LIB(quicktime, lqt_encode_video,
+    [AC_DEFINE([LIBQUICKTIME_000904], [1], [Have libquicktime 0.9.4 or newer])],
+    , 
+    [$LIBQUICKTIME_EXTRA_LIBS])
 fi
 AM_CONDITIONAL(HAVE_LIBQUICKTIME, test x"$have_libquicktime" = x"yes")
 AC_SUBST(LIBQUICKTIME_CFLAGS)

I've not tested yet (more important problem, my firefox builds  are broken), but I guess both import_mov.c and configure.in should be patched and autoreconf run in the ebuild...
Comment 8 Ernst de Haan 2005-03-30 00:04:01 UTC
I've got the same problem, with transcode-0.6.14. I have libquicktime-0.9.4 installed.
Comment 9 Jan Brinkmann (RETIRED) gentoo-dev 2005-04-09 12:46:42 UTC
*** Bug 88502 has been marked as a duplicate of this bug. ***
Comment 10 Jan Brinkmann (RETIRED) gentoo-dev 2005-04-10 10:18:39 UTC
*** Bug 88568 has been marked as a duplicate of this bug. ***
Comment 11 Jory A. Pratt 2005-04-10 14:23:06 UTC
I would suggest you all just go ahead and mask libquicktime-0.9.4 for now locally, I have sent an email to zypher asking him too p.mask it seeing it is breaking other ports as well not just transcode.
Comment 12 Jürgen Hötzel 2005-04-12 17:15:34 UTC
Created attachment 56132 [details]
New ebuild compiles with libquicktime-0.9.4
Comment 13 Jürgen Hötzel 2005-04-12 17:16:13 UTC
Created attachment 56133 [details, diff]
New ebuild compiles with libquicktime-0.9.4 (patch-only)
Comment 14 Jürgen Hötzel 2005-04-12 17:17:02 UTC
Created attachment 56134 [details, diff]
compiles with libquicktime-0.9.4
Comment 15 Jürgen Hötzel 2005-04-12 17:18:17 UTC
Created attachment 56135 [details, diff]
Fix: undefined reference to `yuv2rgb_init_mmx'

See: http://article.gmane.org/gmane.comp.video.transcode.user/16427
Comment 16 Jürgen Hötzel 2005-04-12 17:20:16 UTC
Olivier is right with his suggestions. There is also another file to patch (export/export_mov.c).All up:

configure.in 
export/export_mov.c
import/decode_mov.c 
import/import_mov.c

I also come across another bug on my box: http://article.gmane.org/gmane.comp.video.transcode.user/16427.

so the new ebuild uses 2 patches.

J
Comment 17 Jürgen Hötzel 2005-04-12 17:20:16 UTC
Olivier is right with his suggestions. There is also another file to patch (export/export_mov.c).All up:

configure.in 
export/export_mov.c
import/decode_mov.c 
import/import_mov.c

I also come across another bug on my box: http://article.gmane.org/gmane.comp.video.transcode.user/16427.

so the new ebuild uses 2 patches.

Jürgen
Comment 18 Nicolas Vilz 2005-04-12 17:51:16 UTC
i had to do one "libtoolize --copy --force", then ebuild ... compile ran cleanly... now installing and qmerging...
Comment 19 merwan kashouty 2005-04-13 07:00:38 UTC
ditto on the libtoolize --copy --force , i just added it to the ebuild in overlay just before autoconf runs

src_compile() {
        libtoolize --copy --force
        einfo "Running autoreconf"
        autoreconf || die "autoreconf failed"
Comment 20 Jan Brinkmann (RETIRED) gentoo-dev 2005-04-13 09:31:48 UTC
fixed in cvs, thanks a lot for reporting and for supporting our development. also thanks for creating the patch.
Comment 21 Jan Brinkmann (RETIRED) gentoo-dev 2005-04-13 11:25:24 UTC
*** Bug 88990 has been marked as a duplicate of this bug. ***
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2005-04-13 12:07:31 UTC
*** Bug 88993 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2005-04-13 12:19:33 UTC
*** Bug 89000 has been marked as a duplicate of this bug. ***
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2005-04-13 12:33:24 UTC
*** Bug 89003 has been marked as a duplicate of this bug. ***