Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 85782 - sys-libs/glibc-2.3.4.20041102-r1: build fails in src_test
Summary: sys-libs/glibc-2.3.4.20041102-r1: build fails in src_test
Status: RESOLVED DUPLICATE of bug 81636
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-18 08:21 UTC by Sascha Silbe
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
posix/globtest.out (bug85782-globtest.out,469 bytes, text/plain)
2005-03-18 08:23 UTC, Sascha Silbe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Silbe 2005-03-18 08:21:52 UTC
sys-libs/glibc-2.3.4.20041102-r1 fails the "Tilde{,2,3} test". Looks like it's got something to do with ~portage vs. ~root.


Reproducible: Didn't try
Steps to Reproduce:
1. emerge -uv glibc

Actual Results:  
[...]
i586-pc-linux-gnu-gcc globtest.c -c -std=gnu99 -O2 -Wall -Winline -Wstrict-prototypes -Wwrite-strings -finline-limit=2000 -freorder-blocks -march=pentium -mcpu=athlon-tbird -pipe -mpreferred-stack-boundary=2     -I../include -I. -I/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix -I.. -I../libio  -I/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads -I../sysdeps/i386/elf -I../linuxthreads/sysdeps/unix/sysv/linux/i386 -I../linuxthreads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread -I../sysdeps/pthread -I../linuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix -I../linuxthreads/sysdeps/i386/i586 -I../linuxthreads/sysdeps/i386 -I../libidn/sysdeps/unix -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i586 -I../sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -nostdinc -isystem /usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5/include -isystem //usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h   -DNOT_IN_libc=1    -o /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest.o -MD -MP -MF /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest.o.dt -MT /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest.o
i586-pc-linux-gnu-gcc -nostdlib -nostartfiles -o /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest  -Wl,-dynamic-linker=/lib/ld-linux.so.2   -Wl,-z,combreloc -Wl,-z,relro /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/csu/crt1.o /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/csu/crti.o `i586-pc-linux-gnu-gcc --print-file-name=crtbegin.o` /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest.o  -Wl,-rpath-link=/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/math:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/elf:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/dlfcn:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/nss:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/nis:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/rt:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/resolv:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/crypt:/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/linuxthreads /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/libc.so.6 /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/libc_nonshared.a -lgcc -lgcc_eh `i586-pc-linux-gnu-gcc --print-file-name=crtend.o` /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/csu/crtn.o
/bin/sh -e globtest.sh /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/ /var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/elf/ \
         ld-linux.so.2
make[2]: *** [/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/build-default-i586-pc-linux-gnu-linuxthreads/posix/globtest.out] Error 1
make[2]: Leaving directory `/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/posix'
make[1]: *** [posix/tests] Error 2
make[1]: Leaving directory `/var/tmp/portage/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
make: *** [check] Error 2

!!! ERROR: sys-libs/glibc-2.3.4.20041102-r1 failed.
!!! Function src_test, Line 756, Exitcode 2
!!! make check failed :(
!!! If you need support, post the topmost build error, NOT this status message.



Expected Results:  
Successfully complete the test suite und install the package.


Gentoo Base System version 1.4.16
Portage 2.0.51.19 (default-linux/x86/2004.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.10-infra-r2-cube-1 i686)
=================================================================
System uname: 2.6.10-infra-r2-cube-1 i686 AMD Athlon(tm) XP 1700+
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  8 2005, 02:37:46)]
distcc 2.16 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.7.9-r1, 1.4_p6, 1.9.4, 1.6.3, 1.8.5-r3
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium -mcpu=athlon-tbird -O3 -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /usr/vice/etc /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/afs/modload /etc/gconf /etc/make.globals /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium -mcpu=athlon-tbird -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect distlocks fixpackages sandbox sfperms strict test userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.easynet.nl/mirror/gentoo/ http://gentoo.inode.at/ ftp://gentoo.inode.at/source/"
LANG="en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-local--main--1.0"
SYNC="rsync://hybrid.sascha.silbe.org/gentoo-portage"
USE="x86 3dnow S3TC X acl afs alsa apm avi bash-completion berkdb bitmap-fonts blas bzlib cdr crypt curl doc dvd dvdr emboss encode fam flac font-server foomaticdb fortran gdbm gif gimpprint gtk gtk2 gtkhtml guile hbci imagemagick imap imlib ipv6 j-noaim j-nomsn j-noyahoo jabber jpeg kerberos lapack lcms libg++ libwww lvm1 mad maildir makecheck mbox mikmod mmx monitor mozsvg mp3 mpeg mysql nas ncurses nls nodrm offensive oggvorbis opengl oss pam pdflib plotutils png postgres python qt qtmt quicktime readline samba scanner sdl serial skey spell sqlite sse ssl tetex tiff truetype truetype-fonts type1-fonts unicode xml xml2 xv xvid zlib linguas_en,de"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS
Comment 1 Sascha Silbe 2005-03-18 08:23:01 UTC
Created attachment 53792 [details]
posix/globtest.out
Comment 2 Jeremy Huddleston (RETIRED) gentoo-dev 2005-03-18 11:54:20 UTC

*** This bug has been marked as a duplicate of 81636 ***
Comment 3 Sascha Silbe 2005-03-22 11:45:54 UTC
Bug #81636 is about the tst-fopenloc.check test, this one is about the globtest.sh test. Why are they duplicates?